Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 717752 - games-roguelike/dwarf-fortress-0.47.04 version bump
Summary: games-roguelike/dwarf-fortress-0.47.04 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-16 20:17 UTC by Martin Doucha
Modified: 2020-05-28 01:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Diff of ebuilds (df_diff,604 bytes, text/plain)
2020-05-12 23:33 UTC, Rick Foland
Details
Diff of Ebuilds Updated (df44.07.diff,602 bytes, patch)
2020-05-28 01:40 UTC, Rick Foland
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Doucha 2020-04-16 20:17:44 UTC
New version of Dwarf Fortress is out. This release brings epic levels of organized villainy and fixes several game-breaking bugs, for example unit inventory corruption in fortress mode when your squad returns from a raid on another fort, which will crash the game.

Reproducible: Always
Comment 1 Rick Foland 2020-05-12 02:49:42 UTC
Version 47.04 builds fine with the current ebuild, but errors with EAPI 7. Is using EAPI 7 mandatory or can I push this package using 6?
Comment 2 Rick Foland 2020-05-12 02:57:30 UTC
Whoops. I didn't realize this was maintained by the games project. Forget what I said. I'm looking into the failure on EAPI 7 now.
Comment 3 Sam James gentoo-dev Security 2020-05-12 03:18:57 UTC
(In reply to Rick Foland from comment #2)
> Whoops. I didn't realize this was maintained by the games project. Forget
> what I said. I'm looking into the failure on EAPI 7 now.

Any PR would still be gladly welcomed.
Comment 4 Rick Foland 2020-05-12 03:34:10 UTC
Okay, I think I got it. It was using some depreciated functions that it was inheriting from the versionator eclass. I replaced them with the new ones and everything is working with EAPI 7.I made the below changes:

EAPI=7

inherit toolchain-funcs

MY_PV=$(ver_rs 1 _ "$(ver_cut 2-)")
Comment 5 Rick Foland 2020-05-12 23:33:52 UTC
Created attachment 638488 [details]
Diff of ebuilds
Comment 6 Rick Foland 2020-05-28 01:40:27 UTC
Created attachment 642128 [details, diff]
Diff of Ebuilds Updated

The parsing of the version changed up on me today and I fixed it in the ebuild.