Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716208 - sci-chemistry/openbabel-perl-2.4.1 : -- Configuring incomplete, errors occurred!
Summary: sci-chemistry/openbabel-perl-2.4.1 : -- Configuring incomplete, errors occurred!
Status: RESOLVED DUPLICATE of bug 664124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo musl team
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-04-04 17:32 UTC by Toralf Förster
Modified: 2021-04-06 20:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.74 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
CMakeError.log (CMakeError.log,8.99 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
CMakeOutput.log (CMakeOutput.log,76.44 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,290.09 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
environment (environment,129.62 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.07 KB, application/x-bzip)
2020-04-04 17:32 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.06 KB, application/x-bzip)
2020-04-04 17:32 UTC, Toralf Förster
Details
sci-chemistry:openbabel-perl-2.4.1:20200404-171528.log (sci-chemistry:openbabel-perl-2.4.1:20200404-171528.log,9.58 KB, text/plain)
2020-04-04 17:32 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,32.01 KB, application/x-bzip)
2020-04-04 17:32 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-04-04 17:32:02 UTC
Shared          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0

-- Configuring incomplete, errors occurred!
See also /var/tmp/portage/sci-chemistry/openbabel-perl-2.4.1/work/openbabel-perl-2.4.1_build/CMakeFiles/CMakeOutput.log.
See also /var/tmp/portage/sci-chemistry/openbabel-perl-2.4.1/work/openbabel-perl-2.4.1_build/CMakeFiles/CMakeError.log.
 * ERROR: sci-chemistry/openbabel-perl-2.4.1::gentoo failed (configure phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_musl_hardened-20200328-201618

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-gentoo-linux-musl-9.3.0 *
clang version 10.0.0 
Target: x86_64-gentoo-linux-musl
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.42.0 *
Available Java Virtual Machines:
  (none found)


timestamp of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sat Apr  4 16:39:40 UTC 2020
/var/db/repos/musl	Sat Apr  4 03:02:24 UTC 2020

emerge -qpvO sci-chemistry/openbabel-perl
[ebuild  N    ] sci-chemistry/openbabel-perl-2.4.1
Comment 1 Toralf Förster gentoo-dev 2020-04-04 17:32:05 UTC
Created attachment 630034 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-04-04 17:32:07 UTC
Created attachment 630036 [details]
CMakeError.log
Comment 3 Toralf Förster gentoo-dev 2020-04-04 17:32:10 UTC
Created attachment 630038 [details]
CMakeOutput.log
Comment 4 Toralf Förster gentoo-dev 2020-04-04 17:32:13 UTC
Created attachment 630040 [details]
emerge-history.txt
Comment 5 Toralf Förster gentoo-dev 2020-04-04 17:32:16 UTC
Created attachment 630042 [details]
environment
Comment 6 Toralf Förster gentoo-dev 2020-04-04 17:32:19 UTC
Created attachment 630044 [details]
etc.portage.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-04-04 17:32:22 UTC
Created attachment 630046 [details]
logs.tbz2
Comment 8 Toralf Förster gentoo-dev 2020-04-04 17:32:24 UTC
Created attachment 630048 [details]
sci-chemistry:openbabel-perl-2.4.1:20200404-171528.log
Comment 9 Toralf Förster gentoo-dev 2020-04-04 17:32:27 UTC
Created attachment 630050 [details]
temp.tbz2
Comment 10 Attila Tóth 2020-06-03 16:45:46 UTC
CMake Error at cmake/modules/MacroEnsureVersion.cmake:76 (MATH):
  MATH cannot parse the expression: "x86_649*10000 + x86_643*100 + x86_640":
  syntax error, unexpected exp_NUMBER, expecting $end (8).
Call Stack (most recent call first):
  cmake/modules/MacroEnsureVersion.cmake:95 (NORMALIZE_VERSION)
  CMakeLists.txt:248 (macro_ensure_version)

This is because GCC version autodetection fails again, this time with gcc-10.
Related to this bug:
https://bugs.gentoo.org/664124
Comment 11 Toralf Förster gentoo-dev 2021-04-06 20:31:42 UTC

*** This bug has been marked as a duplicate of bug 664124 ***