Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 713966 - sys-apps/ifplugd-0.28-r10 : fails to build with -fno-common or gcc-10
Summary: sys-apps/ifplugd-0.28-r10 : fails to build with -fno-common or gcc-10
Status: RESOLVED DUPLICATE of bug 706746
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-03-22 12:43 UTC by Toralf Förster
Modified: 2020-04-08 07:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.51 KB, text/plain)
2020-03-22 12:43 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,176.24 KB, text/plain)
2020-03-22 12:43 UTC, Toralf Förster
Details
environment (environment,16.92 KB, text/plain)
2020-03-22 12:43 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.98 KB, application/x-bzip)
2020-03-22 12:43 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,8.36 KB, application/x-bzip)
2020-03-22 12:43 UTC, Toralf Förster
Details
sys-apps:ifplugd-0.28-r10:20200322-054944.log (sys-apps:ifplugd-0.28-r10:20200322-054944.log,11.03 KB, text/plain)
2020-03-22 12:43 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,8.07 KB, application/x-bzip)
2020-03-22 12:43 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-03-22 12:43:08 UTC
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -D_REENTRANT -DSYSCONFDIR=\/etc\ -D_GNU_SOURCE -O2 -pipe -march=native -fno-common -falign-functions=32:25:16 -pipe -W -Wall -Wno-unused-parameter -c ifmonitor.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -D_REENTRANT -DSYSCONFDIR=\/etc\ -D_GNU_SOURCE -O2 -pipe -march=native -fno-common -falign-functions=32:25:16 -pipe -W -Wall -Wno-unused-parameter -c nlapi.c
x86_64-pc-linux-gnu-gcc -D_REENTRANT -DSYSCONFDIR=\/etc\ -D_GNU_SOURCE -O2 -pipe -march=native -fno-common -falign-functions=32:25:16 -pipe -W -Wall -Wno-unused-parameter  -Wl,-O1 -Wl,--as-needed -o ifplugd  ifplugd.o interface.o ifmonitor.o nlapi.o -ldaemon 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: interface.o:(.bss+0x0): multiple definition of interface_do_message; ifplugd.o:(.data+0x1c): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: interface.o:(.bss+0x4): multiple definition of interface_auto_up; ifplugd.o:(.data+0x20): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-test-20200310-081612

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Rust versions:
  [1]   rust-1.41.1 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.14.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

timestamp of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun 22 Mar 2020 04:39:13 AM UTC

emerge -qpvO sys-apps/ifplugd
[ebuild  N    ] sys-apps/ifplugd-0.28-r10  USE="-doc (-selinux)"
Comment 1 Toralf Förster gentoo-dev 2020-03-22 12:43:10 UTC
Created attachment 624336 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-03-22 12:43:13 UTC
Created attachment 624338 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-03-22 12:43:15 UTC
Created attachment 624340 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-03-22 12:43:18 UTC
Created attachment 624342 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-03-22 12:43:21 UTC
Created attachment 624344 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-03-22 12:43:24 UTC
Created attachment 624346 [details]
sys-apps:ifplugd-0.28-r10:20200322-054944.log
Comment 7 Toralf Förster gentoo-dev 2020-03-22 12:43:27 UTC
Created attachment 624348 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-04-08 07:22:16 UTC

*** This bug has been marked as a duplicate of bug 706746 ***