Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706746 - sys-apps/ifplugd-0.28-r10 - ld: interface.o:.../work/ifplugd-0.28/src/interface.h:25: multiple definition of `interface_do_message'; ifplugstatus.o:.../work/ifplugd-0.28/src/int
Summary: sys-apps/ifplugd-0.28-r10 - ld: interface.o:.../work/ifplugd-0.28/src/interfa...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: PATCH
: 713966 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-27 19:42 UTC by Jeroen Roovers
Modified: 2020-05-03 20:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-apps:ifplugd-0.28-r10:20200127-193522.log (sys-apps:ifplugd-0.28-r10:20200127-193522.log,13.98 KB, text/x-log)
2020-01-27 19:42 UTC, Jeroen Roovers
Details
ifplugd-0.28-fno-common.patch (ifplugd-0.28-fno-common.patch,337 bytes, patch)
2020-01-27 19:46 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2020-01-27 19:42:31 UTC
Created attachment 605714 [details]
sys-apps:ifplugd-0.28-r10:20200127-193522.log

/usr/lib/gcc/hppa2.0-unknown-linux-gnu/9.2.0/../../../../hppa2.0-unknown-linux-gnu/bin/ld: interface.o:/var/tmp/portage/sys-apps/ifplugd-0.28-r10/work/ifplugd-0.28/src/interface.h:25: multiple definition of `interface_do_message'; ifplugstatus.o:/var/tmp/portage/sys-apps/ifplugd-0.28-r10/work/ifplugd-0.28/src/interface.h:25: first defined here
/usr/lib/gcc/hppa2.0-unknown-linux-gnu/9.2.0/../../../../hppa2.0-unknown-linux-gnu/bin/ld: interface.o:/var/tmp/portage/sys-apps/ifplugd-0.28-r10/work/ifplugd-0.28/src/interface.h:24: multiple definition of `interface_auto_up'; ifplugstatus.o:/var/tmp/portage/sys-apps/ifplugd-0.28-r10/work/ifplugd-0.28/src/interface.h:24: first defined here
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:267: ifplugstatus] Error 1
Comment 1 Jeroen Roovers gentoo-dev 2020-01-27 19:46:48 UTC
Created attachment 605716 [details, diff]
ifplugd-0.28-fno-common.patch
Comment 2 Jeroen Roovers gentoo-dev 2020-04-08 07:22:16 UTC
*** Bug 713966 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2020-05-03 20:20:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9c5cef11f89018c18d3f78657864434f3f232744

commit 9c5cef11f89018c18d3f78657864434f3f232744
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-05-03 20:14:32 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-05-03 20:20:48 +0000

    sys-apps/ifplugd: rev bump
    
    - Bump to EAPI 7
    
    - Fix building against GCC 10
    
    Thanks-to: Jeroen Roovers <jer@gentoo.org>
    Closes: https://bugs.gentoo.org/706746
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 .../ifplugd/files/ifplugd-0.28-gcc10-compatibility.patch    | 13 +++++++++++++
 .../{ifplugd-0.28-r10.ebuild => ifplugd-0.28-r11.ebuild}    |  8 +++++---
 2 files changed, 18 insertions(+), 3 deletions(-)