Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708704 - gui-wm/sway with CFLAGS=-fno-common - ld: sway/345c74e@@sway@exe/config.c.o:/home/portage/gui-wm/sway-1.2/work/sway-1.2-build/../sway-1.2/include/sway/server.h:81: multiple definition of `server'; ...
Summary: gui-wm/sway with CFLAGS=-fno-common - ld: sway/345c74e@@sway@exe/config.c.o:/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aaron Bauman
URL: https://github.com/swaywm/sway/commit...
Whiteboard:
Keywords: PATCH
: 708798 (view as bug list)
Depends on: 707496
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-02-08 11:27 UTC by Jeroen Roovers
Modified: 2020-04-17 17:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2020-02-08 11:27:41 UTC
After fixing bug #707496, you'll see:

ld: sway/345c74e@@sway@exe/config.c.o:/home/portage/gui-wm/sway-1.2/work/sway-1.2-build/../sway-1.2/include/sway/server.h:81: multiple definition of `server'; sway/345c74e@@sway@exe/commands.c.o:/home/portage/gui-wm/sway-1.2/work/sway-1.2-build/../sway-1.2/include/sway/server.h:81: first defined here
[and so on]

This is already fixed upstream but no release is available yet.
Comment 1 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2020-02-08 19:03:16 UTC
ah, you even saw that it was fixed already :D, ya, use git master (9999) if you need -fno-common
Comment 2 Jonas Stein gentoo-dev 2020-04-17 01:46:04 UTC
*** Bug 708798 has been marked as a duplicate of this bug. ***
Comment 3 Sergei Trofimovich gentoo-dev 2020-04-17 06:59:40 UTC
(In reply to Matthew Thode ( prometheanfire ) from comment #1)
> ah, you even saw that it was fixed already :D, ya, use git master (9999) if
> you need -fno-common

The fix is 2-liner. Are you fine with me or someone else to pull patch as-is in to gentoo?
Comment 4 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2020-04-17 14:30:58 UTC
if you wish to make a revbump to do so, feel free.
Comment 5 Larry the Git Cow gentoo-dev 2020-04-17 17:28:22 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2ef12a373c665ba88bcde172454948cfcb57684b

commit 2ef12a373c665ba88bcde172454948cfcb57684b
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-04-17 17:28:03 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-04-17 17:28:16 +0000

    gui-wm/sway: tweak for gcc-10, bug #708704
    
    Apply upstream 29a5ce5 "Fix compiling with -fno-common ".
    
    Reported-by: Jeroen Roovers
    Closes: https://bugs.gentoo.org/708704
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 gui-wm/sway/files/sway-1.4-gcc-10.patch |  42 ++++++++++++
 gui-wm/sway/sway-1.4-r1.ebuild          | 118 ++++++++++++++++++++++++++++++++
 2 files changed, 160 insertions(+)