Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708798 - gui-wm/sway-1.4 : fails to build with -fno-common or gcc-10
Summary: gui-wm/sway-1.4 : fails to build with -fno-common or gcc-10
Status: RESOLVED DUPLICATE of bug 708704
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aaron Bauman
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-02-09 09:41 UTC by Toralf Förster
Modified: 2020-04-17 01:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.66 KB, text/plain)
2020-02-09 09:41 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,211.69 KB, text/plain)
2020-02-09 09:42 UTC, Toralf Förster
Details
environment (environment,93.06 KB, text/plain)
2020-02-09 09:42 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,17.01 KB, application/x-bzip)
2020-02-09 09:42 UTC, Toralf Förster
Details
gui-wm:sway-1.4:20200209-045209.log (gui-wm:sway-1.4:20200209-045209.log,287.73 KB, text/plain)
2020-02-09 09:42 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,227 bytes, application/x-bzip)
2020-02-09 09:42 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,30.45 KB, application/x-bzip)
2020-02-09 09:42 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-02-09 09:41:56 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: sway/345c74e@@sway@exe/config.c.o:(.bss+0x20): multiple definition of `server'; sway/345c74e@@sway@exe/commands.c.o:(.bss+0x20): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: sway/345c74e@@sway@exe/config.c.o:(.bss+0x8): multiple definition of `debug'; sway/345c74e@@sway@exe/commands.c.o:(.bss+0x0): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-test-20200203-215003

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)

Available Rust versions:
  [1]   rust-1.41.0 *
java-config:
The following VMs are available for generation-2:
*)	AdoptOpenJDK JRE 8.242_p08 [openjdk-jre-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-jre-bin-8  system-vm
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Sun, 09 Feb 2020 03:07:11 +0000

emerge -qpvO gui-wm/sway
[ebuild  N    ] gui-wm/sway-1.4  USE="man swaybar swaybg swayidle swaylock swaymsg swaynag -X -elogind -fish-completion -systemd -tray -wallpapers -zsh-completion"
Comment 1 Toralf Förster gentoo-dev 2020-02-09 09:41:59 UTC
Created attachment 612992 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-02-09 09:42:02 UTC
Created attachment 612994 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-02-09 09:42:04 UTC
Created attachment 612996 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-02-09 09:42:07 UTC
Created attachment 612998 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-02-09 09:42:10 UTC
Created attachment 613000 [details]
gui-wm:sway-1.4:20200209-045209.log
Comment 6 Toralf Förster gentoo-dev 2020-02-09 09:42:13 UTC
Created attachment 613002 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-02-09 09:42:15 UTC
Created attachment 613004 [details]
temp.tbz2
Comment 8 Jonas Stein gentoo-dev 2020-04-17 01:46:04 UTC

*** This bug has been marked as a duplicate of bug 708704 ***