Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706756 - media-libs/libv4l-1.16.6 : fails to build with -fno-common or gcc-10
Summary: media-libs/libv4l-1.16.6 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Utkin
URL:
Whiteboard:
Keywords:
: 706130 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-27 20:23 UTC by Toralf Förster
Modified: 2020-03-21 22:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.57 KB, text/plain)
2020-01-27 20:23 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,79.49 KB, text/plain)
2020-01-27 20:23 UTC, Toralf Förster
Details
environment (environment,87.91 KB, text/plain)
2020-01-27 20:23 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.05 KB, application/x-bzip)
2020-01-27 20:23 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,13.13 KB, application/x-bzip)
2020-01-27 20:23 UTC, Toralf Förster
Details
media-libs:libv4l-1.16.6:20200127-184556.log (media-libs:libv4l-1.16.6:20200127-184556.log,163.96 KB, text/plain)
2020-01-27 20:23 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,33.59 KB, application/x-bzip)
2020-01-27 20:23 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-27 20:23:11 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/libdvbv5_la-compat-soname.o .libs/libdvbv5_la-crc32.o .libs/libdvbv5_la-countries.o .libs/libdvbv5_la-dvb-legacy-channel-format.o .libs/libdvbv5_la-dvb-zap-format.o .libs/libdvbv5_la-dvb-vdr-format.o .libs/libdvbv5_la-dvb-v5.o .libs/libdvbv5_la-parse_string.o .libs/libdvbv5_la-dvb-demux.o .libs/libdvbv5_la-dvb-dev.o .libs/libdvbv5_la-dvb-dev-local.o .libs/libdvbv5_la-dvb-fe.o .libs/libdvbv5_la-dvb-log.o .libs/libdvbv5_la-dvb-file.o .libs/libdvbv5_la-dvb-v5-std.o .libs/libdvbv5_la-dvb-sat.o .libs/libdvbv5_la-dvb-scan.o .libs/libdvbv5_la-descriptors.o tables/.libs/libdvbv5_la-header.o tables/.libs/libdvbv5_la-pat.o tables/.libs/libdvbv5_la-pmt.o tables/.libs/libdvbv5_la-nit.o tables/.libs/libdvbv5_la-sdt.o tables/.libs/libdvbv5_la-vct.o tables/.libs/libdvbv5_la-mgt.o tables/.libs/libdvbv5_la-eit.o tables/.libs/libdvbv5_la-cat.o tables/.libs/libdvbv5_la-atsc_eit.o tables/.libs/libdvbv5_la-mpeg_ts.o tables/.libs/libdvbv5_la-mpeg_pes.o tables/.libs/libdvbv5_la-mpeg_es.o descriptors/.libs/libdvbv5_la-desc_language.o descriptors/.libs/libdvbv5_la-desc_network_name.o descriptors/.libs/libdvbv5_la-desc_cable_delivery.o descriptors/.libs/libdvbv5_la-desc_sat.o descriptors/.libs/libdvbv5_la-desc_terrestrial_delivery.o descriptors/.libs/libdvbv5_la-desc_t2_delivery.o descriptors/.libs/libdvbv5_la-desc_service.o descriptors/.libs/libdvbv5_la-desc_frequency_list.o descriptors/.libs/libdvbv5_la-desc_event_short.o descriptors/.libs/libdvbv5_la-desc_event_extended.o descriptors/.libs/libdvbv5_la-desc_atsc_service_location.o descriptors/.libs/libdvbv5_la-desc_hierarchy.o descriptors/.libs/libdvbv5_la-desc_extension.o descriptors/.libs/libdvbv5_la-desc_isdbt_delivery.o descriptors/.libs/libdvbv5_la-desc_logical_channel.o descriptors/.libs/libdvbv5_la-desc_ts_info.o descriptors/.libs/libdvbv5_la-desc_partial_reception.o descriptors/.libs/libdvbv5_la-desc_ca.o descriptors/.libs/libdvbv5_la-desc_ca_identifier.o .libs/libdvbv5_la-dvb-dev-remote.o   -ludev -lm -lrt -Wl,--as-needed  -O2 -march=native -Wl,-O1   -Wl,-soname -Wl,libdvbv5.so.0 -o .libs/libdvbv5.so.0.0.0
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/libdvbv5_la-dvb-fe.o:(.bss+0x0): multiple definition of `delivery_system_name'; .libs/libdvbv5_la-dvb-v5.o:(.data.rel.local+0x280): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/libdvbv5_la-dvb-fe.o:(.bss+0xa0): multiple definition of `dvb_v5_name'; .libs/libdvbv5_la-dvb-v5.o:(.data.rel.local+0x320): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-libressl-20200125-232521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7 (uninstalled)
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.14.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Mon, 27 Jan 2020 17:10:40 +0000

emerge -qpvO media-libs/libv4l
[ebuild  N    ] media-libs/libv4l-1.16.6  USE="jpeg" ABI_X86="(64) -32 (-x32)"
Comment 1 Toralf Förster gentoo-dev 2020-01-27 20:23:14 UTC
Created attachment 605756 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-27 20:23:16 UTC
Created attachment 605758 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-27 20:23:19 UTC
Created attachment 605760 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-27 20:23:22 UTC
Created attachment 605762 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-27 20:23:24 UTC
Created attachment 605764 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-27 20:23:27 UTC
Created attachment 605766 [details]
media-libs:libv4l-1.16.6:20200127-184556.log
Comment 7 Toralf Förster gentoo-dev 2020-01-27 20:23:30 UTC
Created attachment 605768 [details]
temp.tbz2
Comment 8 Larry the Git Cow gentoo-dev 2020-02-25 23:38:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3eb69318e07bd2df74d4ee009e8eb3d8dc6563f6

commit 3eb69318e07bd2df74d4ee009e8eb3d8dc6563f6
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-02-25 23:37:50 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-02-25 23:37:50 +0000

    media-libs/libv4l: Fix GCC 10 / -fno-common
    
    Closes: https://bugs.gentoo.org/706756
    Package-Manager: Portage-2.3.89, Repoman-2.3.20
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../files/libv4l-1.16.6-gcc10-fno-common.patch     | 44 ++++++++++++++++++++++
 media-libs/libv4l/libv4l-1.16.6.ebuild             |  4 +-
 2 files changed, 47 insertions(+), 1 deletion(-)
Comment 9 Larry the Git Cow gentoo-dev 2020-02-26 12:12:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7d29f89250c815ce65f73d6fa2e14662f621a221

commit 7d29f89250c815ce65f73d6fa2e14662f621a221
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-02-26 12:12:17 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-02-26 12:12:17 +0000

    media-libs/libv4l: Use merged patch from upstream
    
    Closes: https://bugs.gentoo.org/706756
    Package-Manager: Portage-2.3.89, Repoman-2.3.20
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../files/libv4l-1.16.6-gcc10-fno-common.patch     | 28 ++++++++++++++++++++--
 1 file changed, 26 insertions(+), 2 deletions(-)
Comment 10 Sergei Trofimovich gentoo-dev 2020-03-21 22:23:39 UTC
*** Bug 706130 has been marked as a duplicate of this bug. ***