Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706130 - media-libs/libv4l-1.16.6 : ld: .libs/libdvbv5_la-dvb-fe.o:(.bs s+0x0): multiple definition of `delivery_system_name'; .libs/libdvbv5_la-dvb-v5.o:(.data.rel.local+0x280): first defined here
Summary: media-libs/libv4l-1.16.6 : ld: .libs/libdvbv5_la-dvb-fe.o:(.bs s+0x0): multip...
Status: RESOLVED DUPLICATE of bug 706756
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Utkin
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-22 22:27 UTC by Anthony Parsons
Modified: 2020-03-21 22:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,254.81 KB, text/x-log)
2020-01-22 22:27 UTC, Anthony Parsons
Details
0001-libdvb5-fix-build-failure-against-gcc-10.patch (0001-libdvb5-fix-build-failure-against-gcc-10.patch,2.79 KB, patch)
2020-01-23 20:13 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Parsons 2020-01-22 22:27:49 UTC
Created attachment 604022 [details]
build log

Here's another -fno-common build failure. Upstream does have releases newer than what's in portage, but they don't seem to have a fix for this yet.
Comment 1 Sergei Trofimovich gentoo-dev 2020-01-23 20:13:05 UTC
Created attachment 604096 [details, diff]
0001-libdvb5-fix-build-failure-against-gcc-10.patch

Also sent the same patch to https://www.spinics.net/lists/linux-media/ . Not sure if it gets through without subscription.
Comment 2 Sergei Trofimovich gentoo-dev 2020-01-23 22:04:52 UTC
(In reply to Sergei Trofimovich from comment #1)
> Created attachment 604096 [details, diff] [details, diff]
> 0001-libdvb5-fix-build-failure-against-gcc-10.patch
> 
> Also sent the same patch to https://www.spinics.net/lists/linux-media/ . Not
> sure if it gets through without subscription.

It did: https://www.spinics.net/lists/linux-media/msg163329.html
Comment 3 Sergei Trofimovich gentoo-dev 2020-03-21 22:23:39 UTC

*** This bug has been marked as a duplicate of bug 706756 ***