Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 706530 - sci-biology/mcl-14.137 : fails to build with -fno-common or gcc-10
Summary: sci-biology/mcl-14.137 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
: 721278 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-26 18:58 UTC by Toralf Förster
Modified: 2020-06-21 13:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.09 KB, text/plain)
2020-01-26 18:58 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,33.66 KB, text/plain)
2020-01-26 18:58 UTC, Toralf Förster
Details
environment (environment,57.74 KB, text/plain)
2020-01-26 18:58 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.42 KB, application/x-bzip)
2020-01-26 18:58 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,8.23 KB, application/x-bzip)
2020-01-26 18:59 UTC, Toralf Förster
Details
sci-biology:mcl-14.137:20200126-184121.log (sci-biology:mcl-14.137:20200126-184121.log,48.37 KB, text/plain)
2020-01-26 18:59 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,18.88 KB, application/x-bzip)
2020-01-26 18:59 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-26 18:58:48 UTC
make[3]: Entering directory '/var/tmp/portage/sci-biology/mcl-14.137/work/mcl-14-137/src/shcl'
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../src -I../..    -O2 -pipe -march=native -fno-common -pthread -c -o clmformat.o clmformat.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../src -I../..    -O2 -pipe -march=native -fno-common -pthread -c -o report.o report.c
x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native -fno-common -pthread -lm -Wl,-O1 -Wl,--as-needed -o clmformat clmformat.o report.o ../mcl/libmcl.a ../clew/libclew.a  ../gryphon/libgryphon.a ../impala/libimpala.a ../../util/libutil.a -lm 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: report.o:(.bss+0x0): multiple definition of `mclx_n_thread_g'; clmformat.o:(.bss+0x8): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: report.o:(.bss+0x8): multiple definition of `nu_magic'; clmformat.o:(.bss+0x10): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-libressl-20200125-183534

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *


llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *



repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Sun, 26 Jan 2020 17:49:34 +0000

emerge -qpvO sci-biology/mcl
[ebuild  N    ] sci-biology/mcl-14.137  USE="blast"
Comment 1 Toralf Förster gentoo-dev 2020-01-26 18:58:50 UTC
Created attachment 604802 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-26 18:58:53 UTC
Created attachment 604804 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-26 18:58:56 UTC
Created attachment 604806 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-26 18:58:59 UTC
Created attachment 604808 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-26 18:59:02 UTC
Created attachment 604810 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-26 18:59:05 UTC
Created attachment 604812 [details]
sci-biology:mcl-14.137:20200126-184121.log
Comment 7 Toralf Förster gentoo-dev 2020-01-26 18:59:08 UTC
Created attachment 604814 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 11:50:13 UTC
*** Bug 721278 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2020-06-21 13:50:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4129eb414e8ac4027b2e7c4b9445aa8075fd8dea

commit 4129eb414e8ac4027b2e7c4b9445aa8075fd8dea
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-06-21 13:49:32 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-06-21 13:49:32 +0000

    sci-biology/mcl: Fix building against GCC 10
    
    Closes: https://bugs.gentoo.org/706530
    Package-Manager: Portage-2.3.101, Repoman-2.3.22
    Signed-off-by: David Seifert <soap@gentoo.org>

 ...ons.patch => mcl-14.137-fix-declarations.patch} | 34 +++++++++++++++++++---
 sci-biology/mcl/mcl-14.137.ebuild                  |  2 +-
 2 files changed, 31 insertions(+), 5 deletions(-)