Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701098 - media-gfx/mypaint-2.0.0-beta0 media-libs/libmypaint-2.0.0-beta0 media-gfx/mypaint-brushes-2.0.1 version bump
Summary: media-gfx/mypaint-2.0.0-beta0 media-libs/libmypaint-2.0.0-beta0 media-gfx/myp...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 704308 (view as bug list)
Depends on:
Blocks: 701104 708500
  Show dependency tree
 
Reported: 2019-11-24 20:56 UTC by crabbed halo ablution
Modified: 2020-02-07 08:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libmypaint-2.0.0_alpha2.patch (libmypaint-2.0.0_alpha2.patch,1.89 KB, patch)
2019-11-24 20:57 UTC, crabbed halo ablution
Details | Diff
libmypaint2-0002-build-with-and-require-gegl-0.4.patch (libmypaint2-0002-build-with-and-require-gegl-0.4.patch,3.96 KB, patch)
2019-11-24 20:59 UTC, crabbed halo ablution
Details | Diff
libmypaint2-0003-set-api-version-for-libmypaint-gegl.patch (libmypaint2-0003-set-api-version-for-libmypaint-gegl.patch,1.37 KB, patch)
2019-11-24 21:00 UTC, crabbed halo ablution
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description crabbed halo ablution 2019-11-24 20:56:34 UTC
The attached ebuild is slotted, so before committing the following ebuild should be set to depend on media-libs/libmypaint:0=

media-gfx/gimp/gimp-2.10.10-r1.ebuild
media-gfx/gimp/gimp-2.10.12.ebuild
media-gfx/mypaint/mypaint-1.2.1-r3.ebuild
media-gfx/gimp/gimp-2.9.8-r1.ebuild
media-gfx/opentoonz/opentoonz-1.3.0-r1.ebuild
media-gfx/gimp/gimp-9999.ebuild
media-gfx/gimp/gimp-2.10.8-r1.ebuild
media-gfx/opentoonz/opentoonz-1.2.1-r1.ebuild
media-gfx/opentoonz/opentoonz-1.3.0.ebuild


Reproducible: Always
Comment 1 crabbed halo ablution 2019-11-24 20:57:54 UTC
Created attachment 597444 [details, diff]
libmypaint-2.0.0_alpha2.patch
Comment 2 crabbed halo ablution 2019-11-24 20:59:24 UTC
Created attachment 597446 [details, diff]
libmypaint2-0002-build-with-and-require-gegl-0.4.patch

Needed for building against gegl-0.4
Comment 3 crabbed halo ablution 2019-11-24 21:00:56 UTC
Created attachment 597448 [details, diff]
libmypaint2-0003-set-api-version-for-libmypaint-gegl.patch

This patch slots libmypaint-gegl
Comment 4 Jeroen Roovers gentoo-dev 2020-02-07 08:40:59 UTC
*** Bug 704308 has been marked as a duplicate of this bug. ***