Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 700318 - media-libs/mlt-6.18.0 - src_prepare(): ERROR: python_fix_shebang: EPYTHON unset (pkg_setup not called?)
Summary: media-libs/mlt-6.18.0 - src_prepare(): ERROR: python_fix_shebang: EPYTHON uns...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 700340 700352 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-17 08:15 UTC by klaus818
Modified: 2019-11-17 12:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klaus818 2019-11-17 08:15:30 UTC
Emerging (1 of 7) media-libs/mlt-6.18.0::gentoo
 * Fetching files in the background.
 * To view fetch progress, run in another terminal:
 * tail -f /var/log/emerge-fetch.log
 * mlt-6.18.0.tar.gz BLAKE2B SHA512 size ;-) ...                         [ ok ]
 * /etc/portage/package.cflags/ltoworkarounds.conf -> media-libs/mlt: *FLAGS-=-flto*
 * FEATURES='assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr'
 * CFLAGS='-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed'
 * CXXFLAGS='-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed'
 * FFLAGS='-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed'
 * FCFLAGS='-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed'
 * F77FLAGS='-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed'
 * LDFLAGS='-Wl,-O1 -Wl,--as-needed'
 * MAKEOPTS='-j12'
 * gcc (Gentoo 9.2.0-r2 p3) 9.2.0
 * Linux airwolf 5.3.11-gentoo #1 SMP PREEMPT Wed Nov 13 08:09:04 CET 2019 x86_64 AMD Ryzen 5 2600X Six-Core Processor AuthenticAMD GNU/Linux
>>> Unpacking source...
>>> Unpacking mlt-6.18.0.tar.gz to /var/tmp/portage/media-libs/mlt-6.18.0/work
>>> Source unpacked in /var/tmp/portage/media-libs/mlt-6.18.0/work
>>> Preparing source in /var/tmp/portage/media-libs/mlt-6.18.0/work/mlt-6.18.0 ...
 * Applying mlt-6.10.0-swig-underlinking.patch ...                       [ ok ]
 * ERROR: media-libs/mlt-6.18.0::gentoo failed (prepare phase):
 *   python_fix_shebang: EPYTHON unset (pkg_setup not called?)
 * 
 * Call stack:
 *     ebuild.sh, line  125:  Called src_prepare
 *   environment, line 3703:  Called python_fix_shebang 'src/swig/python'
 *   environment, line 3004:  Called die
 * The specific snippet of code:
 *       [[ -n ${EPYTHON} ]] || die "${FUNCNAME}: EPYTHON unset (pkg_setup not called?)";
 * 
 * If you need support, post the output of `emerge --info '=media-libs/mlt-6.18.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/mlt-6.18.0::gentoo'`.
 * The complete build log is located at '/var/log/portage/media-libs:mlt-6.18.0:20191117-081105.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/mlt-6.18.0/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/mlt-6.18.0/work/mlt-6.18.0'
 * S: '/var/tmp/portage/media-libs/mlt-6.18.0/work/mlt-6.18.0'


Portage 2.3.79 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-9.2.0, glibc-2.30-r2, 5.3.11-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.3.11-gentoo-x86_64-AMD_Ryzen_5_2600X_Six-Core_Processor-with-gentoo-2.6
KiB Mem:    16419832 total,   9834412 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Sun, 17 Nov 2019 07:30:01 +0000
Head commit of repository gentoo: f01d879a1dd92494a5febb83cc482baa334aafed
sh bash 5.0_p11
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.9-r1::lto-overlay
dev-util/cmake:           3.15.5::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.3-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

tvbrowser-bin
    location: /usr/local/portage
    masters: gentoo

kde
    location: /var/lib/layman/kde
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/proj/kde.git
    masters: gentoo
    priority: 50

lto-overlay
    location: /var/lib/layman/lto-overlay
    sync-type: laymansync
    sync-uri: https://github.com/InBetweenNames/gentooLTO.git
    masters: gentoo mv
    priority: 50

mv
    location: /var/lib/layman/mv
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/user/mv.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2  -fuse-linker-plugin -pipe -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2  -fuse-linker-plugin -pipe -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.netcologne.de/gentoo/ http://ftp.free.fr/mirrors/ftp.gentoo.org/ https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ https://ftp.halifax.rwth-aachen.de/gentoo/ http://gentoo.mirror.web4u.cz/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="7zip X a52 aac acl acpi activities alsa amd64 berkdb branding bzip2 cairo cdda cdr cli crypt cups cxx dav1d dbus declarative dns-over-tls dri dropbox dts dvd dvdr emboss encode epub exif fam ffmpeg flac fortran gdbm gif gpm grub gtk iconv icu ipv6 ithreads jpeg jumbo-build kde kipi kwallet lcms ldap libnotify libtirpc lightning lm-sensors lto mad matroska mng mp3 mp4 mpeg mtp multilib ncurses nls nptl offload ogg opencl opengl openmp pam pango pcre pdf pgo phonon pim plasma png policykit postproc ppds pulseaudio qml qt5 rar readline scanner sdl seccomp semantic-desktop spell split-usr ssl startup-notification svg sync-plugin-portage system-llvm systemd tcpd threads tiff truetype udev udisks unicode upower usb vaapi vc vdpau vorbis vpx vulkan wayland webp widgets wxwidgets x264 x265 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="sony_dscf1" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="AMDGPU" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/mlt-6.16.0-r2::gentoo was built with the following:
USE="ffmpeg fftw frei0r gtk kdenlive melt opengl qt5 sdl xml -compressed-lumas -debug -jack -libav -libsamplerate -lua -opencv -python -rtaudio -ruby (-vdpau) -vidstab -xine" ABI_X86="(64)" CPU_FLAGS_X86="mmx sse sse2" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_7" PYTHON_TARGETS="python2_7 python3_6 -python3_7"
CFLAGS="-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed"
CXXFLAGS="-march=native -O2 -fuse-linker-plugin -pipe -ftree-vectorize -Wl,-O1 -Wl,--as-needed"
Comment 1 Jeroen Roovers gentoo-dev 2019-11-17 10:43:28 UTC
*** Bug 700340 has been marked as a duplicate of this bug. ***
Comment 2 Jeroen Roovers gentoo-dev 2019-11-17 10:43:57 UTC
he bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=864613c0f925cf31a09490630273e0781eba7103

commit 864613c0f925cf31a09490630273e0781eba7103
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-11-17 10:37:48 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-11-17 10:38:49 +0000

    media-libs/mlt: Conditionalise python_fix_shebang
    
    Closes: https://bugs.gentoo.org/700340
    Package-Manager: Portage-2.3.79, Repoman-2.3.18
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 media-libs/mlt/mlt-6.18.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 3 Andreas Sturmlechner gentoo-dev 2019-11-17 12:00:35 UTC
*** Bug 700352 has been marked as a duplicate of this bug. ***