Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699668 - net-fs/samba-4.11.2: lib/replace/system/network.h:91:10: fatal error: stropts.h: No such file or directory
Summary: net-fs/samba-4.11.2: lib/replace/system/network.h:91:10: fatal error: stropts...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords: PATCH
: 708354 (view as bug list)
Depends on:
Blocks: glibc-2.30 CVE-2019-10197 glibc-2.30-stable
  Show dependency tree
 
Reported: 2019-11-09 15:36 UTC by Guy
Modified: 2020-04-06 00:59 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guy 2019-11-09 15:36:27 UTC
samba-4.11.2 fails. Since 'network.h' belongs to kernel sources, I tried regressing to different kernels. Since the apparent involvement of 'krb5', I also re-emerge app-crypt/mit-krb5 then emerging net-fs/samba-4.11.2. Still failed.

I currently have net-fs/samba-4.11.2 masked.

Fails here:

[1609/2797] Compiling bin/default/librpc/gen_ndr/ndr_winspool_c.c
10:09:47 runner ['x86_64-pc-linux-gnu-gcc', '-D_SAMBA_BUILD_=4', '-DHAVE_CONFIG_H=1', '-march=bdver3', '-O2', '-pipe', '-MMD', '-D_GNU_SOURCE=1', '-D_XOPEN_SOURCE_EXTENDED=1', '-DHAVE_CONFIG_H=1', '-fPIC', '-D__STDC_WANT_LIB_EXT1__=1', '-D_REENTRANT', '-fstack-protector-strong', '-fstack-clash-protection', '-DSTATIC_RPC_NDR_WINSPOOL_MODULES=NULL', '-DSTATIC_RPC_NDR_WINSPOOL_MODULES_PROTO=extern void __RPC_NDR_WINSPOOL_dummy_module_proto(void)', '-Ilibrpc', '-I../../librpc', '-Iinclude/public', '-I../../include/public', '-Isource4', '-I../../source4', '-Ilib', '-I../../lib', '-Isource4/lib', '-I../../source4/lib', '-Isource4/include', '-I../../source4/include', '-Iinclude', '-I../../include', '-Ilib/replace', '-I../../lib/replace', '-I.', '-I../..', '-Isource4/libcli', '-I../../source4/libcli', '-Ilibcli/ldap', '-I../../libcli/ldap', '-Ilibds/common', '-I../../libds/common', '-Isource4/auth/kerberos', '-I../../source4/auth/kerberos', '-Insswitch/libwbclient', '-I../../nsswitch/libwbclient', '-Ilib/ldb-samba', '-I../../lib/ldb-samba', '-Iauth/credentials', '-I../../auth/credentials', '-Ilib/util/var/tmp/portage/net-fs/samba-4.11.2/work/samba-4.11.2-abi_x86_64.amd64/third_party/gpfs', '-I../../lib/util/var/tmp/portage/net-fs/samba-4.11.2/work/samba-4.11.2-abi_x86_64.amd64/third_party/gpfs', '-Ilibcli/auth', '-I../../libcli/auth', '-Iauth', '-I../../auth', '-Ilibcli/util', '-I../../libcli/util', '-Ilib/compression', '-I../../lib/compression', '-Isource4/dsdb', '-I../../source4/dsdb', '-Isource4/auth', '-I../../source4/auth', '-Isource4/auth/gensec', '-I../../source4/auth/gensec', '-Insswitch', '-I../../nsswitch', '-Iauth/gensec', '-I../../auth/gensec', '-Ilib/tsocket', '-I../../lib/tsocket', '-Ilib/audit_logging', '-I../../lib/audit_logging', '-Iauth/ntlmssp', '-I../../auth/ntlmssp', '-Ilibcli/security', '-I../../libcli/security', '-Isource4/lib/socket', '-I../../source4/lib/socket', '-Ilib/util/charset', '-I../../lib/util/charset', '-Ilib/dbwrap', '-I../../lib/dbwrap', '-Ilibcli/lsarpc', '-I../../libcli/lsarpc', '-Isource3', '-I../../source3', '-Isource3/include', '-I../../source3/include', '-Isource3/lib', '-I../../source3/lib', '-Isource4/lib/http', '-I../../source4/lib/http', '-Isource4/param', '-I../../source4/param', '-Isource4/lib/stream', '-I../../source4/lib/stream', '-Ilib/pthreadpool', '-I../../lib/pthreadpool', '-Iauth/kerberos', '-I../../auth/kerberos', '-Ilib/param', '-I../../lib/param', '-Isource4/lib/messaging', '-I../../source4/lib/messaging', '-Idynconfig', '-I../../dynconfig', '-Ilib/crypto', '-I../../lib/crypto', '-Isource4/cluster', '-I../../source4/cluster', '-Ilibcli/nbt', '-I../../libcli/nbt', '-Ilib/socket', '-I../../lib/socket', '-Isource4/lib/tls', '-I../../source4/lib/tls', '-Ilib/krb5_wrap', '-I../../lib/krb5_wrap', '-Isource4/lib/events', '-I../../source4/lib/events', '-Isource3/librpc', '-I../../source3/librpc', '-Ilibcli/drsuapi', '-I../../libcli/drsuapi', 'librpc/gen_ndr/ndr_winspool_c.c', '-c', '-o/var/tmp/portage/net-fs/samba-4.11.2/work/samba-4.11.2-abi_x86_64.amd64/bin/default/librpc/gen_ndr/ndr_winspool_c.c.158.o', '-I/usr/include/et']
In file included from ../../lib/krb5_wrap/krb5_samba.h:42,
                 from ../../source4/auth/kerberos/kerberos.h:29,
                 from ../../auth/credentials/pycredentials.c:36:
../../lib/replace/system/network.h:91:10: fatal error: stropts.h: No such file or directory
   91 | #include <stropts.h>
      |          ^~~~~~~~~~~
compilation terminated


Portage 2.3.78 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-9.2.0, glibc-2.30-r2, 5.3.7-gentoo x86_64)
=================================================================
System uname: Linux-5.3.7-gentoo-x86_64-AMD_A10-7850K_Radeon_R7,_12_Compute_Cores_4C+8G-with-gentoo-2.6
KiB Mem:    31855540 total,  16986932 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 09 Nov 2019 04:30:01 +0000
Head commit of repository gentoo: 0d34ca58f09f73f1b2c30f0c9495bf95d3878a29
sh bash 5.0_p11
ld GNU ld (Gentoo 2.32 p2) 2.32.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 3.7.5 [disabled]
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo, 3.7.5-r1::gentoo
dev-util/ccache:          3.7.5::gentoo
dev-util/cmake:           3.15.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r2::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.3-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: --timeout=15
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

brother-overlay
    location: /var/lib/layman/brother-overlay
    masters: gentoo
    priority: 50

printer-drivers
    location: /var/lib/layman/printer-drivers
    masters: gentoo
    priority: 50

vapoursynth
    location: /var/lib/layman/vapoursynth
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=bdver3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/apache2-php7.3/ext-active/ /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=bdver3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build --with-bdeps=y --keep-going"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_BINHOST="/usr/local/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=15"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="10bit 3dnow 3dnowext X a52 aac aalib accessibility acl acpi activities aio alsa amd64 amr anthy ao apache2 audiofile automount avahi berkdb bluray bonjour boost branding bzip2 cairo cdda cdio cdr chm cjk cli consolekit cracklib crypt css cups curl curlwrappers cxx dbus declarative dga dia directfb dri dts dv dvd dvdr dynamic emboss encode exif expat fam fat fbcon ffmpeg fftw flac flash fontconfig foomaticdb fortran ftp gcj gd gdbm gif gimp glib gmp gnutls gpac gphoto2 gpm graphviz gs gstreamer gtk hddtemp hdri ibus iconv icu id3tag imagemagick imlib immqt-bc inotify ipfilter ipv6 irc java javascript jbig jpeg kde kerberos kipi kwallet lame lcms libnotify libtirpc libvisual lm_sensors lzo m17n-lib mad midi mikmod mjpeg mmap mmx mmxext mng modules mono mp3 mp4 mpeg mpi multilib multiuser musepack mysql nas ncurses network nls nptl nsplugin ntfs odbc offensive ogg openexr opengl openmp oscar pam pango pcre pdf perl phonon plasma plugins png policykit postscript ppds pulseaudio python q32 qml qt5 quicktime rar raw rdesktop readline recode regex reiser4 reiserfs rle rss ruby samba sasl scanner schroedinger scim sdk sdl seccomp sensord session sftp sndfile snmp sox speex spell split-usr sqlite sse sse2 ssl startup-notification subversion svg syslog taglib tcl tcpd theora threads tidy tiff timidity tk toolbar tools transcode truetype udev udisks unicode upower usb utils vaapi vala vdpau vdr vorbis wavpack webkit widgets winbind wmf wxwidgets x264 xattr xcb xcomposite xft xine xinerama xml xorg xosd xpm xscreensaver xv xvid yahoo zeroconf zip zlib" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_core authz_core authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon minolta konica" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US" LLVM_TARGETS="AMDGPU X86" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby24 ruby25 ruby26" SANE_BACKENDS="bh xerox_mfp" USERLAND="GNU" VIDEO_CARDS="radeon radeonsi"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Erik Wallin 2019-11-10 17:25:40 UTC
I installed samba-4.11.2 today and it builds without problems.

Could it be because you have set ACCEPT_KEYWORDS="amd64 ~amd64"?

I would imagine that this will bring in a lot of packages that are not yet stable.

I unmasked the latest samba by adding ~amd64 on samba and the dependencies that needed it.

/etc/portage/package.keywords:
# Needed to run the latest samba
=net-fs/samba-4.11.2 ~amd64
=sys-libs/talloc-2.3.0 ~amd64
=sys-libs/tevent-0.10.1 ~amd64
=sys-libs/ldb-2.0.7 ~amd64
=sys-libs/tdb-1.4.2 ~amd64

That is on a fairly clean install. Only added the usual syslog-ng, crony etc.

My only use flags are
USE="ldap samba"

I would look for the problem elsewhere than the samba package given your ACCEPT_KEYWORDS settings.

To stabilize samba-4.11.2 we need to stabilize the above four dependencies. I'm not aware of any run time issues so that needs to be verified as well.

Perhaps I'm totally misunderstanding this. Are you trying to test samba against all bleeding edge packages? Is that really possible? Wouldn't the right way be to stabilize each package against the current stable set and any necessary dependencies that are not yet stable?
Comment 2 Attila Tóth 2019-11-12 22:59:26 UTC
It's about newer glibc-2.30+ got some stuff removed. Samba unnecessary looks for it:
https://bugzilla.samba.org/show_bug.cgi?id=14100
A solution could be to rebuild python used after glibc update or use the patch attached to the bug.
Comment 3 Russell Dwiggins 2019-11-19 23:31:06 UTC
Rebuilding python did not help in my case. The patch mentioned in Comment 2 did work.
Comment 4 Attila Tóth 2019-11-19 23:52:42 UTC
(In reply to Russell Dwiggins from comment #3)
> Rebuilding python did not help in my case. The patch mentioned in Comment 2
> did work.

Culprit glibc commit:
https://github.com/bminor/glibc/commit/a0a0dc83173ce11ff45105fd32e5d14356cdfb9c

When mentioning python rebuild, I referred to this bug:
https://bugzilla.samba.org/show_bug.cgi?id=14100
- take a look at on comment 6
According to that pyconfig.h is generated compile-time. Each python version has it's own pyconfig.h. So it does matter what version of python is used and which version you've rebuilt.

The current situation on my system:
$ locate pyconfig.h
/usr/include/python2.7/pyconfig.h
/usr/include/python3.5m/pyconfig.h
/usr/include/python3.6m/pyconfig.h
/usr/include/python3.7m/pyconfig.h
/usr/include/python3.8/pyconfig.h
$ cat /usr/include/python2.7/pyconfig.h | grep STROPTS
/* #undef HAVE_STROPTS_H */
$ cat /usr/include/python3.5m/pyconfig.h | grep STROPTS
/* #undef HAVE_STROPTS_H */
$ cat /usr/include/python3.6m/pyconfig.h | grep STROPTS
#define HAVE_STROPTS_H 1
$ cat /usr/include/python3.7m/pyconfig.h | grep STROPTS
#define HAVE_STROPTS_H 1
$ cat /usr/include/python3.8/pyconfig.h | grep STROPTS
/* #undef HAVE_STROPTS_H */

So in my case this issue would be triggered while using 3.6 or 3.7. Either I should use the patch for these or I must rebuild and make sure STROPTS_H is not defined in pyconfig.h.
Comment 5 Andreas Sturmlechner gentoo-dev 2019-11-21 00:41:56 UTC
(In reply to Attila Tóth from comment #4)
> When mentioning python rebuild, I referred to this bug:
> https://bugzilla.samba.org/show_bug.cgi?id=14100
> - take a look at on comment 6

I can confirm this fixed the build issue.
Comment 6 Guy 2019-11-29 19:12:30 UTC
(In reply to Attila Tóth from comment #2)

> A solution could be to rebuild python used after glibc update or use the
> patch attached to the bug.

sys-libs/glibc
   Installed versions:  2.30-r3(2.2)^t{tbz2}(07:18:24 PM 11/28/2019)

Workaround: (after new version of glibc is installed)

   emerge =dev-lang/python-3.6.9 =dev-lang/python-3.7.5-r1 && emerge -v =net-fs/samba-4.11.2

Works here.
Comment 7 André Terpstra 2019-12-05 16:32:33 UTC
(In reply to Guy from comment #6)
> (In reply to Attila Tóth from comment #2)
> 
> > A solution could be to rebuild python used after glibc update or use the
> > patch attached to the bug.
> 
> sys-libs/glibc
>    Installed versions:  2.30-r3(2.2)^t{tbz2}(07:18:24 PM 11/28/2019)
> 
> Workaround: (after new version of glibc is installed)
> 
>    emerge =dev-lang/python-3.6.9 =dev-lang/python-3.7.5-r1 && emerge -v
> =net-fs/samba-4.11.2
> 
> Works here.

Here too!
Comment 8 Konstantin Sobolev 2019-12-12 06:48:48 UTC
getting the same problem with samba-4.8.6-r2. Comment #6 doesn't help, patch from comment #2 does.
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2020-02-05 18:05:32 UTC
*** Bug 708354 has been marked as a duplicate of this bug. ***
Comment 10 Ben Kohler gentoo-dev 2020-02-27 16:17:50 UTC
I was unable to reproduce the failure.  This is what I tried:

1) unpack latest amd64 stage3
2) update it via "emerge -uDNav @world"
3) add sys-libs/glibc to package.accept_keywords and emerge -1 glibc to get 2.30-r4
4) emerge samba

This is not a regression in 4.11 is it? You say it still fails on 4.8
Comment 11 Ian Kumlien 2020-02-27 16:40:20 UTC
4.11.6-r2 failed for me earlier today - I have manually patched this for a long time.

I can't see how this worked for you without the patch.
Comment 12 Ian Kumlien 2020-02-27 16:48:01 UTC
This is what I have on that machine, and the samba evuild is patched so it actually compiles...


Calculating dependencies... done!
[ebuild   R   ~] sys-libs/glibc-2.30-r4:2.2::gentoo  USE="caps (crypt) gd multiarch (multilib) nscd ssp (static-libs) -audit (-cet) -compile-locales -custom-cflags -doc -headers-only -profile (-selinux) -suid -systemtap -test (-vanilla)" 0 KiB
[ebuild   R    ] net-fs/samba-4.11.6-r2::local  USE="acl client cups ldap pam python system-mitkrb5 systemd winbind zeroconf -addc -addns -ads -ceph -cluster -debug (-dmapi) (-fam) -gpg -iprint -json -profiling-data -quota (-selinux) -syslog (-system-heimdal) -test" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_6 -python3_7 -python3_8" 0 KiB
Comment 13 Ben Kohler gentoo-dev 2020-02-27 17:23:08 UTC
Ok my mistake, I am able to reproduce it once I turn on USE=python (side question, are you actually using python support on this, or you just like global USE=python?)

However, after "emerge -1av $(qlist -ICS dev-lang/python)" to rebuild all installed pythons, samba does again build fine, with python support on.
Comment 14 Andreas K. Hüttel gentoo-dev 2020-03-15 16:34:32 UTC
(In reply to Ben Kohler from comment #13)
> Ok my mistake, I am able to reproduce it once I turn on USE=python (side
> question, are you actually using python support on this, or you just like
> global USE=python?)
> 
> However, after "emerge -1av $(qlist -ICS dev-lang/python)" to rebuild all
> installed pythons, samba does again build fine, with python support on.

Ugh. CC'ing python team for advice.
Comment 15 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-03-15 17:02:39 UTC
(In reply to Andreas K. Hüttel from comment #14)
> (In reply to Ben Kohler from comment #13)
> > Ok my mistake, I am able to reproduce it once I turn on USE=python (side
> > question, are you actually using python support on this, or you just like
> > global USE=python?)
> > 
> > However, after "emerge -1av $(qlist -ICS dev-lang/python)" to rebuild all
> > installed pythons, samba does again build fine, with python support on.
> 
> Ugh. CC'ing python team for advice.

I don't see any good solution here.
Comment 16 Larry the Git Cow gentoo-dev 2020-03-15 17:26:37 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7bc3d2f5403cedd036d85ef2740b0fa3931271d6

commit 7bc3d2f5403cedd036d85ef2740b0fa3931271d6
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2020-03-15 17:18:58 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2020-03-15 17:24:03 +0000

    dev-lang/python: Force-fail stropts.h check for future glibc upgrade
    
    Bug: https://bugs.gentoo.org/699668
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 dev-lang/python/python-2.7.17-r1.ebuild    | 4 ++++
 dev-lang/python/python-3.6.10.ebuild       | 6 ++++++
 dev-lang/python/python-3.7.7.ebuild        | 5 +++++
 dev-lang/python/python-3.8.2.ebuild        | 5 +++++
 dev-lang/python/python-3.9.0_alpha4.ebuild | 5 +++++
 5 files changed, 25 insertions(+)
Comment 17 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-03-15 17:32:32 UTC
That's the best I was able to come up with.  It won't help people who upgraded glibc already but it gives a good chance that future users who upgrade python before glibc will not hit the issue.

I haven't revbumped since I don't believe this is a major enough issue.  I suspect that before new glibc goes stable, we'll see new Python versions that will take care of provoking an upgrade.  If not, feel free to ping me to revbump before stabilizing new glibc.
Comment 18 Andreas K. Hüttel gentoo-dev 2020-04-03 20:54:22 UTC
> I haven't revbumped since I don't believe this is a major enough issue.  I
> suspect that before new glibc goes stable, we'll see new Python versions
> that will take care of provoking an upgrade.  If not, feel free to ping me
> to revbump before stabilizing new glibc.

Pretty please, now would be a good time for the revbumps.
Comment 19 Larry the Git Cow gentoo-dev 2020-04-03 21:23:26 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=49286b0470eb48505e6ec7890e7d67d73708371c

commit 49286b0470eb48505e6ec7890e7d67d73708371c
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2020-04-03 21:22:41 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-04-03 21:22:41 +0000

    dev-lang/python: revbumps for stropts.h removal
    
    Bug: https://bugs.gentoo.org/699668
    Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 dev-lang/python/{python-2.7.17-r1.ebuild => python-2.7.17-r2.ebuild}      | 0
 dev-lang/python/{python-3.6.10.ebuild => python-3.6.10-r1.ebuild}         | 0
 dev-lang/python/{python-3.7.7.ebuild => python-3.7.7-r1.ebuild}           | 0
 dev-lang/python/{python-3.8.2.ebuild => python-3.8.2-r1.ebuild}           | 0
 .../python/{python-3.9.0_alpha5.ebuild => python-3.9.0_alpha5-r1.ebuild}  | 0
 5 files changed, 0 insertions(+), 0 deletions(-)
Comment 20 Larry the Git Cow gentoo-dev 2020-04-03 21:26:41 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b7f3a7ae3e12a6e4202b50396f470d0bae7eb394

commit b7f3a7ae3e12a6e4202b50396f470d0bae7eb394
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2020-04-03 21:26:30 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-04-03 21:26:30 +0000

    dev-lang/python: revert unnecessary 3.9.0_alpha5 revbump
    
    Bug: https://bugs.gentoo.org/699668
    Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 .../python/{python-3.9.0_alpha5-r1.ebuild => python-3.9.0_alpha5.ebuild}  | 0
 1 file changed, 0 insertions(+), 0 deletions(-)