Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708354 - net-fs/samba 4.11 needs a patch to build against newer glibc - ?
Summary: net-fs/samba 4.11 needs a patch to build against newer glibc - ?
Status: RESOLVED DUPLICATE of bug 699668
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-05 15:15 UTC by Ian Kumlien
Modified: 2020-02-05 20:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Kumlien 2020-02-05 15:15:09 UTC
stropts has been removed from newer versions of glibc, causing samba to not build.

this fixes it:
--- a/lib/replace/system/network.h      2019-01-15 21:07:00.000000000 +1100
+++ b/lib/replace/system/network.h.new  2019-08-27 23:28:56.106742843 +1000
@@ -87,10 +87,6 @@
 #include <sys/uio.h>
 #endif
 
-#ifdef HAVE_STROPTS_H
-#include <stropts.h>
-#endif
-
 #ifndef HAVE_SOCKLEN_T
 #define HAVE_SOCKLEN_T
 typedef int socklen_t;
---

Reproducible: Always

Steps to Reproduce:
1. emerge samba
2. wait
3. watch it break
Actual Results:  
broken build due to missing stropts

Expected Results:  
Finished build

The bug has been reported to samba a long time ago - the report is getting no attention
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2020-02-05 15:30:07 UTC
Please attach a failed bulid.log to show evidence.

FWIW, it builds fine for me with samba 4.11.6 and glibc 2.30 and no stropts.h exists on my system.
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2020-02-05 16:07:45 UTC
Possible duplicate of bug 699668

Easy to verify with:

$ grep -i stropts /usr/include/python*/pyconfig.h
/usr/include/python2.7/pyconfig.h:/* Define to 1 if you have the <stropts.h> header file. */
/usr/include/python2.7/pyconfig.h:/* #undef HAVE_STROPTS_H */
/usr/include/python3.6m/pyconfig.h:/* Define to 1 if you have the <stropts.h> header file. */
/usr/include/python3.6m/pyconfig.h:/* #undef HAVE_STROPTS_H */
/usr/include/python3.7m/pyconfig.h:/* Define to 1 if you have the <stropts.h> header file. */
/usr/include/python3.7m/pyconfig.h:/* #undef HAVE_STROPTS_H */
/usr/include/python3.8/pyconfig.h:/* Define to 1 if you have the <stropts.h> header file. */
/usr/include/python3.8/pyconfig.h:/* #undef HAVE_STROPTS_H */

All should have "#undef HAVE_STROPTS_H"
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2020-02-05 18:05:32 UTC

*** This bug has been marked as a duplicate of bug 699668 ***