Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 691828 - dev-tex/xcolor-2.12-r1[doc] with dev-tex/pgf-3.1.4 fails to build documentation
Summary: dev-tex/xcolor-2.12-r1[doc] with dev-tex/pgf-3.1.4 fails to build documentation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: PATCH
: 692828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-09 13:50 UTC by David Fellows
Modified: 2019-11-04 16:36 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (dev-tex:xcolor-2.12-r1:20190809-115541.log,38.86 KB, text/x-log)
2019-08-09 13:55 UTC, David Fellows
Details
xcolor2.log with tex output (xcolor2.log,4.22 KB, text/x-log)
2019-08-09 14:34 UTC, David Fellows
Details
texlive-pstricks-2017-pgf-3.1.4-compat.patch (texlive-pstricks-2017-pgf-3.1.4-compat.patch,1.50 KB, patch)
2019-08-20 15:19 UTC, Alexander Miller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Fellows 2019-08-09 13:50:43 UTC
With USE=doc  emerging xcolor-2.12-r1 fails with the following errors logged:

(/usr/share/texmf-site/tex/generic/pgf/utilities/pgffor.code.tex
Runaway argument?
] {pgffor.code.tex} 
! Paragraph ended before \ProvidesPackageRCS@i was complete.
<to be read again> 
                   \par 
l.11 
     
!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on xcolor2.log.
 * pdflatex failed, trying texi2dvi
/usr/bin/texi2dvi: latex exited with bad status, quitting.


Reproducible: Always




The error first occurred during my regular @world update. 
(I have USE=doc enabled globally.(And I am used to sorting out the resulting issues.))
To complete the update I did 
USE=-doc emerge -u1 xcolor
Which succeeded.
I then tried to install the documentation with
emerge -1 --changed-use xcolor.
which failed. This failure is documented in the attached logs, etc. 

emerge --info '=dev-tex/xcolor-2.12-r1::gentoo'
Portage 2.3.69 (python 3.6.5-final-0, default/linux/amd64/17.1/desktop, gcc-8.3.0, glibc-2.29-r2, 4.14.83-gentoo-f1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.83-gentoo-f1-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.6
KiB Mem:     8083432 total,   1685268 free
KiB Swap:    2097148 total,   2077692 free
Timestamp of repository gentoo: Fri, 09 Aug 2019 10:00:01 +0000
Head commit of repository gentoo: 5cb28923bf36cb28c9722fa77c252793b81a84bd
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://mirror.the-best-hosting.net http://gentoo.osuosl.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus doc dri dts dvd dvdr emboss encode exif fam flac fontconfig fortran gcj gdbm gif glamor gpm gtk guile iconv icu ipv6 java jpeg kpathsea lcms libnotify libtirpc mad mmx mng mp3 mp4 mpeg multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp spell split-usr sse sse2 ssl startup-notification svg tcltk tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="konica minolta ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-tex/xcolor-2.12-r1::gentoo was built with the following:
USE="-doc" ABI_X86="(64)"
Comment 1 David Fellows 2019-08-09 13:55:24 UTC
Created attachment 586294 [details]
build log
Comment 2 David Fellows 2019-08-09 14:34:24 UTC
Created attachment 586298 [details]
xcolor2.log  with tex output
Comment 3 David Fellows 2019-08-09 14:36:03 UTC
emerge -pqv '=dev-tex/xcolor-2.12-r1::gentoo'
[ebuild   R   ] dev-tex/xcolor-2.12-r1  USE="doc*"
Comment 4 David Fellows 2019-08-09 14:38:49 UTC
This is probably related to bug #691408, but it occurs with the version of pgf that fixed that bug.
Comment 5 Ervin Peters 2019-08-10 05:42:32 UTC
confirmed

tried with pgf-3.1.4 and pgf-3.1.4b (~).

found:
https://tex.stackexchange.com/questions/469005/pstricks-newly-introduced-error-in-package

and others looking for pgffor.code.tex

migh be a minor 'API change' which is not recognized by every package who uses it.

ervin
Comment 6 Pavel Goran 2019-08-13 15:52:20 UTC
I encountered the same error: dev-tex/xcolor[doc] fails to build, while using dev-tex/pgf-3.1.4 .
Comment 7 Petr Zima 2019-08-20 00:16:30 UTC
I have experienced the same problem, but it was with the old dev-texlive/texlive-pstricks-2017. With the new 2019 version it builds ok. Just be careful that pstricks get upgraded _before_ xcolor.
Comment 8 Alexander Miller 2019-08-20 15:19:33 UTC
Created attachment 587632 [details, diff]
texlive-pstricks-2017-pgf-3.1.4-compat.patch

So with the update of pgf, dev-texlive/texlive-pstricks-2017 is broken and needs to be fixed. I've created a patch for it (based on the code in texlive-pstricks-2019).
Comment 9 Jonas Stein gentoo-dev 2019-08-25 19:20:30 UTC
*** Bug 692828 has been marked as a duplicate of this bug. ***
Comment 10 Jonas Stein gentoo-dev 2019-08-25 19:23:27 UTC
We are going to tree clean the package as discussed in 
https://bugs.gentoo.org/692828#c1
https://bugs.gentoo.org/692828#c2

We will use xcolor from texlive from now on.

Do we need the patch for the remaining xcolor in texlive too?
Comment 11 Alexander Miller 2019-08-26 20:02:08 UTC
There's nothing wrong with xcolor.

It is dev-texlive/texlive-pstricks-2017 which is broken with the current pgf packages. Any document trying to use pstricks will fail, and xcolor just happens to use pstricks for one of its docs---it shouldn't matter which xcolor version you use.

So you need to patch texlive-pstricks-2017 in any case (or stabilize texlive 2019 and remove 2017). It's simply unusable right now.
Comment 12 Cyp 2019-09-05 08:54:41 UTC
Thanks, after saving the patch in Comment 8 as /etc/portage/patches/dev-texlive/texlive-pstricks-2017/texlive-pstricks-2017-pgf-3.1.4-compat.patch and reemerging dev-texlive/texlive-pstricks, I could update dev-tex/xcolor successfully.
Comment 13 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-11-04 10:20:22 UTC
(In reply to Jonas Stein from comment #10)
> We are going to tree clean the package as discussed in 
> https://bugs.gentoo.org/692828#c1
> https://bugs.gentoo.org/692828#c2
> 
> We will use xcolor from texlive from now on.
> 
> Do we need the patch for the remaining xcolor in texlive too?

going to move xcolor to latexrecommended as was discussed (tarrbals should be mirrored soon)
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-11-04 12:28:40 UTC
tl-2019 has veen stabilized, and I have incorporated xcolor into latexrecommended now. dev-tex/xcolor will be removed in 10 days.
Comment 15 Horst Prote 2019-11-04 16:36:22 UTC
If dev-tex/xcolor is incorporated into latexrecommended, should not then the dependency in dev-tex/pgf:

RDEPEND="dev-texlive/texlive-latexrecommended
    dev-tex/xcolor"

be removed then?