Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684336 - app-editors/vim-8.1.0648-r1 USE=minimal - /etc/vim/vimrc: invalid command let g:skip_defaults_vim = 1
Summary: app-editors/vim-8.1.0648-r1 USE=minimal - /etc/vim/vimrc: invalid command le...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-25 14:17 UTC by 白川間瀬流
Modified: 2019-04-25 14:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 白川間瀬流 2019-04-25 14:17:24 UTC
When vim is compiled with the minimal USE-Flag, you get the following complain when starting it

---8<---
Error detected while processing /etc/vim/vimrc:
line  194:
E319: Sorry, the command is not available in this version: let g:skip_defaults_vim = 1
Press ENTER or type command to continue
---8<---

The corresponding config part in the vimrc is the following

---8<---
" We don't want VIM to load their own built-in defaults, preferring ours here
" instead:
let g:skip_defaults_vim = 1
---8<---