Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 681082 - media-gfx/gimp-2.10.8-r1 stabilization request
Summary: media-gfx/gimp-2.10.8-r1 stabilization request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sebastian Pipping
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 572496 CVE-2017-9110, CVE-2017-9111, CVE-2017-9112, CVE-2017-9113, CVE-2017-9114, CVE-2017-9115, CVE-2017-9116 655390 679852 683268
Blocks: 684522 gnome-3.30-stable
  Show dependency tree
 
Reported: 2019-03-20 20:30 UTC by sebB
Modified: 2019-06-05 07:16 UTC (History)
6 users (show)

See Also:
Package list:
media-gfx/gimp-2.10.8-r1 amd64 x86 media-gfx/dcraw-9.28.0-r1 alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 media-gfx/mypaint-brushes-1.3.0-r1 amd64 x86 media-libs/babl-0.1.62 alpha amd64 arm hppa ia64 ppc ppc64 x86 media-libs/gegl-0.4.14 amd64 x86 virtual/opencl-0-r6 amd64 x86
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sebB 2019-03-20 20:30:30 UTC
Maybe a newer gimp version can be stabilized?

2.8.22 is 2 years old.

Gimp 2.10.6-r1 work fine on my stable system and no bug open.

Feel free if you want to stabilize 2.10.8-r1 which work fine too.

Thanks

Reproducible: Always
Comment 1 Mart Raudsepp gentoo-dev 2019-03-31 14:51:08 UTC
ping; 2.10.8-r1 has been around 4 months already too.
Comment 2 Sebastian Pipping gentoo-dev 2019-03-31 20:06:11 UTC
Looking through the https://bugs.gentoo.org/buglist.cgi?quicksearch=media-gfx%2Fgimp results, I'm not sure we're ready: Some of these affect 2.10.6
Comment 3 Mart Raudsepp gentoo-dev 2019-04-01 07:32:59 UTC
2.10.8-r1 too? :(
Time issues on fixing them up, or need upstream fixes for some of these?
Comment 4 Pacho Ramos gentoo-dev 2019-04-07 15:13:32 UTC
From the list I think only bug 679852 affects it, and bug 659246 looks a libmypaint bug
Comment 5 Pacho Ramos gentoo-dev 2019-04-23 23:07:30 UTC
ACK on stabilizing fixed opencl in bug 572496, with that we could proceed as talked with Sebastian some days ago
Comment 6 Stabilization helper bot gentoo-dev 2019-04-24 00:05:07 UTC
An automated check of this bug failed - repoman reported dependency errors (97 lines truncated): 

> dependency.bad media-gfx/gimp/gimp-2.10.8-r1.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libmypaint-1.3.0', '>=media-gfx/mypaint-brushes-1.3.0', '>=media-libs/libheif-1.1.0:=']
> dependency.bad media-gfx/gimp/gimp-2.10.8-r1.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libmypaint-1.3.0', '>=media-gfx/mypaint-brushes-1.3.0', '>=media-libs/libheif-1.1.0:=']
> dependency.bad media-gfx/gimp/gimp-2.10.8-r1.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-gfx/mypaint-brushes-1.3.0', '>=media-libs/libheif-1.1.0:=']
Comment 7 Pacho Ramos gentoo-dev 2019-04-24 08:17:59 UTC
Oops, gimp-2.10 is amd64/x86 only
Let me reorder things
Comment 8 Pacho Ramos gentoo-dev 2019-04-24 08:19:48 UTC
For the other arches, I would go obsolete bug 589098 and probably open a new one with the new deps(if they still want gimp there)
Comment 9 Pacho Ramos gentoo-dev 2019-04-25 22:32:22 UTC
amd64 stable
Comment 10 Timo Ollech 2019-04-26 11:41:06 UTC
Actually https://bugs.gentoo.org/682958 prevents gimp-2.10.8-r1 from building on my system, so it should not be stabilized yet.
Comment 11 Rolf Eike Beer archtester 2019-04-27 06:36:06 UTC
sparc stable
Comment 12 Pacho Ramos gentoo-dev 2019-04-27 17:08:44 UTC
(In reply to Timo Ollech from comment #10)
> Actually https://bugs.gentoo.org/682958 prevents gimp-2.10.8-r1 from
> building on my system, so it should not be stabilized yet.

it compiles fine for me, that patches are an enhancement (from Fedora only) to not be able to deprecate slot :0.3 in the future
Comment 13 Sergei Trofimovich (RETIRED) gentoo-dev 2019-04-27 21:06:04 UTC
ia64 stable
Comment 14 Sergei Trofimovich (RETIRED) gentoo-dev 2019-04-28 13:10:54 UTC
ppc64 stable
Comment 15 DC 2019-04-30 04:27:25 UTC
Hi, I'm trying to do an emerge update. It looks like you've marked gimp-2.10.8-r1.ebuild stable for amd64, but it has a DEPEND on dev-libs/appstream-glib, and all versions of dev-libs/appstream-glib are keyworded with ~amd64 or ~amd64-linux.

Does dev-libs/appstream-glib need to be stabilized as well?
Comment 16 Mart Raudsepp gentoo-dev 2019-04-30 05:06:40 UTC
There has been a stable amd64 appstream-glib for years now.
Currently dev-libs/appstream-glib-0.7.9, which was stabled (as an upgrade from previous versions) back in December 2018.
Comment 17 DC 2019-05-02 01:38:56 UTC
Hm, when I try to "emerge -uD --newuse world", I get the error:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-gfx/gimp-2.10.8-r1::gentoo
# required by @selected
# required by @world (argument)
=dev-libs/appstream-glib-0.7.15 ~amd64

It looks like appstream-glib-0.7.9.ebuild has KEYWORDS="amd64 ~amd64-linux".

I'm not familiar with how KEYWORDS interact, but could the "~amd64-linux" be preventing me from emerging it? Or am I looking at the wrong thing entirely?
Comment 18 Sergei Trofimovich (RETIRED) gentoo-dev 2019-05-03 07:16:31 UTC
hppa stable
Comment 19 Matt Turner gentoo-dev 2019-05-07 21:47:55 UTC
alpha stable
Comment 20 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-08 19:20:49 UTC
x86 stable
Comment 21 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-11 12:10:38 UTC
arm stable
Comment 22 Agostino Sarubbo gentoo-dev 2019-06-05 07:16:02 UTC
ppc stable. Closing.