Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 679882 - dev-cpp/glibmm-2.56.1: FAIL giomm_tls_client/test
Summary: dev-cpp/glibmm-2.56.1: FAIL giomm_tls_client/test
Status: RESOLVED DUPLICATE of bug 677706
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2019-03-09 22:09 UTC by ernsteiswuerfel
Modified: 2019-04-08 01:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (glibmm-2.56.1:20190309-212058.log,303.67 KB, text/plain)
2019-03-09 22:09 UTC, ernsteiswuerfel
Details
test-suite.log (test-suite.log,450 bytes, text/plain)
2019-03-09 22:10 UTC, ernsteiswuerfel
Details
emerge --info (file_679882.txt,5.85 KB, text/plain)
2019-03-09 22:10 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel archtester 2019-03-09 22:09:22 UTC
Created attachment 568356 [details]
build.log

giomm_tls_client/test passes on ppc64, but fails on ppc:

=========================================
   glibmm 2.56.1: tests/test-suite.log
=========================================

# TOTAL: 31
# PASS:  30
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: giomm_tls_client/test
===========================

Gio::Resolver::lookup_by_name() threw exception: terminate called after throwing an instance of 'Glib::ConvertError'
FAIL giomm_tls_client/test (exit status: 134)

[...]
                Stack trace of thread 20265:
                #0  0x00000000f79ec9d4 __libc_signal_restore_set (libc.so.6)
                #1  0x00000000f79ee190 __GI_abort (libc.so.6)
                #2  0x00000000f7be9094 _ZN9__gnu_cxx27__verbose_terminate_handlerEv (libstdc++.so.6)
                #3  0x00000000f7be5ad8 _ZN10__cxxabiv111__terminateEPFvvE (libstdc++.so.6)
                #4  0x00000000f7be5ba4 _ZSt9terminatev (libstdc++.so.6)
                #5  0x00000000f7be6008 __cxa_throw (libstdc++.so.6)
                #6  0x000000000073814c n/a (/var/tmp/portage/dev-cpp/glibmm-2.56.1/work/glibmm-2.56.1-abi_ppc_32.ppc/glib/glibmm/.libs/libglibmm-2.4.so.1.3.0)

GNU gdb (Gentoo 8.1 p1) 8.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://bugs.gentoo.org/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /var/tmp/portage/dev-cpp/glibmm-2.56.1/work/glibmm-2.56.1-abi_ppc_32.ppc/tests/giomm_tls_client/.libs/test...done.
[New LWP 20265]
[New LWP 20750]
[New LWP 20749]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `/var/tmp/portage/dev-cpp/glibmm-2.56.1/work/glibmm-2.56.1-abi_ppc_32.ppc/tests/'.
Program terminated with signal SIGABRT, Aborted.
#0  0xf79ec9d4 in __libc_signal_restore_set (set=0xffb42848) at ../sysdeps/unix/sysv/linux/nptl-signals.h:80
80	  return INTERNAL_SYSCALL (rt_sigprocmask, err, 4, SIG_SETMASK, set, NULL,
[Current thread is 1 (Thread 0xf7d625d0 (LWP 20265))]
Comment 1 ernsteiswuerfel archtester 2019-03-09 22:10:05 UTC
Created attachment 568358 [details]
test-suite.log
Comment 2 ernsteiswuerfel archtester 2019-03-09 22:10:22 UTC
Created attachment 568360 [details]
emerge --info
Comment 3 Thomas Deutschmann gentoo-dev 2019-04-08 01:35:56 UTC

*** This bug has been marked as a duplicate of bug 677706 ***