Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 670759 - =sci-libs/mumps-5.1.2 should depend on >=sci-libs/scotch-6.0.1
Summary: =sci-libs/mumps-5.1.2 should depend on >=sci-libs/scotch-6.0.1
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: EAPI4Removal
  Show dependency tree
 
Reported: 2018-11-09 14:44 UTC by Bernd
Modified: 2020-05-19 21:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd 2018-11-09 14:44:13 UTC
According to upstream (http://mumps.enseeiht.fr/doc/userguide_5.1.2.pdf, section 2.5.2 on page 9) for current mumps the latest version of scotch >=scotch-6.0.1 is recommended.
Comment 1 Bernd 2019-09-15 16:08:03 UTC
I closed the PR some time ago.
Comment 2 Bernd 2019-09-15 16:44:38 UTC
Due to upstream having updated to 5.2.1, the userguide is now at http://mumps.enseeiht.fr/doc/userguide_5.2.1.pdf.

Information about dependency on scotch is now in section 2.6.2 on page 10.

According to that, mumps (5.2.1) is compatible with scotch 5.1.x and 6.0.x, but not with 6.0.0, due to some problem with this version. They recommend, however, to use scotch >= 6.0.1.
Comment 3 Andreas Sturmlechner gentoo-dev 2020-05-19 21:14:32 UTC
This is blocking <sci-libs/scotch-6 cleanup.