Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 669394 - www-client/firefox-63.0 should depend on newer rust
Summary: www-client/firefox-63.0 should depend on newer rust
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-23 09:50 UTC by Tomáš Mózes
Modified: 2018-10-23 11:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Mózes 2018-10-23 09:50:18 UTC
0:07.12 ERROR: Rust compiler 1.27.1 is too old.
0:07.12 To compile Rust language sources please install at least
0:07.12 version 1.28.0 of the 'rustc' toolchain and make sure it is
0:07.12 first in your path.
Comment 1 Thomas Deutschmann gentoo-dev Security 2018-10-23 10:13:37 UTC
I'll adjust but please notice that oldest version in repository is virtual/rust-1.29.1 which would be enough and according to Gentoo policy, in this case we don't need to "enforce" a newer version.
Comment 2 Tomáš Mózes 2018-10-23 11:17:48 UTC
I see, but for a regular user it's better if emerge firefox simply works ;)
Comment 3 Larry the Git Cow gentoo-dev 2018-10-23 11:21:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7182d50a95a5c28c192eab2fb280f0edf1849c51

commit 7182d50a95a5c28c192eab2fb280f0edf1849c51
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2018-10-23 11:20:58 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2018-10-23 11:21:29 +0000

    www-client/firefox: adjust requirements
    
    - Warn user when USE=lto is set but used compiler is outdated.
      [Bug #666784]
    
    - Enforce >=rust-1.28.0. [Bug #669394]
    
    - Disable ELF hack again. [Bug #669382]
    
    - Enforce usage of >=dev-libs/nss-3.39. [Bug #669374]
    
    Bug: https://bugs.gentoo.org/666784
    Closes: https://bugs.gentoo.org/669394
    Closes: https://bugs.gentoo.org/669382
    Closes: https://bugs.gentoo.org/669374
    Package-Manager: Portage-2.3.51, Repoman-2.3.11
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 www-client/firefox/firefox-63.0.ebuild | 45 +++++++++++++++++++++++++++-------
 1 file changed, 36 insertions(+), 9 deletions(-)