Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 669382 - www-client/firefox-63.0[clang]: error: calling a private constructor of class 'std::__1::__wrap_iter<Elf_SymValue *>'
Summary: www-client/firefox-63.0[clang]: error: calling a private constructor of class...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 669386 669914 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-23 07:59 UTC by Perfect Gentleman
Modified: 2018-11-04 13:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.xz,115.49 KB, application/x-xz)
2018-10-23 07:59 UTC, Perfect Gentleman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Perfect Gentleman 2018-10-23 07:59:50 UTC
Created attachment 552488 [details]
build.log

-------
16:44.62 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:177:10: warning: 'serialize' overrides a member function but is not marked 'override' [-Winconsistent-missing-override]
16:44.63     void serialize(std::ofstream &file, char ei_class, char ei_data)
16:44.63          ^
16:44.63 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfxx.h:431:18: note: overridden virtual function is here
16:44.63     virtual void serialize(std::ofstream &file, char ei_class, char ei_data)
16:44.63                  ^
16:44.63 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:199:10: warning: 'isRelocatable' overrides a member function but is not marked 'override' [-Winconsistent-missing-override]
16:44.63     bool isRelocatable() {
16:44.63          ^
16:44.63 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfxx.h:367:18: note: overridden virtual function is here
16:44.63     virtual bool isRelocatable() {
16:44.63                  ^
16:44.67 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:1026:31: error: calling a private constructor of class 'std::__1::__wrap_iter<Elf_SymValue *>'
16:44.67                               std::vector<Elf_SymValue>::iterator(symbol)),
16:44.67                               ^
16:44.67 /usr/include/c++/v1/iterator:1422:60: note: declared private here
16:44.67     _LIBCPP_INLINE_VISIBILITY _LIBCPP_CONSTEXPR_IF_NODEBUG __wrap_iter(iterator_type __x) _NOEXCEPT_DEBUG : __i(__x) {}
16:44.67                                                            ^
16:44.80 gmake[4]: Entering directory '/tmp/portage/www-client/firefox-63.0/work/firefox-63.0/ff/js/src/build'
16:44.80 libjs_static.a
16:44.80 rm -f libjs_static.a
16:44.80 llvm-ar crs libjs_static.a ../Array.o ../RegExp.o ../CTypes.o ../Library.o ../Parser.o ../StoreBuffer.o ../Disassembler-x86-shared.o ../jsmath.o ../jsutil.o ../pm_linux.o ../DoubleToString.o ../Interpreter.o ../JSAtom.o ../ProfilingStack.o ../Unified_cpp_js_src0.o ../Unified_cpp_js_src1.o ../Unified_cpp_js_src10.o ../Unified_cpp_js_src11.o ../Unified_cpp_js_src12.o ../Unified_cpp_js_src13.o ../Unified_cpp_js_src14.o ../Unified_cpp_js_src15.o ../Unified_cpp_js_src16.o ../Unified_cpp_js_src17.o ../Unified_cpp_js_src18.o ../Unified_cpp_js_src19.o ../Unified_cpp_js_src2.o ../Unified_cpp_js_src20.o ../Unified_cpp_js_src21.o ../Unified_cpp_js_src22.o ../Unified_cpp_js_src23.o ../Unified_cpp_js_src24.o ../Unified_cpp_js_src25.o ../Unified_cpp_js_src26.o ../Unified_cpp_js_src27.o ../Unified_cpp_js_src28.o ../Unified_cpp_js_src29.o ../Unified_cpp_js_src3.o ../Unified_cpp_js_src30.o ../Unified_cpp_js_src31.o ../Unified_cpp_js_src32.o ../Unified_cpp_js_src33.o ../Unified_cpp_js_src34.o ../Unified_cpp_js_src35.o ../Unified_cpp_js_src36.o ../Unified_cpp_js_src37.o ../Unified_cpp_js_src38.o ../Unified_cpp_js_src39.o ../Unified_cpp_js_src4.o ../Unified_cpp_js_src40.o ../Unified_cpp_js_src41.o ../Unified_cpp_js_src42.o ../Unified_cpp_js_src43.o ../Unified_cpp_js_src44.o ../Unified_cpp_js_src45.o ../Unified_cpp_js_src5.o ../Unified_cpp_js_src6.o ../Unified_cpp_js_src7.o ../Unified_cpp_js_src8.o ../Unified_cpp_js_src9.o ../../../modules/fdlibm/src/e_acos.o ../../../modules/fdlibm/src/e_acosh.o ../../../modules/fdlibm/src/e_asin.o ../../../modules/fdlibm/src/e_atan2.o ../../../modules/fdlibm/src/e_atanh.o ../../../modules/fdlibm/src/e_cosh.o ../../../modules/fdlibm/src/e_exp.o ../../../modules/fdlibm/src/e_hypot.o ../../../modules/fdlibm/src/e_log.o ../../../modules/fdlibm/src/e_log10.o ../../../modules/fdlibm/src/e_log2.o ../../../modules/fdlibm/src/e_pow.o ../../../modules/fdlibm/src/e_sinh.o ../../../modules/fdlibm/src/e_sqrt.o ../../../modules/fdlibm/src/k_exp.o ../../../modules/fdlibm/src/s_asinh.o ../../../modules/fdlibm/src/s_atan.o ../../../modules/fdlibm/src/s_cbrt.o ../../../modules/fdlibm/src/s_ceil.o ../../../modules/fdlibm/src/s_ceilf.o ../../../modules/fdlibm/src/s_copysign.o ../../../modules/fdlibm/src/s_expm1.o ../../../modules/fdlibm/src/s_fabs.o ../../../modules/fdlibm/src/s_floor.o ../../../modules/fdlibm/src/s_floorf.o ../../../modules/fdlibm/src/s_log1p.o ../../../modules/fdlibm/src/s_nearbyint.o ../../../modules/fdlibm/src/s_rint.o ../../../modules/fdlibm/src/s_rintf.o ../../../modules/fdlibm/src/s_scalbn.o ../../../modules/fdlibm/src/s_tanh.o ../../../modules/fdlibm/src/s_trunc.o ../../../modules/fdlibm/src/s_truncf.o
16:44.95 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:1026:31: error: calling a private constructor of class 'std::__1::__wrap_iter<Elf_SymValue *>'
16:44.95                               std::vector<Elf_SymValue>::iterator(symbol)),
16:44.95                               ^
16:44.95 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:1193:16: note: in instantiation of function template specialization 'do_relocation_section<Elf_Rel>' requested here
16:44.95         exit = do_relocation_section<Elf_Rel>(&elf, R_386_RELATIVE, R_386_32, force, fill);
16:44.95                ^
16:44.95 /usr/include/c++/v1/iterator:1422:60: note: declared private here
16:44.95     _LIBCPP_INLINE_VISIBILITY _LIBCPP_CONSTEXPR_IF_NODEBUG __wrap_iter(iterator_type __x) _NOEXCEPT_DEBUG : __i(__x) {}
16:44.95                                                            ^
16:45.01 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:1026:31: error: calling a private constructor of class 'std::__1::__wrap_iter<Elf_SymValue *>'
16:45.01                               std::vector<Elf_SymValue>::iterator(symbol)),
16:45.01                               ^
16:45.01 /tmp/portage/www-client/firefox-63.0/work/firefox-63.0/build/unix/elfhack/elfhack.cpp:1196:16: note: in instantiation of function template specialization 'do_relocation_section<Elf_Rela>' requested here
16:45.01         exit = do_relocation_section<Elf_Rela>(&elf, R_X86_64_RELATIVE, R_X86_64_64, force, fill);
16:45.01                ^
16:45.01 /usr/include/c++/v1/iterator:1422:60: note: declared private here
16:45.01     _LIBCPP_INLINE_VISIBILITY _LIBCPP_CONSTEXPR_IF_NODEBUG __wrap_iter(iterator_type __x) _NOEXCEPT_DEBUG : __i(__x) {}
16:45.01                                                            ^
16:45.05 2 warnings and 3 errors generated.
16:45.06 gmake[4]: *** [/tmp/portage/www-client/firefox-63.0/work/firefox-63.0/config/rules.mk:767: host_elfhack.o] Error 1
16:45.06 gmake[4]: *** Waiting for unfinished jobs....
16:45.07 gmake[4]: Entering directory '/tmp/portage/www-client/firefox-63.0/work/firefox-63.0/ff/gfx/ots/src'
16:45.07 mkdir -p '.deps/'
-------
-------
~ $ emerge --info
Portage 2.3.51 (python 3.7.1-final-0, default/linux/amd64/17.1/no-multilib, gcc-8.2.0, glibc-2.28-r1, 4.18.16-gentoo x86_64)
=================================================================
System uname: Linux-4.18.16-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770K_CPU_@_3.50GHz-with-gentoo-2.6
KiB Mem:    15823420 total,   4521592 free
KiB Swap:   13904892 total,  13904892 free
Head commit of repository gentoo: f717474a782311cf1c0632cf1692989e44bdd8e4

Head commit of repository gnome: abf15cfb7bba8947130582968aab062b864e577f

Head commit of repository mozilla: aa315b3cb90a62f484206a1a01ba12f93da0fe0a

Head commit of repository qt: 6045280dae176d1cd57959d2cda78de23fcf5aa2

Head commit of repository kde: bf6b3f5b698024aae57fff68720ac078c1719355

Head commit of repository pg_overlay: 534046079f377af8d87204b801e57da714df5f1e

sh bash 4.4_p23
ld GNU gold (Gentoo 2.31.1 p3 2.31.1) 1.16
ccache version 3.5 [disabled]
app-shells/bash:          4.4_p23::gentoo
dev-lang/perl:            5.28.0::gentoo
dev-lang/python:          2.7.15::gentoo, 3.7.1_pre::pg_overlay
dev-util/ccache:          3.5::gentoo
dev-util/cmake:           3.12.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.3::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r1::gentoo
sys-devel/gcc:            8.2.0-r3::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.28-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/gentoo.git
    priority: 1
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay
    sync-git-clone-extra-opts: --single-branch --branch master

gnome
    location: /usr/portage/proj/gnome
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/gnome.git
    masters: gentoo
    priority: 3
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay

mozilla
    location: /usr/portage/proj/mozilla
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/mozilla.git
    masters: gentoo
    priority: 5
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay

qt
    location: /usr/portage/proj/qt
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/qt.git
    masters: gentoo
    priority: 7
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay

kde
    location: /usr/portage/proj/kde
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/kde.git
    masters: gentoo
    priority: 9
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay

pg_overlay
    location: /usr/portage/overlay/pg_overlay
    sync-type: git
    sync-uri: https://github.com/perfect7gentleman/pg_overlay.git
    masters: gentoo
    priority: 11
    eclass-overrides: gnome mozilla gentoo qt kde pg_overlay

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe -fomit-frame-pointer -fno-stack-protector -ftree-vectorize -s"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -mtune=native -O2 -pipe -fomit-frame-pointer -fno-stack-protector -ftree-vectorize -s"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O2 -Wl,--as-needed -Wl,--sort-common -Wl,--strip-debug"
LINGUAS="en en_US ru ru_RU"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X acl alsa amd64 bash-completion bzip2 cairo cli cups custom-cflags cxx dbus dri elogind encode ffmpeg flac fontconfig gmp gzip iconv icu idn inotify introspection jabber jit jpeg libass libffi libnotify libtirpc lm_sensors lzma lzo matroska mmap mtp ncurses nls nptl ntpl ogg opengl openmp orc pam pch pcre pulseaudio readline seccomp smp ssl symlink szip taglib tcmalloc threads tiff truetype udev udisks unicode usb v4l vaapi vorbis wavpack webp x264 xattr xcb xmpp zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en-US ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
-------
Comment 1 Tomáš Mózes 2018-10-23 09:48:29 UTC
*** Bug 669386 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2018-10-23 11:21:43 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7182d50a95a5c28c192eab2fb280f0edf1849c51

commit 7182d50a95a5c28c192eab2fb280f0edf1849c51
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2018-10-23 11:20:58 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2018-10-23 11:21:29 +0000

    www-client/firefox: adjust requirements
    
    - Warn user when USE=lto is set but used compiler is outdated.
      [Bug #666784]
    
    - Enforce >=rust-1.28.0. [Bug #669394]
    
    - Disable ELF hack again. [Bug #669382]
    
    - Enforce usage of >=dev-libs/nss-3.39. [Bug #669374]
    
    Bug: https://bugs.gentoo.org/666784
    Closes: https://bugs.gentoo.org/669394
    Closes: https://bugs.gentoo.org/669382
    Closes: https://bugs.gentoo.org/669374
    Package-Manager: Portage-2.3.51, Repoman-2.3.11
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 www-client/firefox/firefox-63.0.ebuild | 45 +++++++++++++++++++++++++++-------
 1 file changed, 36 insertions(+), 9 deletions(-)
Comment 3 Thomas Deutschmann gentoo-dev Security 2018-10-31 22:03:11 UTC
*** Bug 669914 has been marked as a duplicate of this bug. ***
Comment 4 Martin Mokrejš 2018-11-04 06:21:28 UTC
Unfortunately I still get it with 


>>> Install firefox-63.0.1 into /scratch/var/tmp/portage/www-client/firefox-63.0.1/image/ category www-client
 * PT_PAX marking -m /scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/dist/bin/xpcshell with paxctl
 * PT_PAX marking -m /scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/dist/bin/xpcshell with scanelf
 * XATTR_PAX marking -me /scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/dist/bin/xpcshell with setfattr
 0:01.24 /usr/bin/gmake -C . -j2 -s -w install
 0:01.25 gmake: Entering directory '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff'
 0:01.32 gmake[1]: Entering directory '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/browser/installer'
 0:27.36 terminate called after throwing an instance of 'std::__ios_failure'
 0:27.36   what():  basic_ios::clear: iostream error
 0:28.16 Traceback (most recent call last):
 0:28.16   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/toolkit/mozapps/installer/packager.py", line 339, in <module>
 0:28.16     main()
 0:28.16   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/toolkit/mozapps/installer/packager.py", line 333, in main
 0:28.16     copier.copy(args.destination)
 0:28.16   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/python/mozbuild/mozpack/copier.py", line 431, in copy
 0:28.17     copy_results.append((destfile, f.copy(destfile, skip_if_older)))
 0:28.17   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/python/mozbuild/mozpack/files.py", line 296, in copy
 0:28.17     elfhack(dest)
 0:28.17   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/python/mozbuild/mozpack/executables.py", line 124, in elfhack
 0:28.17     errors.fatal('Error executing ' + ' '.join(cmd))
 0:28.17   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/python/mozbuild/mozpack/errors.py", line 103, in fatal
 0:28.17     self._handle(self.FATAL, msg)
 0:28.17   File "/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/python/mozbuild/mozpack/errors.py", line 98, in _handle
 0:28.17     raise ErrorMessage(msg)
 0:28.17 mozpack.errors.ErrorMessage: Error: Error executing /scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/build/unix/elfhack/elfhack ../../dist/firefox/libxul.so
 0:28.18 gmake[1]: *** [/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/toolkit/mozapps/installer/packager.mk:22: stage-package] Error 1
 0:28.18 gmake[1]: Leaving directory '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff/browser/installer'
 0:28.18 gmake: *** [/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/browser/build.mk:15: install] Error 2
 0:28.18 gmake: Leaving directory '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1/ff'
 * ERROR: www-client/firefox-63.0.1::gentoo failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line 124:  Called src_install
 *   environment, line 5230:  Called die
 * The specific snippet of code:
 *       MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 DESTDIR="${D}" ./mach install || die;
 * 
 * If you need support, post the output of `emerge --info '=www-client/firefox-63.0.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/firefox-63.0.1::gentoo'`.
 * The complete build log is located at '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/build.log'.
 * The ebuild environment file is located at '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/environment'.
 * Working directory: '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1'
 * S: '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1'

>>> Failed to emerge www-client/firefox-63.0.1, Log file:

>>>  '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/build.log'

 * Messages for package www-client/firefox-63.0.1:

 * You are enabling official branding. You may not redistribute this build
 * to any users on your network or the internet. Doing so puts yourself into
 * a legal problem with Mozilla Foundation.
 * You can disable it by emerging firefox _with_ the bindist USE-flag.
 * ERROR: www-client/firefox-63.0.1::gentoo failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line 124:  Called src_install
 *   environment, line 5230:  Called die
 * The specific snippet of code:
 *       MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 DESTDIR="${D}" ./mach install || die;
 * 
 * If you need support, post the output of `emerge --info '=www-client/firefox-63.0.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/firefox-63.0.1::gentoo'`.
 * The complete build log is located at '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/build.log'.
 * The ebuild environment file is located at '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/environment'.
 * Working directory: '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1'
 * S: '/scratch/var/tmp/portage/www-client/firefox-63.0.1/work/firefox-63.0.1'
 * 
 * The following package has failed to build, install, or execute postinst:
 * 
 *  (www-client/firefox-63.0.1:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/scratch/var/tmp/portage/www-client/firefox-63.0.1/temp/build.log'
 *
Comment 5 Perfect Gentleman 2018-11-04 13:05:31 UTC
(In reply to Martin Mokrejš from comment #4)
> Unfortunately I still get it with 
> 
> 
> >>> Install firefox-63.0.1 into /scratch/var/tmp/portage/www-client/firefox-63.0.1/image/ category www-client

It's not the same bug