Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 665348 (gnome-3.30) - GNOME 3.30 Official Release
Summary: GNOME 3.30 Official Release
Status: RESOLVED FIXED
Alias: gnome-3.30
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Tracker
: 665322 (view as bug list)
Depends on: 580474 613374 624958 624960 478204 615216 gnome-3.28 650530 673156 680006 680198 gnome-3.30-stable
Blocks: gnome-3.32
  Show dependency tree
 
Reported: 2018-09-06 11:18 UTC by Mart Raudsepp
Modified: 2020-02-23 18:36 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2018-09-06 11:18:11 UTC
GNOME 3.30 was officially released on 5th Sep 2018. This bug is our usual long-term tracking bug.

1. No talks in here.
2. 3.30 will be included in tree when it is ready.
3. Do not file bump request reports, we might be slow but eventually we will
get around all 3.30 bumps. We already know what's missing from various report scripts. Pull Requests with a note here is acceptable and appreciated, especially when doing more work than simple dependency updates (e.g updating to meson where needed), but no guarantees how fast we can review.
4. If you have a particular problem with 3.30 ebuilds, please file a separate
bug report and make it block this one.

As an extra note, there might be individual 3.30 packages appearing much earlier than the core. This may be done during ongoing work on 3.26 and 3.28 when the 3.30 release can safely work in older GNOME (often in case the 3.30 release really only has bug fixes and/or translation updates over the previous big version; sometimes in case of feature updates too when it doesn't depend on other GNOME stack things). This doesn't mean that core of 3.30 is about to get included as well at that point, unfortunately.
Comment 1 Mart Raudsepp gentoo-dev 2018-09-06 11:20:21 UTC
*** Bug 665322 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2019-03-18 11:02:47 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=22dfbe34522eef790188da9d58e383ba42e82ba1

commit 22dfbe34522eef790188da9d58e383ba42e82ba1
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-03-18 11:02:21 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-03-18 11:02:21 +0000

    gnome-base/gnome: bump to 3.30.2
    
    Bug: https://bugs.gentoo.org/665348
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 gnome-base/gnome/gnome-3.30.2.ebuild | 51 ++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)
Comment 3 Mart Raudsepp gentoo-dev 2020-02-23 18:36:25 UTC
3.30 is mostly removed from tree in favor of stable 3.32. Closing the bug after copying the still open dependent tracking bugs to 3.34 bug 695712