Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 662914 - app-eselect/eselect-wxwidgets-20140423 does not work with a 17.1 profile
Summary: app-eselect/eselect-wxwidgets-20140423 does not work with a 17.1 profile
Status: RESOLVED DUPLICATE of bug 552500
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2018-08-06 00:14 UTC by Rafael Kitover
Modified: 2018-08-06 15:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Kitover 2018-08-06 00:14:44 UTC
Even though I have wxGTK installed, eselect-wxwidgets does not detect it with a 17.1 profile:

$ eselect wxwidgets list
Available wxWidgets profiles:
  (none found)

As a result wx-config is broken and I cannot build any wxWidgets apps.
Comment 1 Rafael Kitover 2018-08-06 03:07:42 UTC
The fix seems to be changing:

WXCONFDIR="${EROOT}"/usr/lib/wx/config

to:

WXCONFDIR="${EROOT}"/usr/lib64/wx/config

at the top of /usr/share/eselect/modules/wxwidgets.eselect

I'd submit a patch but I couldn't figure out how to do it properly for multilib.
Comment 2 Mart Raudsepp gentoo-dev 2018-08-06 15:28:49 UTC
Patch is available in bug 552500

*** This bug has been marked as a duplicate of bug 552500 ***