Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 660346 - app-text/calibre-3.15.0 and qt-5.11 build fails: static assertion failed: sizeof sp ecialLanguages / sizeof *specialLanguages == QChar::ScriptCount
Summary: app-text/calibre-3.15.0 and qt-5.11 build fails: static assertion failed: siz...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius
URL:
Whiteboard: fixed in 3.26.1
Keywords: PATCH
: 660420 660464 (view as bug list)
Depends on: 664562
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-07-04 11:59 UTC by Marco Genasci
Modified: 2018-08-25 11:50 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
calibre-3.15.0_qt-5.11.patch (calibre-3.15.0_qt-5.11.patch,1.01 KB, patch)
2018-07-04 12:01 UTC, Marco Genasci
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Genasci 2018-07-04 11:59:46 UTC
app-text/calibre-3.15.0 fails build phase with qt 5.11 with error:

In file included from /usr/include/qt5/QtGui/qtguiglobal.h:43:0,
                 from /usr/include/qt5/QtGui/5.11.1/QtGui/qpa/qplatformfontdatabase.h:52,
                 from /var/tmp/portage/app-text/calibre-3.15.0/work/calibre-3.15.0/src/calibre/headless/fontconfig_database.h:9,
                 from /var/tmp/portage/app-text/calibre-3.15.0/work/calibre-3.15.0/src/calibre/headless/fontconfig_database.cpp:40:
/var/tmp/portage/app-text/calibre-3.15.0/work/calibre-3.15.0/src/calibre/headless/fontconfig_database.cpp:296:1: error: static assertion failed: sizeof sp
ecialLanguages / sizeof *specialLanguages == QChar::ScriptCount
 Q_STATIC_ASSERT(sizeof specialLanguages / sizeof *specialLanguages == QChar::ScriptCount);
 ^
make: *** [Makefile:713: fontconfig_database.o] Error 1


Reproducible: Always
Comment 1 Marco Genasci 2018-07-04 12:01:54 UTC
Created attachment 538298 [details, diff]
calibre-3.15.0_qt-5.11.patch

Patch to resolve problem.

Reference https://www.linux.org.ru/forum/general/14325983
Comment 2 Bernd Feige 2018-07-04 13:26:53 UTC
I can confirm the problem and that the patch solves it nicely. Thanks!
Comment 3 Zac Medico gentoo-dev 2018-07-05 02:38:31 UTC
*** Bug 660420 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Sturmlechner gentoo-dev 2018-07-05 18:14:57 UTC
*** Bug 660464 has been marked as a duplicate of this bug. ***