Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656722 - app-emulation/vice-3.4 version bump
Summary: app-emulation/vice-3.4 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: PullRequest
: 698952 (view as bug list)
Depends on:
Blocks: gtkglext-removal
  Show dependency tree
 
Reported: 2018-05-27 23:25 UTC by groepaz
Modified: 2020-04-05 09:44 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
vice 3.3 ebuild (vice-3.3.ebuild,2.94 KB, text/plain)
2019-05-18 17:22 UTC, doj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description groepaz 2018-05-27 23:25:03 UTC
we released a new tarball recently.

with this release, all GUIs/Ports except GTK3 and SDL are deprecated and will be removed. because of this:

- the existing ebuild needs some adjustments, --enable-fullscreen does no more exist, and --enable-gnomeui3 has been replaced by --enable-native-gtk3ui. i suggest making GTK3 the default, the tarball still has the old XAW and GTK2 UIs, but they are unmaintained and will get removed in 3.3

- i suggest creating another ebuild that explicitly builds the SDL port/UI (with an sdl- prefix). this would allow to install both in parallel.

drop into #vice-dev on freenode at late evenings EST if there are any questions :)
Comment 1 groepaz 2019-03-05 14:41:06 UTC
just FYI - we are at 3.3 now, the mentioned UIs do no more exist and GTK3 is considered the default for all major platforms.
Comment 2 Roman S. 2019-04-06 22:01:12 UTC
Status is still unconfirmed :( What should we do to confirm that new version was indeed released by upstream?
Comment 3 groepaz 2019-04-07 09:15:25 UTC
what are you usually doing? look at the tarball in the repo on sourceforge perhaps? :) 

https://sourceforge.net/projects/vice-emu/files/releases/
Comment 4 James Le Cuirot gentoo-dev 2019-04-07 09:22:24 UTC
"Unconfirmed" doesn't mean we don't believe you, in this case it just means I don't have time to maintain 877 packages by myself.
Comment 5 DrSlony 2019-04-11 10:17:49 UTC
Looking forward to this.
Comment 6 doj 2019-05-18 17:22:22 UTC
Created attachment 577212 [details]
vice 3.3 ebuild

attached is my working version of an ebuild file for vice 3.3
I've hard coded the GTK3 UI and cleaned up some no longer supported options. I have not tested all optional USE flags.

Note that vice now requires the xa cross assembler to build. I've submitted an ebuild for that, see Bug 686234.
Comment 7 David Heidelberg (okias) 2019-10-30 20:49:58 UTC
*** Bug 698952 has been marked as a duplicate of this bug. ***
Comment 8 David Heidelberg (okias) 2019-10-30 21:07:52 UTC
Pull request [1], feel free to improve, if interested, I'll merge it.

[1] https://github.com/gentoo/gentoo/pull/13504
Comment 9 DrSlony 2020-01-11 13:21:59 UTC
Bump version to 3.4.
Comment 10 James Le Cuirot gentoo-dev 2020-01-12 23:28:47 UTC
Just letting you all know that I've been spending a lot of time on this. The old ebuild was very bad and therefore all the newly-contributed ebuilds based on it are also bad. It's just a horrendous package to deal with. I've almost completely reworked the ebuild and it's looking a lot better now but I'm not quite there yet.
Comment 11 James Le Cuirot gentoo-dev 2020-01-26 17:25:10 UTC
FYI Andreas, 3.4 does not use VTE.
Comment 12 Andreas Sturmlechner gentoo-dev 2020-01-26 18:16:38 UTC
(In reply to James Le Cuirot from comment #11)
> FYI Andreas, 3.4 does not use VTE.
I suspected so, hence the relation to this bug ;)
Comment 13 Larry the Git Cow gentoo-dev 2020-02-22 22:09:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c2dac17fd6d6844839eaa6b77e234b09804f6ee0

commit c2dac17fd6d6844839eaa6b77e234b09804f6ee0
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2020-02-22 22:07:07 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2020-02-22 22:09:36 +0000

    app-emulation/vice: Bump to post 3.4 snapshot with multiple variants
    
    The ebuild has been almost entirely rewritten. Many missing
    dependencies have been added. Multiple variants for GTK, SDL, and
    headless can now be installed simultaneously.
    
    Closes: https://bugs.gentoo.org/656722
    Closes: https://github.com/gentoo/gentoo/pull/13504
    Package-Manager: Portage-2.3.89, Repoman-2.3.20
    Signed-off-by: James Le Cuirot <chewi@gentoo.org>

 app-emulation/vice/Manifest               |   1 +
 app-emulation/vice/metadata.xml           |   4 +
 app-emulation/vice/vice-3.4_p37498.ebuild | 173 ++++++++++++++++++++++++++++++
 3 files changed, 178 insertions(+)
Comment 14 ernsteiswuerfel archtester 2020-02-22 23:06:10 UTC
(In reply to James Le Cuirot from comment #10)
> Just letting you all know that I've been spending a lot of time on this. The
> old ebuild was very bad and therefore all the newly-contributed ebuilds
> based on it are also bad. It's just a horrendous package to deal with. I've
> almost completely reworked the ebuild and it's looking a lot better now but
> I'm not quite there yet.
Many thanks!