Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 652112 - dev-libs/sdformat-6.0.0 - src_configure(): Couldn't find the urdfdom >= 1.0 system installation
Summary: dev-libs/sdformat-6.0.0 - src_configure(): Couldn't find the urdfdom >= 1.0 s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords: PullRequest
: 688260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-01 03:31 UTC by OKUMURA N. Shin-ya
Modified: 2020-07-23 15:19 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.78 KB, text/plain)
2018-04-01 03:32 UTC, OKUMURA N. Shin-ya
Details
emerge -v --info =dev-libs/sdformat-6.0.0 (emerge-info.log,27.78 KB, text/plain)
2018-04-02 17:26 UTC, OKUMURA N. Shin-ya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OKUMURA N. Shin-ya 2018-04-01 03:31:12 UTC
emerge-ing dev-libs/sdformat-6.0.0 fails with "Couldn't find the urdfdom >= 1.0 system installation"

Reproducible: Always

Steps to Reproduce:
1. emerge =dev-libs/sdformat-6.0.0

Actual Results:  
emerge fails.

Expected Results:  
emerge should finish successfully. :-)
Comment 1 OKUMURA N. Shin-ya 2018-04-01 03:32:16 UTC
Created attachment 526230 [details]
build.log
Comment 2 Jonas Stein gentoo-dev 2018-04-02 09:31:24 UTC
Thank you for the report. Please recompile and 
paste the emerge info as described on
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
Please reopen this ticket (Status:unconfirmed) afterwards.
Comment 3 OKUMURA N. Shin-ya 2018-04-02 17:26:32 UTC
Created attachment 526354 [details]
emerge -v --info =dev-libs/sdformat-6.0.0
Comment 4 Shannon 2019-11-01 14:21:12 UTC
I can confirm the issue.
This prevents ros-melodic/desktop_full from emerging.
Comment 5 Shannon 2019-11-01 17:26:15 UTC
Temporary work-around to get it to build is to not force the use of an external URDF.

sdformat-6.2.0.ebuild
Comment out line 34

#		"-DUSE_INTERNAL_URDF=OFF"
Comment 6 Alec Ten Harmsel 2020-05-15 16:14:16 UTC
Looks like this was fixed in https://github.com/ros/urdfdom_headers/commit/2cb39e9a15b3a21a888e0be5299a2a4401da7ebc and is in urdfdom_headers v1.0.5.
Comment 7 Alexis Ballier gentoo-dev 2020-07-23 14:47:12 UTC
*** Bug 688260 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2020-07-23 15:19:14 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cc2a025f533ba15fce6580893c635a07a1fb276f

commit cc2a025f533ba15fce6580893c635a07a1fb276f
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2020-07-23 14:42:41 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2020-07-23 15:18:57 +0000

    dev-libs/urdfdom_headers: bump to 1.0.5
    
    Closes: https://bugs.gentoo.org/652112
    Package-Manager: Portage-3.0.0, Repoman-2.3.23
    Signed-off-by: Alexis Ballier <aballier@gentoo.org>

 dev-libs/urdfdom_headers/Manifest                  |  1 +
 .../urdfdom_headers/urdfdom_headers-1.0.5.ebuild   | 29 ++++++++++++++++++++++
 .../urdfdom_headers/urdfdom_headers-9999.ebuild    |  6 ++---
 3 files changed, 33 insertions(+), 3 deletions(-)