Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688260 - dev-libs/urdfdom_headers installs pkgconfig file into /usr/lib on amd64
Summary: dev-libs/urdfdom_headers installs pkgconfig file into /usr/lib on amd64
Status: RESOLVED DUPLICATE of bug 652112
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robot Operating System team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-06-17 22:48 UTC by Victor Mataré
Modified: 2020-07-23 14:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Quick-fix patching the CMakeLists.txt to install to the correct place. (fix_pkgconfig_libdir.patch,631 bytes, patch)
2019-07-29 13:50 UTC, Jan-Matthias Braun
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Mataré 2019-06-17 22:48:30 UTC
As the title says. On an x86_64 system:

# qlist urdfdom_headers
/usr/lib/pkgconfig/urdfdom_headers.pc
[...]

Of course this became an issue only after migrating to the 17.1 profile.
Comment 1 Victor Mataré 2019-06-17 23:03:52 UTC
Upstream PR: https://github.com/ros/urdfdom_headers/pull/58
Comment 2 Jan-Matthias Braun 2019-07-29 13:50:23 UTC
Created attachment 584976 [details, diff]
Quick-fix patching the CMakeLists.txt to install to the correct place.

This does exactly the same as the PR linked above.
So, while not necessary in the long run, for now it fixes the build.
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2020-06-09 12:54:28 UTC
Fixed in 1.0.5 upstream released May 8, 2020
Comment 4 Alexis Ballier gentoo-dev 2020-07-23 14:47:12 UTC

*** This bug has been marked as a duplicate of bug 652112 ***