Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 650178 - dev-lang/mono-4.4.1.0 : processes.c:1641:12: error: implicit declaration of function makedev [-Werror=implicit-function-declaration]
Summary: dev-lang/mono-4.4.1.0 : processes.c:1641:12: error: implicit declaration of f...
Status: RESOLVED DUPLICATE of bug 638746
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2018-03-11 08:39 UTC by Toralf Förster
Modified: 2018-04-18 10:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.26 KB, text/plain)
2018-03-11 08:39 UTC, Toralf Förster
Details
dev-lang:mono-4.4.1.0:20180311-013605.log (dev-lang:mono-4.4.1.0:20180311-013605.log,261.50 KB, text/plain)
2018-03-11 08:39 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,132.93 KB, text/plain)
2018-03-11 08:39 UTC, Toralf Förster
Details
environment (environment,134.56 KB, text/plain)
2018-03-11 08:39 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.42 KB, application/x-bzip)
2018-03-11 08:39 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,33.54 KB, application/x-bzip)
2018-03-11 08:39 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,55.13 KB, application/x-bzip)
2018-03-11 08:39 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-03-11 08:39:07 UTC
processes.c: In function 'load_modules':
processes.c:1641:12: error: implicit declaration of function 'makedev' [-Werror=implicit-function-declaration]
   device = makedev ((int)maj_dev, (int)min_dev);
            ^~~~~~~
processes.c:1641:3: warning: nested extern declaration of 'makedev' [-Wnested-externs]

=== This is an issue at stable ===


  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop_stable_20180307-182850

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
  [3]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems)
  [2]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-lang/mono
[ebuild  N    ] dev-lang/mono-4.4.1.0  USE="nls (-doc) -minimal -pax_kernel -xen" ABI_X86="(64) -32 (-x32)"
Comment 1 Toralf Förster gentoo-dev 2018-03-11 08:39:10 UTC
Created attachment 523402 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-03-11 08:39:14 UTC
Created attachment 523404 [details]
dev-lang:mono-4.4.1.0:20180311-013605.log
Comment 3 Toralf Förster gentoo-dev 2018-03-11 08:39:17 UTC
Created attachment 523406 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-03-11 08:39:20 UTC
Created attachment 523408 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-03-11 08:39:23 UTC
Created attachment 523410 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-03-11 08:39:26 UTC
Created attachment 523412 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2018-03-11 08:39:29 UTC
Created attachment 523414 [details]
temp.tbz2
Comment 8 Pacho Ramos gentoo-dev 2018-04-18 10:23:20 UTC

*** This bug has been marked as a duplicate of bug 638746 ***