Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638746 - dev-lang/mono-4.4.1.0 - processes.c:1641:12: error: implicit declaration of function 'makedev' [-Werror=implicit-function-declaration]
Summary: dev-lang/mono-4.4.1.0 - processes.c:1641:12: error: implicit declaration of f...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords: PATCH
: 650178 (view as bug list)
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-11-25 00:30 UTC by Jiří Moravec
Modified: 2018-04-30 16:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mono-4.4.1.0-makedev.ebuild.patch (mono-4.4.1.0-makedev.ebuild.patch,862 bytes, patch)
2017-11-25 00:32 UTC, Jiří Moravec
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiří Moravec 2017-11-25 00:30:27 UTC
Stable dev-lang/mono-4.4.1.0 ebuild compilation failed with error:

...
../../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..  -I../../eglib/src -I../../eglib/src -I../../libgc/include -DMONO_BINDIR=\""/usr/bin"\" -I../.. -fvisibility=hidden -DGC_LINUX_THREADS -D_GNU_SOURCE -D_REENTRANT -DUSE_MMAP -DUSE_MUNMAP -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes  -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wwrite-strings -Wno-switch -Wno-switch-enum -Wno-unused-value -Wno-attributes  -DUSE_COMPILER_TLS  -march=bdver2 -mtune=bdver2 -O2 -pipe -mno-tbm -std=gnu99 -fno-strict-aliasing -fwrapv -DMONO_DLL_EXPORT -Wno-unused-but-set-variable -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes  -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wwrite-strings -Wno-switch -Wno-switch-enum -Wno-unused-value -Wno-attributes -mno-tls-direct-seg-refs -Werror-implicit-function-declaration -c -o semaphores.lo semaphores.c
processes.c: In function 'load_modules':
processes.c:1641:12: error: implicit declaration of function 'makedev' [-Werror=implicit-function-declaration]
   device = makedev ((int)maj_dev, (int)min_dev);
            ^~~~~~~
processes.c:1641:3: warning: nested extern declaration of 'makedev' [-Wnested-externs]
   device = makedev ((int)maj_dev, (int)min_dev);
   ^~~~~~
../../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..  -I../../eglib/src -I../../eglib/src -I../../libgc/include -DMONO_BINDIR=\""/usr/bin"\" -I../.. -fvisibility=hidden -DGC_LINUX_THREADS -D_GNU_SOURCE -D_REENTRANT -DUSE_MMAP -DUSE_MUNMAP -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes  -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wwrite-strings -Wno-switch -Wno-switch-enum -Wno-unused-value -Wno-attributes  -DUSE_COMPILER_TLS  -march=bdver2 -mtune=bdver2 -O2 -pipe -mno-tbm -std=gnu99 -fno-strict-aliasing -fwrapv -DMONO_DLL_EXPORT -Wno-unused-but-set-variable -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes  -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wwrite-strings -Wno-switch -Wno-switch-enum -Wno-unused-value -Wno-attributes -mno-tls-direct-seg-refs -Werror-implicit-function-declaration -c -o shared.lo shared.c
...

And in newer UNSTABLE versions, this error is already corrected! WTF!!
Comment 1 Jiří Moravec 2017-11-25 00:32:22 UTC
Created attachment 506462 [details, diff]
mono-4.4.1.0-makedev.ebuild.patch
Comment 2 Pacho Ramos gentoo-dev 2018-04-18 10:23:20 UTC
*** Bug 650178 has been marked as a duplicate of this bug. ***
Comment 3 Andreas K. Hüttel gentoo-dev 2018-04-30 16:04:47 UTC
Let's assume this is fixed in 4.8.