Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638372 - dev-libs/grok-0.9.2-r2 stable request
Summary: dev-libs/grok-0.9.2-r2 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard: Was: dev-libs/grok-0.9.2-r1 : grok_ca...
Keywords: STABLEREQ
: 644676 (view as bug list)
Depends on: 656752 657148
Blocks: glibc-rpc glibc-2.26-stable
  Show dependency tree
 
Reported: 2017-11-21 18:26 UTC by Toralf Förster
Modified: 2019-01-02 02:31 UTC (History)
1 user (show)

See Also:
Package list:
dev-libs/grok-0.9.2-r2
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
emerge-info.txt (emerge-info.txt,15.32 KB, text/plain)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details
dev-libs:grok-0.9.2-r1:20171121-113038.log (dev-libs:grok-0.9.2-r1:20171121-113038.log,2.13 KB, text/plain)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details
emerge-history.txt (emerge-history.txt,110.91 KB, text/plain)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details
environment (environment,44.21 KB, text/plain)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details
etc.portage.tbz2 (etc.portage.tbz2,16.64 KB, application/x-bzip)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details
temp.tbz2 (temp.tbz2,12.51 KB, application/x-bzip)
2017-11-21 18:26 UTC, Toralf Förster
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-11-21 18:26:09 UTC
                 from grok.h:136,
                 from grok.c:1:
grok_capture_xdr.h:9:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-no-multilib_libressl_20171119-113915

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *



emerge -qpv dev-libs/grok
[ebuild  N    ] dev-libs/grok-0.9.2-r1
Comment 1 Toralf Förster gentoo-dev 2017-11-21 18:26:12 UTC
Created attachment 505446 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-11-21 18:26:15 UTC
Created attachment 505448 [details]
dev-libs:grok-0.9.2-r1:20171121-113038.log
Comment 3 Toralf Förster gentoo-dev 2017-11-21 18:26:18 UTC
Created attachment 505450 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-11-21 18:26:21 UTC
Created attachment 505452 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-11-21 18:26:24 UTC
Created attachment 505454 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-11-21 18:26:27 UTC
Created attachment 505456 [details]
temp.tbz2
Comment 7 Andreas K. Hüttel gentoo-dev 2018-04-22 16:01:02 UTC
*** Bug 644676 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2018-05-05 15:34:45 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=62601511e80a9c080934c2f74ff2ebd15faefab2

commit 62601511e80a9c080934c2f74ff2ebd15faefab2
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-05-05 15:33:53 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-05-05 15:34:24 +0000

    dev-libs/grok: Fix build with glibc-2.26, bug 638372
    
    Also fix libdir, bug 628048
    This still needs stabilization together with glibc-2.26.
    
    Closes: https://bugs.gentoo.org/628048
    Bug: https://bugs.gentoo.org/638372
    Package-Manager: Portage-2.3.33, Repoman-2.3.9

 dev-libs/grok/files/grok-0.9.2-libdir.patch   | 28 +++++++++++++++++
 dev-libs/grok/files/grok-0.9.2-libtirpc.patch | 21 +++++++++++++
 dev-libs/grok/grok-0.9.2-r2.ebuild            | 45 +++++++++++++++++++++++++++
 3 files changed, 94 insertions(+)
Comment 9 Pacho Ramos gentoo-dev 2018-05-24 18:06:19 UTC
together with newer glibc or it can be done before?
Thanks
Comment 10 Stabilization helper bot gentoo-dev 2018-05-28 15:01:39 UTC
An automated check of this bug failed - repoman reported dependency errors (117 lines truncated): 

> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/rpcsvc-proto-1', '>=dev-util/gperf-3.1']
> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/rpcsvc-proto-1']
> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=net-libs/rpcsvc-proto-1', '>=dev-util/gperf-3.1']
Comment 11 Stabilization helper bot gentoo-dev 2018-05-28 16:01:43 UTC
An automated check of this bug failed - repoman reported dependency errors (117 lines truncated): 

> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/rpcsvc-proto-1', '>=dev-util/gperf-3.1']
> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/rpcsvc-proto-1']
> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=net-libs/rpcsvc-proto-1', '>=dev-util/gperf-3.1']
Comment 12 Stabilization helper bot gentoo-dev 2018-06-28 16:00:25 UTC
An automated check of this bug failed - repoman reported dependency errors (51 lines truncated): 

> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: arm(default/linux/arm/13.0) ['>=net-libs/rpcsvc-proto-1']
> dependency.bad dev-libs/grok/grok-0.9.2-r2.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['>=net-libs/rpcsvc-proto-1']
> dependency.badindev dev-libs/grok/grok-0.9.2-r2.ebuild: DEPEND: arm(default/linux/arm/13.0/armv4) ['>=net-libs/rpcsvc-proto-1']
Comment 13 Thomas Deutschmann gentoo-dev Security 2018-07-04 03:17:45 UTC
x86 stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-09 15:22:12 UTC
amd64 stable
Comment 15 Pacho Ramos gentoo-dev 2018-07-10 14:24:24 UTC
*** Bug 660332 has been marked as a duplicate of this bug. ***
Comment 16 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-22 15:22:54 UTC
arm stable
Comment 17 Matt Turner gentoo-dev 2019-01-02 02:31:14 UTC
hppa stable