Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63732 - xorg-x11-6.8.0 + keyboard LEDs.
Summary: xorg-x11-6.8.0 + keyboard LEDs.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords: Inclusion
: 78583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-11 19:47 UTC by dynamotwain
Modified: 2007-08-02 00:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch-xorg-kbd (patch-xorg-kbd,883 bytes, text/plain)
2007-02-05 19:18 UTC, Sebastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dynamotwain 2004-09-11 19:47:09 UTC
After switching VTs, all keyboard LEDs turn off.

Reproducible: Always
Steps to Reproduce:
1. emerge xorg-x11-6.8.0 (Using nvidia drivers if it matters)
2. Start up X, turn on numlock and capslock. (Scroll lock doesn't turn on, but it doesn't make much sense in X anyway.)
3. Switch to any non-X VT. (Lights go to correct settings for VT.)
4. Switch back to X's VT. (Keyboard lights resume to where they were before the switch.)
5. Wait about a second. (Keyboard LEDs all turn off.)


Actual Results:  
Keyboard LEDs turn off upon VT switching back into X.

Expected Results:  
Keyboard LEDs should stay on when appropriate settings are on.
If I have CapsLock on, switch to a non-X11 vt, and switch back, I'd expect the
CapsLock light to stay on.

Portage 2.0.50-r11 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.6)
=================================================================
System uname: 2.6.6 i686 Intel(R) Celeron(R) CPU 2.40GHz
Gentoo Base System version 1.4.9
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /etc/tomcat /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/
http://gentoo.mirrors.pair.com/ http://lug.mtu.edu/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3ds S3TC X X509 Xaw3d aalib acl acpi acpi4linux alsa apache2 apm arts avi
berkdb bitmap-fonts bonobo cdr crypt cups curl dga directfb dv dvd dvdr encode
esd ethereal evms2 fax fbcon ffmpeg fftw flac flash foomaticdb freetype gd gdbm
gif gimpprint ginac gnome gphoto2 gpm gtk gtk2 gtkhtml guile imap imlib jabber
java javascript jikes joystick jpeg kde ladcca ldap libcaca libg++ libwww lirc
live lzo mad maildir mdb mikmod mmx mng motif mozsvg mozxmlterm mpeg mpeg4 mpi
msn music mysql mythtv nagios-dns nagios-ntp nagios-ping nagios-ssh ncurses
network nls nvidia offensive oggvorbis openal opengl oscar oss pam pda pdflib
perl php png ppds python qt quicktime readline roundrobin rtc samba scanner sdk
sdl skey slang slp snmp speex spell sse sse2 ssl svg svga tcltk tcpd tetex
theora tiff timidity transcode transparent-proxy truetype usb v4l v4l2 videos
vim-with-x wmf wxwindows x86 xinerama xml2 xmms xosd xprint xv xvid zlib zvbi"
Comment 1 Andrew Gaffney (RETIRED) gentoo-dev 2004-09-20 02:01:18 UTC
I can confirm this with xorg-x11-6.8.0-r1 on x86 (kernel 2.6.5-gentoo-r1 if it matters). When I switch to a virtual console and then back into X, the keyboard's lights all turn off. Although, it seems to just be a superficial bug as the states are restored (numlock is still on, even though the light isn't....hitting the numlock button twice (turn it off and then back on) makes the light comes on).
Comment 2 Victor Ashirov 2005-06-06 11:56:30 UTC
Had the same.
xorg-x11-6.8.2-r2, nvidia (also tried nv)
Sometimes leds restore when closing some app (e.g. XMMS).
Comment 3 Andrew Gaffney (RETIRED) gentoo-dev 2005-06-06 12:29:19 UTC
I can't confirm if this is still a problem for me since my current keyboard
(wireless) doesn't have LEDs. Even if it was a problem, I wouldn't care since I
have no LEDs to not turn on :)
Comment 4 Nickolay L. Selikhov 2005-06-06 12:41:16 UTC
I've this problem to =(

kolyan@manjakws:~]$ qpkg -v -I | grep x11
x11-misc/ttmkfdir-3.0.9-r3 *
x11-misc/shared-mime-info-0.14-r2 *
x11-misc/xautolock-2.1 *
x11-misc/gdeskcal-0.57.1 *
x11-misc/xxkb-1.10 *
x11-base/xorg-x11-6.8.2-r1 *
x11-base/opengl-update-2.2.1 *
x11-terms/xterm-200-r1 *
x11-libs/gtk+-2.6.4-r1 *
x11-libs/qt-3.3.4-r3 *
x11-libs/gtkglarea-1.99.0 *
x11-libs/gtk+-1.2.10-r11 *
x11-libs/fltk-1.1.4 *
x11-libs/pango-1.8.1 *
x11-libs/libdockapp-0.5.0-r1 *
x11-libs/startup-notification-0.8 *
x11-libs/gtkglarea-1.2.3-r1 *
x11-libs/xosd-2.2.8-r1 *
x11-libs/openmotif-2.2.3-r3 *
x11-themes/gtk-engines-metal-2.2.0 *
x11-themes/gtk-engines-2.2.0 *
x11-themes/hicolor-icon-theme-0.5 *
x11-themes/gnome-icon-theme-2.8.0 *
x11-themes/mplayer-skins-0.2-r3 *
x11-themes/gnome-themes-2.8.2 *

# emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11.9 i686)
=================================================================
System uname: 2.6.11.9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  2 2005, 00:41:18)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.5, 1.6.3, 1.4_p6, 1.8.5-r3
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=i686 -mcpu=pentium4 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac aalib alib alsa apm avi berkdb bitmap-fonts bluetooth bzlib cdr
crypt ctype cups curl divx4linux dvd dvdr emboss emu10k1 encode esd fam flac
foomaticdb fortran gd gdbm gif gimpprint gnome gpm gtk gtk2 gtkhtml guile iconv
imagemagick imap imlib java jpeg kde libg++ libwww linguas_ru mad mikmod mmx
mmx2 motif mp3 mpeg ncurses network nls nptl nptlonly nvidia odbc ogg oggvorbis
openalopengl orbit oss pam pdflib perl png pnp posix ppd python qt quicktime
readlineruby samba scanner sdl shared slang snmp sockets sox spell sse ssl svga
tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode usb vim-with-x
vorbis xml xml2 xmms xosd xpm xsl xv xvid zlib video_cards_nvidia userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 5 Dmitry 'DiSH' Shkolnikov 2005-06-06 14:04:09 UTC
The same problem
Using i915 kernel module driver (intel 855 chipset)
Comment 6 Joshua Baergen (RETIRED) gentoo-dev 2005-06-06 19:54:58 UTC
Could someone please try 6.8.99.8?  If the issue still exists I'd be much
obliged if you could post the bug upstream and let us know here.
Comment 7 Victor Ashirov 2005-06-07 14:31:47 UTC
Solution is easy.
Add to your xorg.conf in section "InputDevice" line

Option "Xleds"      "1 2 3"
Comment 8 Joshua Baergen (RETIRED) gentoo-dev 2005-06-10 20:46:12 UTC
Hmm, that line allows xset to control the keyboard LEDs, indicating that X uses
xset to restore LEDs on restore.  Somewhere in the X code it turns off the
keyboard LEDs then relies on that command to set them properly.

I don't think that requiring that line in your Xorg is really a fix, more like a
workaround.  Again, I'd be interested to know if this problem still exists in
6.8.99.8.
Comment 9 Victor Ashirov 2005-06-12 11:25:44 UTC
This problem still exists in xorg-6.8.99.8. "Xleds" trick helps again.
AFAIR xorg-6.7.x hasn't this problem, but I can't test it now. Something in xkb 
code is broken. Or it's a new feature =)
Comment 10 Tres 'RiverRat' Melton 2005-07-10 01:17:55 UTC
This problem has been around for at least the last 10 years and it isn't totally
X related.  It has to do with Linux's virtual terminals.  When changing virtual
terminals the state is saved and restored upon switching but X keeps the state
of CAPS-LOCK, SCROLL-LOCK, and NUM-LOCK stored internally so the virtual console
code in Linux can't get the state to restore it.

The solution is either for X to keep the linux virtual terminal informed of the
state so the VT code can restore them or for the VT code to inform X that it is
once again the controlling terminal so that X can restore them.
Comment 11 Joshua Baergen (RETIRED) gentoo-dev 2005-07-12 16:29:37 UTC
*** Bug 78583 has been marked as a duplicate of this bug. ***
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2005-09-07 09:13:28 UTC
This is an upstream bug.
Comment 13 Sebastian 2007-02-05 19:17:11 UTC
Hi there,

there's a patch upstream at https://bugs.freedesktop.org/show_bug.cgi?id=313
I think it didn't make it into xorg-7.2 (patch dated 2007-01-14). Could you guys please include it?

Regards
Sebastian
Comment 15 Sebastian 2007-02-05 19:28:58 UTC
Tried the patch. Applied and compiled with xf86-input-keyboard-1.1.0 but LED still stays dead :( Oh well.

Regards
Comment 16 Sebastian 2007-02-05 19:48:46 UTC
Ah, stupid me - patch works. I forgot to remove "--dry-run" from my patch command x-) My oh my...

Regards
Sebastian
Comment 17 Donnie Berkholz (RETIRED) gentoo-dev 2007-02-05 21:01:11 UTC
We're waiting on upstream inclusion.
Comment 18 Joshua Baergen (RETIRED) gentoo-dev 2007-04-06 21:31:26 UTC
This patch has been included upstream:

http://gitweb.freedesktop.org/?p=users/cloos/xf86-input-keyboard.git;a=commit;h=05dd89ef03cee6853e7c2db518b6b22785cc3e7c
Comment 19 Donnie Berkholz (RETIRED) gentoo-dev 2007-08-01 21:26:50 UTC
How much of an issue is this with 1.2.1? It looks like some fixes made it into the release, but some might not be there yet.

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-input-keyboard.git;a=summary has the commit history.
Comment 20 Donnie Berkholz (RETIRED) gentoo-dev 2007-08-02 00:03:53 UTC
Eh, nevermind the previous comment. I added a couple patches to 1.1.1-r1 and 1.2.0-r1 that should fix your issue.