Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 78583 - numlock indicator is off but numlock is on after switching from VT to X11
Summary: numlock indicator is off but numlock is on after switching from VT to X11
Status: RESOLVED DUPLICATE of bug 63732
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-18 14:30 UTC by Rickard Närström
Modified: 2005-07-12 16:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rickard Närström 2005-01-18 14:30:22 UTC
sorry for the confusing summery but I diden't find an easy way to explain this bug in just a few words. Here is a full explanation:

I have numlockx to start when starting gdm, and I have /etc/init.d/numlock to my boot runlevel (I don't think this have anything with this bug to do)

when X is started I can change to a VT with ctrl+alt+Fn (no problem there)
when I then change back to X with ctrl+alt+F7 the numlock indekator is turned off. (NOTE: just the indekator I can still write numbers juing the numpad)
To make the indekator turned on again I have to press the numlock key twice (one to shut off numlock and one to turn it on again).

Reproducible: Always
Steps to Reproduce:
1. start X
2. make sure numlock is turned on
3. switch to VT using ctrl+alt+Fn
4. switch back to X using ctrl+alt+F7

Actual Results:  
the numlock indekator is turned off

Expected Results:  
the numlock indekator shuld stay on (or turn on if you don't have numlock in
your VT)

# X -version
This is a pre-release version of the The X.Org Foundation X11.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the The X.Org Foundation "monolithic tree" CVS
repository hosted at http://www.freedesktop.org/Software/xorg/
X Window System Version 6.8.1.902 (6.8.2 RC 2)
Release Date: 12 January 2005
X Protocol Version 11, Revision 0, Release 6.8.1.902
Build Operating System: Linux 2.6.10-gentoo-r2 x86_64 [ELF]
Current Operating System: Linux rickard 2.6.10-gentoo-r5 #1 SMP Tue Jan 18
22:35:37 CET 2005 x86_64
Build Date: 17 January 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
# emerge info
Portage 2.0.51-r13 (default-linux/amd64/2004.3, gcc-3.4.3,
glibc-2.3.4.20041102-r0, 2.6.10-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.10-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 22 2004, 17:04:02)]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1, 2.15.92.0.2-r2
sys-devel/libtool:   1.5.10-r2
virtual/os-headers:  2.6.8.1-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon64 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
GENTOO_MIRRORS="ftp://mirror.pudas.net/gentoo http://mirror.pudas.net/gentoo
http://trumpetti.atm.tut.fi/gentoo/ ftp://ftp.du.se/pub/os/gentoo
http://ftp.du.se/pub/os/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="amd64 X aalib acpi alsa apache2 audiofile avi berkdb bitmap-fonts bonobo
cdparanoia cdr cjk crypt cups divx4linux dvd dvdr emul-linux-x86 encode esd f77
fam fla flac font-server fortran ftp gcj gdbm gif gnome gpm gtk gtk2 gtkhtml
imagemagick imlib insecure-drivers java jp2 jpeg junit libwww lzw lzw-tiff mad
mikmod mpeg msn multilib mysql ncurses network nls no-old-linux offensive
oggvorbis opengl operanom2 pdflib php png posix pthreads python radeon readline
rtc samba sdl slang sockets spell ssl tcltk tcpd tiff truetype truetype-fonts
type1-fonts unicode usb userlocales vanilla videos vim xine xml xml2 xpm xrandr
xv xvid zlib"
Unset:  LDFLAGS
Comment 1 Olivier Crete (RETIRED) gentoo-dev 2005-01-20 12:35:10 UTC
hmm.. seems like an X problem..
Comment 2 Rickard Närström 2005-01-20 14:23:01 UTC
I found this if it can be of any help:
https://bugs.freedesktop.org/show_bug.cgi?id=1530
Comment 3 Tres 'RiverRat' Melton 2005-07-10 16:20:32 UTC
This is a duplicate of Bug #63732
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2005-07-12 16:29:37 UTC
Indeed it is; thank you.

*** This bug has been marked as a duplicate of 63732 ***