Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 635216 - net-mail/mailutils keyword request
Summary: net-mail/mailutils keyword request
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Eray Aslan
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 654992
Blocks:
  Show dependency tree
 
Reported: 2017-10-23 19:28 UTC by Ulrich Müller
Modified: 2019-05-18 10:55 UTC (History)
4 users (show)

See Also:
Package list:
net-mail/mailutils-3.4-r3 amd64-fbsd x86-fbsd
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2017-10-23 19:28:42 UTC
mailutils are required as dependency by app-editors/emacs-vcs (and will soon be by app-editors/emacs). However, repoman -d reports that the following keywords are missing:
~alpha ~arm ~ia64 ~ppc64 ~amd64-fbsd ~x86-fbsd

Is it OK to CC arches?
Comment 1 Larry the Git Cow gentoo-dev 2017-10-23 19:53:10 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8aa0926f76d06bfb75cc5012f0a5cc7aa5da2653

commit 8aa0926f76d06bfb75cc5012f0a5cc7aa5da2653
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2017-10-23 19:46:53 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2017-10-23 19:52:22 +0000

    profiles: package.use.mask app-editors/emacs-vcs[mailutils] on various arches.
    
    Bug: https://bugs.gentoo.org/635216

 profiles/arch/alpha/package.use.mask               | 4 ++++
 profiles/arch/amd64-fbsd/package.use.mask          | 6 +++++-
 profiles/arch/arm/package.use.mask                 | 4 ++++
 profiles/arch/ia64/package.use.mask                | 4 ++++
 profiles/arch/powerpc/ppc64/package.use.mask       | 4 ++++
 profiles/arch/x86-fbsd/package.use.mask            | 4 ++++
 profiles/default/linux/uclibc/arm/package.use.mask | 6 +++++-
 7 files changed, 30 insertions(+), 2 deletions(-)}
Comment 2 Eray Aslan gentoo-dev 2017-10-24 06:41:34 UTC
CC'ing arches.  All will have to keyword

net-mail/mailutils
dev-db/kyotocabinet

In addition, amd64-fbsd will need
virtual/mysql
virtual/gsasl
dev-db/tokyocabinet

or mask the corresponding USE flags for their arches.
Comment 3 Sergei Trofimovich gentoo-dev 2017-10-25 21:42:54 UTC
~ia64 keyworded
Comment 4 Sergei Trofimovich gentoo-dev 2017-10-29 11:37:28 UTC
~ppc64 keyworded
Comment 5 Larry the Git Cow gentoo-dev 2018-04-09 22:24:39 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0dbdc7826646ceff6e91f14ea52db362657b4983

commit 0dbdc7826646ceff6e91f14ea52db362657b4983
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2018-04-09 22:15:16 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2018-04-09 22:23:08 +0000

    profiles: package.use.mask app-editors/emacs[mailutils].
    
    emacs:26 now supports the mailutils flag, so emacs must be masked in
    addition to emacs-vcs.
    
    Bug: https://bugs.gentoo.org/635216

 profiles/arch/alpha/package.use.mask               | 1 +
 profiles/arch/amd64-fbsd/package.use.mask          | 1 +
 profiles/arch/arm/package.use.mask                 | 1 +
 profiles/arch/x86-fbsd/package.use.mask            | 1 +
 profiles/default/linux/uclibc/arm/package.use.mask | 1 +
 5 files changed, 5 insertions(+)}
Comment 6 Markus Meier gentoo-dev 2018-04-14 11:25:19 UTC
~arm added.
Comment 7 Stabilization helper bot gentoo-dev 2018-04-26 15:02:44 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad virtual/gsasl/gsasl-2.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['net-libs/libgsasl']
> dependency.bad virtual/mysql/mysql-5.6-r10.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['=dev-db/mariadb-10.2*[embedded(-)?,server?,static?]']
Comment 8 Stabilization helper bot gentoo-dev 2018-04-26 19:00:04 UTC
An automated check of this bug failed - the following atoms are unknown:

net-libs/libgsasl
dev-db/mariadb

Please verify the atom list.
Comment 9 Stabilization helper bot gentoo-dev 2018-04-26 20:00:38 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad dev-db/mariadb/mariadb-10.2.14.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['sys-libs/cracklib:0=']
> dependency.bad dev-db/mariadb/mariadb-10.2.14.ebuild: PDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['>=dev-perl/DBD-mysql-2.9004', 'dev-db/mariadb-connector-c[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'dev-db/mysql-connector-c[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad dev-db/mariadb/mariadb-10.2.14.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['dev-db/mysql-init-scripts', 'sys-libs/cracklib:0=']
> dependency.bad virtual/mysql/mysql-5.6-r10.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['=dev-db/mariadb-10.2*[embedded(-)?,server?,static?]']
> dependency.bad net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild: DEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['net-libs/libntlm']
> dependency.bad net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild: RDEPEND: ~amd64-fbsd(default/bsd/fbsd/amd64/11.1) ['net-libs/libntlm']
Comment 10 Ulrich Müller gentoo-dev 2018-04-26 20:32:07 UTC
Giving up on amd64-fbsd for now.
Comment 11 Larry the Git Cow gentoo-dev 2018-06-22 20:40:06 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=db54a44736795d04e7c3aa584cff582e2a7f2351

commit db54a44736795d04e7c3aa584cff582e2a7f2351
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-06-22 20:35:52 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-22 20:39:41 +0000

    net-mail/mailutils: keyworded 3.4-r2 for sparc
    
    Bug: https://bugs.gentoo.org/635216
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 net-mail/mailutils/mailutils-3.4-r2.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 12 Tobias Klausmann gentoo-dev 2018-10-16 09:19:57 UTC
Keyworded on ~alpha.
Comment 13 Larry the Git Cow gentoo-dev 2018-12-25 12:54:31 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=73a71dda414538b23524b210fe1d7ebb7f6b5466

commit 73a71dda414538b23524b210fe1d7ebb7f6b5466
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2018-12-25 12:47:21 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2018-12-25 12:53:49 +0000

    profiles: Move app-editors/emacs[mailutils] to stable mask on alpha.
    
    net-mail/mailutils has been keyworded on ~alpha some time ago.
    
    Bug: https://bugs.gentoo.org/635216
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 profiles/arch/alpha/package.use.mask        | 5 -----
 profiles/arch/alpha/package.use.stable.mask | 5 +++--
 2 files changed, 3 insertions(+), 7 deletions(-)