Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634514 - dev-db/mysql-5.6.37 with sys-devel/gcc-7.2.0 - .../work/mysql/sql-common/client_authentication.cc:87:59: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
Summary: dev-db/mysql-5.6.37 with sys-devel/gcc-7.2.0 - .../work/mysql/sql-common/clie...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 638256 (view as bug list)
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-10-17 07:28 UTC by Christian Strahl
Modified: 2017-11-21 15:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (mysql-5.6.37-build.log,691.42 KB, text/x-log)
2017-10-17 07:31 UTC, Christian Strahl
Details
mysql-5.6.37-gcc7.patch (mysql-5.6.37-gcc7.patch,485 bytes, patch)
2017-10-17 07:33 UTC, Christian Strahl
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Strahl 2017-10-17 07:28:03 UTC
dev-db/mysql-5.6.37 fails to build with gcc-7.2.0

work/mysql/sql-common/client_authentication.cc:87:59: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
       mysql->options.extension->server_public_key_path != '\0')
                                                           ^~~~


Reproducible: Always
Comment 1 Christian Strahl 2017-10-17 07:31:49 UTC
Created attachment 498942 [details]
build.log
Comment 2 Christian Strahl 2017-10-17 07:33:58 UTC
Created attachment 498944 [details, diff]
mysql-5.6.37-gcc7.patch

the attached patch fixes this bug, please add it to the ebuild
Comment 3 Christian Strahl 2017-10-17 07:37:50 UTC
This is the same bug as in #618054, but for a different package.

The attached patch works for both packages, because the codebase seems to be the same.
Comment 4 Piotr Stachura 2017-10-20 05:54:16 UTC
Issue and fix confirmed on dev-db/mysql-5.6.38
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2017-11-20 21:04:00 UTC
*** Bug 638256 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2017-11-21 15:27:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c6a3a38050e112302534fa1392dc5649ca3d4f36

commit c6a3a38050e112302534fa1392dc5649ca3d4f36
Author:     Brian Evans <grknight@gentoo.org>
AuthorDate: 2017-11-21 15:26:43 +0000
Commit:     Brian Evans <grknight@gentoo.org>
CommitDate: 2017-11-21 15:26:43 +0000

    dev-db/mysql: Fix building 5.6.38 on gcc 7
    
    Closes: https://bugs.gentoo.org/634514
    Package-Manager: Portage-2.3.15, Repoman-2.3.6

 dev-db/mysql/Manifest            | 1 +
 dev-db/mysql/mysql-5.6.38.ebuild | 3 ++-
 2 files changed, 3 insertions(+), 1 deletion(-)