Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638256 - dev-db/mysql-5.6.38 - .../work/mysql/sql-common/client_authentication.cc:87:59: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
Summary: dev-db/mysql-5.6.38 - .../work/mysql/sql-common/client_authentication.cc:87:5...
Status: RESOLVED DUPLICATE of bug 634514
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-11-20 17:11 UTC by Toralf Förster
Modified: 2017-11-20 21:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.96 KB, text/plain)
2017-11-20 17:11 UTC, Toralf Förster
Details
dev-db:mysql-5.6.38:20171120-135717.log (dev-db:mysql-5.6.38:20171120-135717.log,630.53 KB, text/plain)
2017-11-20 17:11 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,61.51 KB, text/plain)
2017-11-20 17:11 UTC, Toralf Förster
Details
environment (environment,190.00 KB, text/plain)
2017-11-20 17:11 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.07 KB, application/x-bzip)
2017-11-20 17:11 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,23.75 KB, application/x-bzip)
2017-11-20 17:11 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,80.12 KB, application/x-bzip)
2017-11-20 17:11 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-11-20 17:11:34 UTC
/var/tmp/portage/dev-db/mysql-5.6.38/work/mysql/sql-common/client_authentication.cc: In function ‘RSA* rsa_init(MYSQL*)’:
/var/tmp/portage/dev-db/mysql-5.6.38/work/mysql/sql-common/client_authentication.cc:87:59: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
       mysql->options.extension->server_public_key_path != '\0')
                                                           ^~~~
make[2]: *** [libmysql/CMakeFiles/clientlib.dir/build.make:207: libmysql/CMakeFiles/clientlib.dir/__/sql-common/client_authentication.cc.o] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop-plasma-systemd_test_20171118-222131

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0
 [2] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-db/mysql
[ebuild   R   ] dev-db/mysql-5.6.38  USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -numa -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" ABI_X86="(64) -32 (-x32)"
Comment 1 Toralf Förster gentoo-dev 2017-11-20 17:11:37 UTC
Created attachment 505222 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-11-20 17:11:40 UTC
Created attachment 505224 [details]
dev-db:mysql-5.6.38:20171120-135717.log
Comment 3 Toralf Förster gentoo-dev 2017-11-20 17:11:43 UTC
Created attachment 505226 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-11-20 17:11:46 UTC
Created attachment 505228 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-11-20 17:11:49 UTC
Created attachment 505230 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-11-20 17:11:52 UTC
Created attachment 505232 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-11-20 17:11:55 UTC
Created attachment 505234 [details]
temp.tbz2
Comment 8 Christian Strahl 2017-11-20 20:59:05 UTC
This is a duplicate of #634514.

In #634514 is also a patch for this problem.
Comment 9 Brian Evans Gentoo Infrastructure gentoo-dev 2017-11-20 21:04:00 UTC

*** This bug has been marked as a duplicate of bug 634514 ***