Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625160 - portage does not rebuild := deps in proper order (dev-ml/integers-0.2.2 : Error: The files /usr/lib64/ocaml/findlib/findlib.cma)
Summary: portage does not rebuild := deps in proper order (dev-ml/integers-0.2.2 : Err...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 749555
  Show dependency tree
 
Reported: 2017-07-15 06:59 UTC by Toralf Förster
Modified: 2020-10-19 04:48 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.31 KB, text/plain)
2017-07-15 06:59 UTC, Toralf Förster
Details
dev-ml:integers-0.2.2:20170714-215027.log (dev-ml:integers-0.2.2:20170714-215027.log,2.01 KB, text/plain)
2017-07-15 06:59 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,147.81 KB, text/plain)
2017-07-15 06:59 UTC, Toralf Förster
Details
environment (environment,15.11 KB, text/plain)
2017-07-15 06:59 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,38.72 KB, application/x-bzip)
2017-07-15 06:59 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,6.22 KB, application/x-bzip)
2017-07-15 06:59 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-07-15 06:59:08 UTC
disagree over interface String
File "./pkg/pkg.ml", line 1:
Error: The files /usr/lib64/ocaml/findlib/findlib.cma
       and /usr/lib64/ocaml/topkg/topkg.cmi make inconsistent assumptions
       over interface String
 * ERROR: dev-ml/integers-0.2.2::gentoo failed (compile phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-systemd_20170711-225716

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems)
  [2]   ruby22 (with Rubygems) *
Comment 1 Toralf Förster gentoo-dev 2017-07-15 06:59:11 UTC
Created attachment 484702 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-07-15 06:59:14 UTC
Created attachment 484704 [details]
dev-ml:integers-0.2.2:20170714-215027.log
Comment 3 Toralf Förster gentoo-dev 2017-07-15 06:59:17 UTC
Created attachment 484706 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-07-15 06:59:21 UTC
Created attachment 484708 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-07-15 06:59:24 UTC
Created attachment 484710 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-07-15 06:59:27 UTC
Created attachment 484712 [details]
temp.tbz2
Comment 7 Alexis Ballier gentoo-dev 2017-07-15 10:40:50 UTC
seems a portage bug:

Error: The files /usr/lib64/ocaml/findlib/findlib.cma
       and /usr/lib64/ocaml/topkg/topkg.cmi make inconsistent assumptions

means that you updated dev-lang/ocaml but one of dev-ml/findlib and dev-ml/topkg has been rebuilt with new ocaml but not the other. (most likely findlib has been rebuilt but not topkg)

dev-lang/ocaml has SLOT=0/$PV

dev-ml/integers has build dep on topkg and findlib

dev-ml/topkg has dev-ml/findlib:= and dev-lang/ocaml:= build + run dep
dev-ml/findlib has >=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?] build + run dep


so this seems to me a proper ordering would have been:
update dev-lang/ocaml
rebuild dev-ml/findlib
rebuild dev-ml/topkg
build/rebuild dev-ml/integers


portage seems to have skipped the 'rebuild dev-ml/topkg' step causing this bug
Comment 8 Alexis Ballier gentoo-dev 2017-07-15 10:46:54 UTC
*** Bug 625164 has been marked as a duplicate of this bug. ***
Comment 9 Alexis Ballier gentoo-dev 2017-07-15 10:47:51 UTC
bug #625164 is another occurence of improper rebuild ordering by portage if you need more data/evidence
Comment 10 Sam James archtester gentoo-dev Security 2020-10-17 01:05:51 UTC
A workaround may well end up being some haskell-updater tool for now.
Comment 11 Zac Medico gentoo-dev 2020-10-19 04:31:30 UTC
(In reply to Alexis Ballier from comment #7)
> so this seems to me a proper ordering would have been:
> update dev-lang/ocaml
> rebuild dev-ml/findlib
> rebuild dev-ml/topkg
> build/rebuild dev-ml/integers
> 
> 
> portage seems to have skipped the 'rebuild dev-ml/topkg' step causing this
> bug

It looks like dev-ml/topkg-0.9.0 was rebuilt in emerge-history.txt attached in comment #3.