Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 621320 - app-text/texlive-core-2017 compiled with gcc-7.1.0 does not work for texlive-basic-2017
Summary: app-text/texlive-core-2017 compiled with gcc-7.1.0 does not work for texlive-...
Status: RESOLVED DUPLICATE of bug 621252
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-06-09 16:24 UTC by milan hodoscek
Modified: 2017-06-10 07:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,40.23 KB, text/plain)
2017-06-09 16:27 UTC, milan hodoscek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description milan hodoscek 2017-06-09 16:24:32 UTC
app-text/texlive-core-2017 compiled with gcc-7.1.0 does not work for texlive-basic-2017
                                                                                   
gcc-6.3.0 is OK, so for the time being I created /etc/portage/env/app-text/texlive-core file with the CC="gcc-6.3.0" CXX="g++-6.3.0" in it.                                                                                 
                                                                                                              
texlive-basic can use gcc-7.1.0 then...                                                                       
                                                                                                              
emerge --info texlive-core texlive-basic


Portage 2.3.6 (python 3.5.3-final-0, default/linux/amd64/13.0/systemd, gcc-7.1.0, glibc-2.24-r1, 4.11.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.11.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.3
KiB Mem:     8077812 total,   1672764 free
KiB Swap:   58604540 total,  58203388 free
Timestamp of repository gentoo: Fri, 09 Jun 2017 12:00:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.13::gentoo, 3.5.3::gentoo, 3.6.1-r1::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.27.1::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo, 2.28-r2::gentoo
sys-devel/gcc:            4.9.4::gentoo, 5.4.0-r3::gentoo, 6.3.0::gentoo, 7.1.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl alsa amd64 amr ansi apache2 apng applet audacious audiofile autoipd avahi berkdb bitmapfonts bittorrent branding bzip2 cairo canna cdda cdio cdr cjk clang cli clozurecl clucene cracklib crypt css cups curl cxx daap dbus dconf dcraw declarative device-mapper dga dri dv dvd dvdr dvdread egl emacs emovix eps epspdf exif extensions extras f77 faac faad fastcgi ffmpeg flac fltk fontconfig foomaticdb fortran gd gdbm gdu gegl gif gimp gimpprint gkrellm glamor gles2 glib gnuplot gphoto2 gsf gstreamer gtk gtk3 gudev gzip hwdb hwinfo iapbs iconv icu imagemagick infinality introspection ipod ipv6 java javascript jbig jpeg jpeg2k kde kdenlive kdepim kdrive lapack latex lcms ldap legacy-systray libinput lzma matplotlib matroska mbox mdnsresponder-compat melt minizip mjpeg mng modemmanager modules mozilla mp3 mpm-itk multilib multiuser musepack musicbrainz mysql mysqli ncurses nepomuk network nls nptl nsplugin nss octave offensive ogg oggvorbis openbabel opengl openmp opus pam pcntl pcre pcre16 pdf perl plotutils png pnm policykit posix postscript preview-latex printsupport private-headers pstricks pulseaudio python python3 qml qt3 qt3support qt4 qt5 readline rle rtc sasl scanner script sdl seccomp semantic-desktop session smp sna sndfile sockets socks5 sox spamassassin spell sql sqlite ssl static-libs svc svg systemd tagwriting tcl tcltk tcpd tetex tex tga theora threads tiff tk truetype udev udisks unicode upcall usb uvm vala vcd vdr vhosts vim vim-pager vorbis vpx wayland webkit widgets wmf wxgtk1 x264 xattr xetex xft xinerama xkb xml xmp xvfb xvid xz yv12 zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="us" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.5 3.6"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-text/texlive-core-2017::gentoo was built with the following:
USE="X cjk luajittex tk xetex -doc -source" ABI_X86="(64)"
CXXFLAGS="-O2 -pipe -std=c++11"


dev-texlive/texlive-basic-2017::gentoo was built with the following:
USE="luajittex -doc -source" ABI_X86="(64)"
Comment 1 milan hodoscek 2017-06-09 16:27:14 UTC
Created attachment 475776 [details]
build.log
Comment 2 Alexis Ballier gentoo-dev 2017-06-10 07:50:51 UTC

*** This bug has been marked as a duplicate of bug 621252 ***