Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 621252 - app-text/texlive-core-2017: sys-devel/gcc-7.1.0 miscompiles `luatex` in dev-texlive/texlive-core-2017 causing build failure in dev-texlive/texlive-basic-2017
Summary: app-text/texlive-core-2017: sys-devel/gcc-7.1.0 miscompiles `luatex` in dev-t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
: 621320 (view as bug list)
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-06-08 19:31 UTC by Aric Belsito
Modified: 2017-06-10 07:50 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix luatex alignment with gcc7 (0001_fix-gcc-7_align.patch,849 bytes, patch)
2017-06-09 12:04 UTC, Steffen Hau
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aric Belsito 2017-06-08 19:31:22 UTC
Title says it all.

I had to switch back to gcc-6.3.0 in order to continue the update.
Comment 1 Aric Belsito 2017-06-08 19:33:22 UTC
$ emerge --info
Portage 2.3.6 (python 3.6.1-final-0, hardened/linux/musl/amd64, gcc-7.1.0, musl-1.1.16, 4.9.24-hardened x86_64)
=================================================================
System uname: Linux-4.9.24-hardened-x86_64-Intel-R-_Core-TM-_i5-4210U_CPU_@_1.70GHz-with-gentoo-2.3
KiB Mem:     5994428 total,    599676 free
KiB Swap:   12582908 total,  12582908 free
Timestamp of repository gentoo: Thu, 08 Jun 2017 15:54:10 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.13::gentoo, 3.6.1-r1::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r4::musl
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            6.3.0::musl, 7.1.0-r1::musl
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::musl (virtual/os-headers)
sys-libs/musl:            1.1.16::musl-extras
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo/gentoo.git
    priority: -1000

libressl
    location: /var/lib/layman/libressl
    masters: gentoo
    priority: 50

musl
    location: /var/lib/layman/musl
    masters: gentoo
    priority: 50

musl-extras
    location: /var/lib/layman/musl-extras
    masters: gentoo musl
    priority: 50

local
    location: /usr/local/portage
    masters: gentoo libressl musl
    priority: 100

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-gentoo-linux-musl"
CFLAGS="-march=native -O2 -pipe -floop-nest-optimize"
CHOST="x86_64-gentoo-linux-musl"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/i2pd/certificates"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -floop-nest-optimize"
DISTDIR="/var/cache/distfiles"
FCFLAGS="-march=native -O2 -pipe -floop-nest-optimize"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe -floop-nest-optimize"
GENTOO_MIRRORS="https://mirrors.kernel.org/gentoo/"
INSTALL_MASK="charset.alias"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X alsa amd64 berkdb cli cracklib crypt custom-cflags cxx dbus dri fortran hardened iconv icu ipv6 jpeg libressl modules ncurses nls nptl opengl openmp openssl pax_kernel pcre pic png readline seccomp session ssl tcpd threads tiff unicode xattr zlib zsh-completion" ABI_X86="64" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 f16c" CURL_SSL="libressl" ELIBC="musl" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en_US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="i386 x86_64" RUBY_TARGETS="ruby24" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Steffen Hau 2017-06-09 12:04:29 UTC
Created attachment 475708 [details, diff]
fix luatex alignment with gcc7
Comment 3 Steffen Hau 2017-06-09 12:05:18 UTC
There's a patch and an explanation available on http://www.tug.org/pipermail/tex-live/2017-June/040192.html. Applying the patch makes luatex no longer segfaulting.
Comment 4 Alexis Ballier gentoo-dev 2017-06-09 12:55:00 UTC
applied in texlive-core-2017-r1, thanks
Comment 5 Alexis Ballier gentoo-dev 2017-06-10 07:50:51 UTC
*** Bug 621320 has been marked as a duplicate of this bug. ***