Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620832 - net-im/err[qt4] depends on dev-qt/qtwebkit:4 via dev-python/pyside[webkit]
Summary: net-im/err[qt4] depends on dev-qt/qtwebkit:4 via dev-python/pyside[webkit]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergey Popov
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qtwebkit4-removal
  Show dependency tree
 
Reported: 2017-06-04 17:47 UTC by Andreas Sturmlechner
Modified: 2017-06-08 01:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2017-06-04 17:47:38 UTC
net-im/err depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

If there's no upstream port available, I'd suggest to remove the USE flag.
Comment 1 Sergey Popov gentoo-dev Security 2017-06-08 01:27:14 UTC
commit 1783fcaae0c9670e4c23a01979b0d32bc945dcd7
Author: Sergey Popov <pinkbyte@gentoo.org>
Date:   Thu Jun 8 04:19:46 2017 +0300

    net-im/err: remove support for GUI console, which relies on ancient qtwebkit
    
    Add missing USE-flag dependency for specific Python version on dev-python/xmpppy
    
    Gentoo-Bug: 620832
    
    Package-Manager: Portage-2.3.6, Repoman-2.3.1