Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 620684 (qtwebkit4-removal) - [TRACKER] Packages still using dev-qt/qtwebkit:4
Summary: [TRACKER] Packages still using dev-qt/qtwebkit:4
Status: RESOLVED FIXED
Alias: qtwebkit4-removal
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL: https://github.com/gentoo/gentoo/pull...
Whiteboard:
Keywords: PMASKED, Tracker
Depends on: 608606 620686 620688 620690 620692 620694 620696 620698 620700 620702 620704 620706 620708 620710 620712 620714 620716 620722 620724 620726 620728 620730 620734 620736 620740 620742 620744 620746 620748 620750 620752 620754 620756 620758 620760 620792 620816 620820 620822 620826 620828 620830 620832 620836 621550 621552 621556 621558 621560 622684 622704 622708 623928 624194 624196 624244 625260 631806 634280
Blocks: 524584 544334 qt4-removal
  Show dependency tree
 
Reported: 2017-06-04 06:23 UTC by Michael Palimaka (kensington)
Modified: 2018-01-13 00:45 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-06-04 06:23:01 UTC
dev-qt/qtwebkit:4 is ancient and is likely to have more holes in it than swiss cheese. Nobody should use it anymore.
Comment 1 Alex Belykh 2017-06-04 14:58:56 UTC
You don't seem to have created bugs for things that depend on qtwebkit transitively, e.g. stuff depending on PyQt4 with webkit use flag.
Comment 2 Andreas Sturmlechner gentoo-dev 2017-10-14 21:49:39 UTC
Rdeps mask list: https://github.com/gentoo/gentoo/pull/5945
Comment 3 Andreas Sturmlechner gentoo-dev 2017-11-10 21:45:32 UTC
Ready for last-rites?
Comment 4 Larry the Git Cow gentoo-dev 2017-11-16 18:55:35 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7e799631b67e2fc4dab217b90720b3ad7eeaa347

commit 7e799631b67e2fc4dab217b90720b3ad7eeaa347
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-11-16 18:52:49 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-11-16 18:55:11 +0000

    profiles: Initiate last-rites for Qt4WebKit and remaining rdeps
    
    Bug: https://bugs.gentoo.org/620684
    Bug: https://bugs.gentoo.org/620702
    Bug: https://bugs.gentoo.org/620736
    Bug: https://bugs.gentoo.org/620826

 profiles/package.mask | 30 +++++++++++++++++++-----------
 1 file changed, 19 insertions(+), 11 deletions(-)}
Comment 5 Larry the Git Cow gentoo-dev 2018-01-06 11:41:12 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=893b23bb814213d1c0465d97d14c9cbf74f48fce

commit 893b23bb814213d1c0465d97d14c9cbf74f48fce
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2018-01-06 11:40:26 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2018-01-06 11:40:59 +0000

    dev-qt/qtwebkit: Drop obsolete qtwebkit:4 packages
    
    Bug: https://bugs.gentoo.org/620684
    Package-Manager: Portage-2.3.13, Repoman-2.3.3

 dev-qt/qtwebkit/Manifest                           |   2 -
 dev-qt/qtwebkit/files/4.10.4-gcc5.patch            |  35 ------
 .../files/4.10.4-use-correct-icu-typedef.patch     |  40 -------
 .../qtwebkit/files/4.8.2-javascriptcore-x32.patch  |  11 --
 dev-qt/qtwebkit/metadata.xml                       |   2 -
 dev-qt/qtwebkit/qtwebkit-4.10.4.ebuild             | 125 ---------------------
 dev-qt/qtwebkit/qtwebkit-4.8.7.ebuild              |  69 ------------
 7 files changed, 284 deletions(-)}