Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 620756 - www-client/dooble depends on dev-qt/qtwebkit:4
Summary: www-client/dooble depends on dev-qt/qtwebkit:4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Richard Yao
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qtwebkit4-removal
  Show dependency tree
 
Reported: 2017-06-04 08:00 UTC by Michael Palimaka (kensington)
Modified: 2017-08-12 14:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dooble-cleanup.patch (dooble-cleanup.patch,7.71 KB, patch)
2017-08-04 18:03 UTC, Andreas Sturmlechner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-06-04 08:00:11 UTC
www-client/dooble depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

Since 1.56c has a qt5 USE flag, I'd suggest removing both and just building qt5, as well as removing older versions.
Comment 1 Andreas Sturmlechner gentoo-dev 2017-07-30 17:51:46 UTC
Is there anything stopping us from dropping USE=qt4?
Comment 2 Andreas Sturmlechner gentoo-dev 2017-08-04 18:03:57 UTC
Created attachment 487950 [details, diff]
dooble-cleanup.patch
Comment 3 Andreas Sturmlechner gentoo-dev 2017-08-12 14:45:19 UTC
As of git commits 6787c3c2dbb8cd97b6d03a83fe20f929b6472ef2 and e9f2166473f13a152c6eb1e28743a3be2a213f6e, Qt4 deps have been dropped.