Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 620742 - net-voip/vidyodesktop depends on dev-qt/qtwebkit:4
Summary: net-voip/vidyodesktop depends on dev-qt/qtwebkit:4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard: Masked for removal on 2017-11-30
Keywords: PMASKED
Depends on:
Blocks: qtwebkit4-removal
  Show dependency tree
 
Reported: 2017-06-04 07:42 UTC by Michael Palimaka (kensington)
Modified: 2017-11-29 23:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-06-04 07:42:35 UTC
net-voip/vidyodesktop  depends on dev-qt/qtwebkit:4 which is ancient and will never see any security updates.

Since this appears to be a binary-only package, I'm not sure what can be done about it long term, especially considering that Qt 4 is also dead.
Comment 1 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2017-06-05 15:27:45 UTC
My suggestion is to mask it with the other packages that will need to be deprecated at the same time.
Comment 2 Andreas Sturmlechner gentoo-dev 2017-10-25 19:12:06 UTC
And masked it was. qtwebkit:4 won't be around for much longer...
Comment 3 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2017-10-25 19:26:45 UTC
wfm, upstream hasn't made a release in quite a while
Comment 4 Larry the Git Cow gentoo-dev 2017-11-29 23:19:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d60617bb5c7260e18ef0811794c0df745521d6cf

commit d60617bb5c7260e18ef0811794c0df745521d6cf
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-11-29 23:14:45 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-11-29 23:19:21 +0000

    profiles: Remove last-rited packages
    
    Closes: https://bugs.gentoo.org/620708
    Closes: https://bugs.gentoo.org/620742

 app-crypt/kencfs/Manifest                          |  1 -
 app-crypt/kencfs/files/kencfs-1.4.0-encfs5.patch   | 13 ----
 app-crypt/kencfs/files/kencfs-1.6.2-desktop.patch  | 11 ---
 app-crypt/kencfs/kencfs-1.6.4.ebuild               | 45 ------------
 app-crypt/kencfs/metadata.xml                      |  8 ---
 media-sound/google-musicmanager/Manifest           |  6 --
 .../google-musicmanager-1.0.129.6633_beta.ebuild   | 82 ----------------------
 .../google-musicmanager-1.0.221.5230_beta.ebuild   | 80 ---------------------
 .../google-musicmanager-1.0.243.1116_beta.ebuild   | 80 ---------------------
 media-sound/google-musicmanager/metadata.xml       | 11 ---
 net-voip/vidyodesktop/Manifest                     |  4 --
 net-voip/vidyodesktop/metadata.xml                 | 11 ---
 .../vidyodesktop/vidyodesktop-3.6.3.017.ebuild     | 74 -------------------
 .../vidyodesktop/vidyodesktop-3.6.7.010.ebuild     | 74 -------------------
 profiles/package.mask                              | 16 -----
 15 files changed, 516 deletions(-)