Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 615876 - media-libs/tiff-4.0.7-r3 with GCC 6.3 Graphite - Internal Compiler Error in add_loop_constraints building
Summary: media-libs/tiff-4.0.7-r3 with GCC 6.3 Graphite - Internal Compiler Error in a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 619476 (view as bug list)
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-04-17 17:35 UTC by causality
Modified: 2017-09-26 18:25 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
55_all_gcc-6-pr71824.patch (55_all_gcc-6-pr71824.patch,3.97 KB, patch)
2017-05-07 04:15 UTC, Peter Levine
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description causality 2017-04-17 17:35:16 UTC
On ~amd64 system, GCC 6.3:  media-libs/tiff-4.0.7-r3 fails to build with GCC Graphite CFLAGS.  Emerge prints a message directly requesting a bug report.  This is the last portion of the build output:

-----

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools -I../libtiff  -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/libtiff   -march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution -Wall -W -c -o tiffcp.o /var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiffcp.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools -I../libtiff  -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/libtiff   -march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution -Wall -W -c -o tiffcrop.o /var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiffcrop.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools -I../libtiff  -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/libtiff   -march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution -Wall -W -c -o tiffdither.o /var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiffdither.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools -I../libtiff  -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/libtiff   -march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution -Wall -W -c -o tiffdump.o /var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiffdump.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools -I../libtiff  -I/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/libtiff   -march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution -Wall -W -c -o tiffinfo.o /var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiffinfo.c
/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiff2pdf.c: In function ‘t2p_compose_pdf_page’:
/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7/tools/tiff2pdf.c:4402:6: internal compiler error: in add_loop_constraints, at graphite-sese-to-poly.c:931
 void t2p_compose_pdf_page(T2P* t2p){
      ^~~~~~~~~~~~~~~~~~~~
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
make[1]: *** [Makefile:699: tiff2pdf.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/var/tmp/portage/media-libs/tiff-4.0.7-r3/work/tiff-4.0.7-abi_x86_64.amd64/tools'
make: *** [Makefile:546: all-recursive] Error 1
 * ERROR: media-libs/tiff-4.0.7-r3::gentoo failed (compile phase):
 *   emake failed

-----

Output of emerge --info '=media-libs/tiff-4.0.7-r3::gentoo':

Portage 2.3.5 (python 2.7.13-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-6.3.0, glibc-2.24-r1, 4.10.10-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.10.10-gentoo-x86_64-Intel-R-_Core-TM-_i5-6500_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    16372412 total,   2362380 free
KiB Swap:    2246652 total,   2246652 free
Timestamp of repository gentoo: Mon, 17 Apr 2017 00:15:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo, 3.5.3::gentoo
dev-util/ccache:          3.3.4::gentoo
dev-util/cmake:           3.8.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.24.2::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.ca.gentoo.org/gentoo-portage
    priority: -1000

andy
    location: /var/lib/layman/andy
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -ftree-loop-distribution"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/distfiles/ http://gentoo.mirrors.tds.net/gentoo http://mirrors.evowise.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--sort-common -Wl,--strip-debug -Wl,-flto=4"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext X \ a52 aac aalib acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg jpeg2k kde kipi kwallet lcms ldap libnotify lzma mad mng modules mp3 mp4 mpeg mplayer multilib mysql ncurses nls nptl offensive ogg opengl openmp openssl pam pango pcre pdf phonon plasma png policykit ppds python qml qt3support qt4 qt5 readline sdl seccomp session socks5 spell ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb videos vorbis widgets win32codecs wmf wxwidgets x264 xattr xcb xcomposite xine xinerama xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22 ruby23 ruby24" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

-----

When built without the Graphite flags (but every other flag staying the same), the build succeeds and the package installs as normal.  That is, it builds and installs successfully with these flags (as specified via /etc/portage/package.env):

CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -ftree-loop-distribution"
CXXFLAGS="${CFLAGS}"

-----

Just one Graphite flag triggers the "internal compiler error".  I separately tried each one of the following flags:  -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity -- any one of those, alone, will cause the problem.  Specifically, each of these fail:

CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -ftree-loop-distribution -floop-interchange"

CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -ftree-loop-distribution -floop-strip-mine"

CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -ftree-loop-distribution -floop-block"

CFLAGS="-march=native -O2 -fomit-frame-pointer -finline-functions -ftracer -fgcse-sm -fgcse-las -fipa-pta -fsched-pressure -pipe -flto=4 -ffat-lto-objects -fuse-linker-plugin -ftree-loop-distribution -fgraphite-identity"

-----

So, at this time, I know of only one workaround: disable Graphite features when building this specific package.  

I did not find this specific bug here at bugs.gentoo.org.  Also, I was unable to find this problem searching upstream's https://gcc.gnu.org/bugzilla/ bugtracker.  Among other terms I tried, a search for the term "add_loop_constraints" turned up nothing.  As per the request relayed by the emerge output, I'm filing a bug here.  I don't know if I should also file a bug upstream - please advise.
Comment 1 Peter Levine 2017-04-23 20:14:06 UTC
Pretty sure this is the bug.  Fixed upstream:

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71824
Comment 2 causality 2017-04-23 22:30:27 UTC
That does look like the same bug I encountered.  One part confused me a bit:  the last comment (Comment 18) for that GCC bug # 71824 says "Fixed" back on Feb 2, 2017.  Also, Comment 5 says "GCC 6.3 being released, adjusting target milestone".

This leads me to believe that that particular bug (# 71824) has already been fixed.  If that's the case, then I have found a similar-looking but different bug and should still file an upstream bug report.

What I'm not sure about is whether Gentoo's packaged GCC 6.3 would have included a fix from early February or not.  Please advise?
Comment 3 Peter Levine 2017-04-24 16:11:39 UTC
(In reply to causality from comment #2)
> That does look like the same bug I encountered.  One part confused me a bit:
> the last comment (Comment 18) for that GCC bug # 71824 says "Fixed" back on
> Feb 2, 2017.  Also, Comment 5 says "GCC 6.3 being released, adjusting target
> milestone".
> 
> This leads me to believe that that particular bug (# 71824) has already been
> fixed.  If that's the case, then I have found a similar-looking but
> different bug and should still file an upstream bug report.
> 
> What I'm not sure about is whether Gentoo's packaged GCC 6.3 would have
> included a fix from early February or not.  Please advise?

The target milestone is the release targeted to have the fix.  Because GCC-6.3 was released before the fix, they had to move the target to GCC-6.4.  Since the bug had since been marked "fixed" with "target milestone" at 6.4, it should be fixed in GCC-6.4.0.
Comment 4 Peter Levine 2017-05-07 04:15:34 UTC
Created attachment 471850 [details, diff]
55_all_gcc-6-pr71824.patch

Patch for gcc-6.3.0 based on https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=9f225861308a6a6eb618c9e5d2a898f2f5cd9d87 sans commitlog changes.  Tested on GCC-6.3.0.
Comment 5 Nikolaj Šujskij 2017-06-07 19:32:55 UTC
*** Bug 619476 has been marked as a duplicate of this bug. ***
Comment 6 Nikos Chantziaras 2017-07-19 22:50:06 UTC
Same here with upgrade from 5.4.0-r3 to 6.3.0. media-libs/tiff-4.0.8 fails with:

/var/tmp/portage/media-libs/tiff-4.0.8/work/tiff-4.0.8/tools/tiff2pdf.c: In function 't2p_compose_pdf_page':
/var/tmp/portage/media-libs/tiff-4.0.8/work/tiff-4.0.8/tools/tiff2pdf.c:4402:6: internal compiler error: in add_loop_constraints, at graphite-sese-to-poly.c:931
 void t2p_compose_pdf_page(T2P* t2p){
      ^~~~~~~~~~~~~~~~~~~~
Comment 7 Peter Levine 2017-07-20 02:02:41 UTC
A. This bug should be marked as "confirmed".
B. The "Assignee" should be changed to the "toolchain" project, as it is not a media-libs/tiff bug.
C. Maybe someone other than myself could apply the patch to gcc-6.3.0, build it, and try compiling media-libs/tiff-4.0.7-r3 with graphite flags to confirm it fixes the issue.
C. Then, hopefully 55_all_gcc-6-pr71824.patch could be included in the gcc-6.3.0 patchset.
Comment 8 Nikos Chantziaras 2017-07-20 02:08:22 UTC
(In reply to Peter Levine from comment #7)
> C. Maybe someone other than myself could apply the patch to gcc-6.3.0, build
> it, and try compiling media-libs/tiff-4.0.7-r3 with graphite flags to
> confirm it fixes the issue.

I just did that, and I can confirm the patch fixes the ICE. tiff builds correctly.
Comment 9 wolfwood 2017-08-01 04:45:19 UTC
I'm seeing this same issue using gcc 6.3.0 to compile groff with 
CFLAGS="-march=native -O3 -pipe -floop-interchange -ftree-loop-distribution -floop-strip-mine -floop-block -ftree-vectorize"

the 55_all_gcc-6-pr71824.patch patch resolved the issue compiling groff and seems to have allowed 'emerge -av @system' to continue.


Portage 2.3.6 (python 2.7.13-final-0, default/linux/amd64/13.0, gcc-6.3.0, glibc-2.24-r3, 4.11.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.11.12-gentoo-x86_64-Intel-R-_Core-TM-_i5-5300U_CPU_@_2.30GHz-with-gentoo-2.4.1
KiB Mem:     8059140 total,   2942484 free
KiB Swap:   16251900 total,  16251900 free
Timestamp of repository gentoo: Sun, 30 Jul 2017 20:00:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.2::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo
dev-util/cmake:           3.9.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.64::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15.1::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            4.9.3::dlang, 5.4.0-r3::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

local
    location: /usr/local/portage
    masters: gentoo

dlang
    location: /var/lib/layman/dlang
    sync-type: laymansync
    sync-uri: https://github.com/gentoo/dlang.git
    masters: gentoo
    priority: 50

rust
    location: /var/lib/layman/rust
    sync-type: laymansync
    sync-uri: git://github.com/gentoo/gentoo-rust.git
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    sync-type: laymansync
    sync-uri: git://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O3 -pipe -floop-interchange -ftree-loop-distribution -floop-strip-mine -floop-block -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O3 -pipe -floop-interchange -ftree-loop-distribution -floop-strip-mine -floop-block -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" --jobs --load-average=3.95"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 5 -l 3.95"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl aes amd64 avx avx2 berkdb bzip2 cli cracklib crypt cxx dbus dri dri3 egl evdev f16c fma3 fortran gdbm gtkstyle iconv inotify ipv6 libkms mmx mmxext modules multilib ncurses nls nptl opengl openmp pam pcre popcnt readline seccomp session sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 tcpd unicode xattr xcb xft xlib-xcb zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="BPF X86" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 pypy pypy3" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/groff-1.22.3::gentoo was built with the following:
USE="X -examples" ABI_X86="(64)"
Comment 10 wolfwood 2017-08-02 04:33:38 UTC
unfortunately I hit a different upstream graphite bug in gcc 6.3 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80069 when compiling libav

/var/tmp/portage/media-video/libav-12.1/work/libav-12.1/libavcodec/nellymoser.c:116:6: internal compiler error: in outer_projection_mupa, at graphite-sese-to-poly.c:1176
 void ff_nelly_get_sample_bits(const float *buf, int *bits)
      ^~~~~~~~~~~~~~~~~~~~~~~~
Comment 11 Nikos Chantziaras 2017-08-04 09:06:29 UTC
GCC 6.4.0 is now in the tree, which appears to fix the tiff and libav ICEs.
Comment 12 Andreas K. Hüttel gentoo-dev 2017-09-26 18:25:26 UTC
(In reply to Nikos Chantziaras from comment #11)
> GCC 6.4.0 is now in the tree, which appears to fix the tiff and libav ICEs.

Awesome.