Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 61311 - net-print/turboprint (new ebuild)
Summary: net-print/turboprint (new ebuild)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
: 63120 (view as bug list)
Depends on:
Blocks: printer-drivers
  Show dependency tree
Reported: 2004-08-22 16:59 UTC by Nicholas Vantrease
Modified: 2020-11-09 16:00 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---

turboprint-1.90.ebuild (turboprint-1.90.ebuild,1.05 KB, text/plain)
2004-10-09 15:18 UTC, Andreas Proschofsky (RETIRED)
turboprint-1.91.2.ebuild (turboprint-1.91.2.ebuild,2.55 KB, text/plain)
2005-03-30 18:46 UTC, James Le Cuirot
post-install.patch (post-install.patch,845 bytes, patch)
2005-03-30 18:46 UTC, James Le Cuirot
Details | Diff
ebuild for turboprint 1.92 (turboprint-1.92.ebuild,1.76 KB, text/plain)
2005-04-24 11:44 UTC, Sven
patch needed by turboprint 1.92 ebuild (setup.patch,1.95 KB, patch)
2005-04-24 11:45 UTC, Sven
Details | Diff
patch needed by turboprint 1.92 ebuild (setup.patch,2.75 KB, patch)
2005-04-24 12:46 UTC, Sven
Details | Diff
ebuild for turboprint 1.92 (turboprint-1.92.ebuild,1.75 KB, text/plain)
2005-04-24 12:46 UTC, Sven
turboprint-1.93.ebuild (turboprint-1.93.ebuild,1.48 KB, text/plain)
2005-09-30 16:32 UTC, Guillaume Castagnino
install-post-root-r2.patch (install-post-root-r2.patch,9.37 KB, patch)
2005-09-30 16:33 UTC, Guillaume Castagnino
Details | Diff
install-static-root.patch (install-static-root.patch,357 bytes, patch)
2005-09-30 16:33 UTC, Guillaume Castagnino
Details | Diff
turboprint-1.94.ebuild (turboprint-1.94.ebuild,1.47 KB, text/plain)
2006-01-13 01:07 UTC, Guillaume Castagnino
net-print/turboprint-2.17-r2 - ebuild: Version bump (turboprint-2.17-r2.ebuild,21.51 KB, text/plain)
2010-12-18 11:00 UTC, Zorzo Luca
net-print/turboprint - ebuild, patches and manifest: Version bump (turboprint-2.17-r2.tar.gz,7.28 KB, application/octet-stream)
2010-12-18 11:01 UTC, Zorzo Luca
net-print/turboprint - license (Turboprint,3.15 KB, text/plain)
2010-12-18 11:03 UTC, Zorzo Luca

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Vantrease 2004-08-22 16:59:08 UTC
After going through the Printing Howto, and having no luck, I went to the forums, and found nothing relevant. I finally got Gentoo to *recognize* my printer, but it would never actually print. (Sometimes it would just feed paper through the printer). The EPSON provided drivers would not compile, even the rpm'd files wouldn't work properly (I tried those thinking they were already compiled), but that didn't work either. 

I've resorted to using a program called TurboPrint ( to handle the driver side of CUPS, and it works wonderfully, but it would be nice to see appropriate drivers inside the CUPS installation, or available as an Ebuild.

Reproducible: Always
Steps to Reproduce:
1.Kernel options: USB & USB Printing built-in, reboot, check for identification/recognition of printer.
2./etc/init.d/cups start
3.browse to localhost:631, set up printer using either of the listed Epson Photo drivers 

Actual Results:  
When set up with the "old" Epson Photo drivers, CUPS sees my printer but
anything sent to it is completely ignored. So, it says "Test Page sent...." and
acts like it was sent, but the printer does nothing, as if nothing had been sent. 

When set up with the "new" Epson Photo drivers, CUPS sees my printer, and will
send to it. However, somehow, it tells the printer to just keep feeding paper
through (I left it running, it went through 500 pages, and didn't put a drop of
ink on any of them).

Expected Results:  
A driver that supports Epson as an ebuild would be the best, however, if that's
not possible, a TurboPrint Ebuild would be the best bet (as i know it works
perfectly with the Epson Stylus Photo R200, and supposedly with others).

MSI 865 PE Neo2 Motherboard, Intel 865PE (Piix4 / ICH5r)
P4 3.0 GHz 800 MHz FSB, 2 GB Dual Channel DDR PC3200 RAM
120GB SATA HDD (ntfs storage), 80GB IDE HDD (linux partitions), 9GB SCSI Ultra
160 on an Adaptec 29160LP card (XP drive), CD-RW, DVD-RW. 
USB Devices: Logitech wireless keyboard/mouse receiver, Epson Printer (Stylus
Photo R200). 

TurboPrint solved this for me, but it is not "open source." There is a "free"
version and a "paid for" version.
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2004-09-22 05:43:20 UTC
if you can post an ebuild for the free version i'll add it
Comment 2 Heinrich Wendel (RETIRED) gentoo-dev 2004-09-22 05:48:11 UTC
*** Bug 63120 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Proschofsky (RETIRED) gentoo-dev 2004-10-09 15:18:10 UTC
Here is a quick shot at an initial ebuild from me, works for me, but checking it would be good, especially at the deps and the license, which is incorrect now, the right one is here:
Comment 4 Andreas Proschofsky (RETIRED) gentoo-dev 2004-10-09 15:18:41 UTC
Created attachment 41436 [details]
Comment 5 James Le Cuirot gentoo-dev 2005-03-30 18:45:30 UTC
I've spent a long time putting together this new and improved ebuild for version 1.91-2. It uses the tar.gz version instead of the RPM version and correctly installs the CUPS or the LPR version depending on whether the cups USE flag is set or not.

The part of the installation script that deals with the KDE/GNOME shortcuts is skipped because this could probably be handled better within the ebuild itself. I haven't written any extra code since I don't know anything about making KDE/GNOME shortcuts and Gentoo seems to leave this up to the user for many packages anyway.

There's two snags with this ebuild though. The first is that it can't be emerged in sandbox mode because of one particular test file it creates. This occurs within a binary setup program so this cannot really be fixed. I've included a warning if the user tries to install it with sandbox mode turned on.

The other is that there is a fair amount of post-installation. I included a pkg_postrm() function to clean up the mess after the package has been unmerged but the problem is that this gets run even when the package is simply being upgraded and consequently breaks the upgraded version. This behaviour strikes me as odd. I would only expect pkg_postrm() to get run when the package is actually being removed altogether. This needs to be fixed before the ebuild can be added to Portage. Any ideas?

I tested this with the Canon SmartBase MP390 and it works fine.
Comment 6 James Le Cuirot gentoo-dev 2005-03-30 18:46:05 UTC
Created attachment 54903 [details]
Comment 7 James Le Cuirot gentoo-dev 2005-03-30 18:46:24 UTC
Created attachment 54904 [details, diff]
Comment 8 Sven 2005-04-24 09:21:50 UTC
The setup of turboprint has to be fixed. It doesn't provide any equivalent to "make DESTDIR=". The setup is a shell-script, so we can patch it if the menufacturer doesn't want to provide any support. Just use "./setup --nogui", and the shell-script is used instead of bin/xtpsetup.

I will contact the manufacturer soon, and i'll ask if he can provide us with a "--destdir" parameter fot the setup.
Comment 9 James Le Cuirot gentoo-dev 2005-04-24 09:37:42 UTC
The work I've done on it already achieves this to a certain extent. The script already supports an "RPM Build Root" so I took advantage of that. It's just a case of clearing up the post-installation phase.
Comment 10 Sven 2005-04-24 11:43:31 UTC
here's a new ebuild that executes lib/install-post earlier, but it still suffers from the "bug", that tpsetup tried to open /etc/turboprint/tp_testfile.tst, which has to be fixed by the manufacturer. We can't, since tpsetup is a binary (as James said already).
Comment 11 Sven 2005-04-24 11:44:22 UTC
Created attachment 57109 [details]
ebuild for turboprint 1.92
Comment 12 Sven 2005-04-24 11:45:09 UTC
Created attachment 57110 [details, diff]
patch needed by turboprint 1.92 ebuild
Comment 13 Sven 2005-04-24 12:44:52 UTC
OK, i give up.

My ebuild still has the following hickups:
- "tpsetup --writeppdfiles" does not work without files in /etc/turboprint and therefor it cannot be executed before the package is installed
- perhaps "tpsetup --writeppdfiles" will also search for tpp files in /usr/share instead of /var/tmp/portage/image/... which is wrong too

I asked the manufacturer for support. The whole installation-process is not "Gentoo-compatible", and executing "tpsetup --writeppdfiles" from pkg_postinst() seems horribly wrong to me.

Does anybody know, what "tpsetup --update" is for?
Comment 14 Sven 2005-04-24 12:46:08 UTC
Created attachment 57117 [details, diff]
patch needed by turboprint 1.92 ebuild
Comment 15 Sven 2005-04-24 12:46:33 UTC
Created attachment 57118 [details]
ebuild for turboprint 1.92
Comment 16 James Le Cuirot gentoo-dev 2005-04-24 13:12:58 UTC
Yeah that's why I kept the post-installation as a post-installation. I can't remember what it does though. Been too long.
Comment 17 Sven 2005-04-24 13:22:05 UTC
"tpsetup --writeppdfiles" generated creates a ton of ppd files, that are used by CUPS as far as i understand it.

The comment for "tpsetup --update" was "call setup to update LPD config files / CUPS PPD files", but why should we update the ppd files we just generated? this doesn't make any sense to me. Perhaps it does make sense for LPD based systems, but i have none to test it.

IMHO the ppd files should be installed/uninstalled by portage, and therefor we cannot move their generation to pkg_postinst().
Comment 18 James Le Cuirot gentoo-dev 2005-04-24 16:37:38 UTC
I'm pretty sure there was a reason for the "update" but I can't remember right now. I'm extremely busy so I haven't got time to look into it but perhaps you could try copying the files you need to run tpsetup into ${D}? Though I suppose tpsetup will still want to use the real files. Hmmm. Is there any kind of chroot technique for situations like this?
Comment 19 Sven 2005-07-01 20:41:19 UTC
Well, 1.92-2 is out. I'll ask the manufacturer for the promised gentoo-support.
Perhaps we're lucky, and they already finished the work ...

I don't think that there is any kind of chroot-technique, thought the sandbox
could "overlay" the real filesystem with the image - couldn't it? But i guess
that's nothing we will see soon.
Comment 20 Luis Medinas (RETIRED) gentoo-dev 2005-08-03 20:03:22 UTC
*** Bug 87029 has been marked as a duplicate of this bug. ***
Comment 21 Luis Medinas (RETIRED) gentoo-dev 2005-08-03 20:23:50 UTC
Sorry my eyes are very heavy. true/turbo print
Comment 22 Guillaume Castagnino 2005-09-30 16:32:25 UTC
Created attachment 69590 [details]

I have done this for 1.93 (ported for my work on 1.92(-2))

My first approach was to use LD_PRELOAD to avoid sandbox breakage by creating
and removing an empty file in /etc/turboprint (don't know wy they do that),
overriding fopen and unlink. But it was quite ugly, so I now use
SANDBOX_ON=0/1, since this sandbox breakage seems to me not dangerous (only
creating and removing a file wich is not usefull for anyone).

follow the 2 needed patches
Comment 23 Guillaume Castagnino 2005-09-30 16:33:03 UTC
Created attachment 69591 [details, diff]
Comment 24 Guillaume Castagnino 2005-09-30 16:33:20 UTC
Created attachment 69592 [details, diff]
Comment 25 James Le Cuirot gentoo-dev 2005-09-30 16:42:38 UTC
That seems to be the easiest way around it. I didn't know it was possible to 
turn sandbox on and off like that. It's probably something the devs try to keep 
quiet. (-;
Comment 26 Michael Gaber 2006-01-13 00:58:32 UTC
also there is a version 1.94 available
Comment 27 Guillaume Castagnino 2006-01-13 01:06:07 UTC
You can find my ebuild up to date here :

Same approach as I explained before (61311#c22).
Comment 28 Guillaume Castagnino 2006-01-13 01:07:35 UTC
Created attachment 76972 [details]
Comment 29 Michael Gaber 2006-01-13 01:10:52 UTC
works fine for me! please add it to portage!
Comment 30 Stefan Schweizer (RETIRED) gentoo-dev 2006-01-14 11:39:50 UTC
seems fine to me, get a developer to add it or become developer yourself and maintain some more ebuilds.
Comment 31 Guillaume Castagnino 2006-12-19 14:59:45 UTC
ebuild for 1.95 version available here as usual : (or from my overlay gently added to layman list : layman -a xwing)

This is a enhanced version that does not use the install-post script anymore (that needed to be over-patched to work in the sandbox instead of the real root) but do the post-install manually in src_install function. This solution needs less patching and is easyier to maintain.
As usual, there is some sandbox breakage during the tpsetup execution. Now I use the addpredict function to work around this problem instead of SANDBOX_ON=0/1 (more elegant solution).

I only provide cups and x86 support in the ebuild since I cannot test lpr and/or amd64 (I do not have any of them).

Any enhancement and feedback is welcomed ;)
Comment 32 Rainer Keller 2008-03-30 17:24:46 UTC
I have used the ebuild for turboprint 1.96.3 and tried it for version 1.96.4.
During this I encountered some sandbox violations. The steps "Generating ppd files" and "Simlinking ppd files" tried to access some files at /dev.

My solution is adding:
addread /dev/random
addpredict /dev

I first tried it with addpredict only but the setup will stop because it cannot gather random numers. So read access would be necessary.
Comment 33 Guillaume Castagnino 2008-04-02 05:23:47 UTC

This sound strange to me : sandbox should allready allow to read in /dev.
Moreover, the "Simlinking ppd files" step is only a "dosym" loop (native eutils eclass function)

Whats your emerge --info ? especially, do you have unusual FEATURES ?
Comment 34 Rainer Keller 2008-04-02 14:49:40 UTC
> Whats your emerge --info ? especially, do you have unusual FEATURES ?

Portage (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo x86_64)
System uname: 2.6.24-gentoo x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Timestamp of tree: Sun, 30 Mar 2008 10:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -pipe -march=athlon64 -mfpmath=sse -mmmx -msse -msse2 -m3dnow -ggdb"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon64 -mfpmath=sse -mmmx -msse -msse2 -m3dnow -ggdb"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
LINGUAS="de us"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acpi alsa amd64 bash-completion berkdb cdr cli cracklib crypt cups dri dvd dvdr fam gdbm gif gpm iconv isdnlog jpeg kde kdehiddenvisibility lirc mad midi mp3 mudflap ncurses nls nptl nptlonly ogg openmp pam pcre png ppds pppd qt qt4 quicktime readline reflection session smartcard spl ssl tcpd tiff unicode usb vorbis xinerama xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de us" LIRC_DEVICES="serial" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 35 zhcnmccmzhdvfevooo 2008-07-29 16:15:02 UTC
is there any chance, to get an ebuild for turboprint v2 in the overlay?
For my new printer I would need this version.
Comment 36 Guillaume Castagnino 2008-07-29 19:54:47 UTC
(In reply to comment #35)
> is there any chance, to get an ebuild for turboprint v2 in the overlay?
> For my new printer I would need this version.


Currently, not from me : my license is not valid for the v2 (bought some years ago, so not eligible to v2), and my printers are supported by the v1.

So I have not seriously studied the v2 install process. After a quick look, it seems to be more difficult to avoid a graphic install (and without any questions to the user) than with the v1, but I did not study deeper the installer, so I could miss the point.

Comment 37 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2009-01-13 20:51:38 UTC
(this is an automated message based on filtering criteria that matched this bug)

Hello, The Gentoo Team would like to firstly thank you for your ebuild
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to commit to and all users can have ebuilds reviewed by Gentoo devs for entry into the overlay.
So, the sunrise team is suggesting that you look into this and submit your
ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. We anticipate a large number of requests in a short time. 

On behalf of the Gentoo Sunrise Team,

Comment 38 Zorzo Luca 2010-12-18 11:00:13 UTC
Created attachment 257487 [details]
net-print/turboprint-2.17-r2 - ebuild: Version bump

Ebuild for Turboprint V2. Please try and modify it so we can have a good ebuild, I'm not an experienced ebuild-writer.

Language management should be improved, as well the printer selection.
Comment 39 Zorzo Luca 2010-12-18 11:01:48 UTC
Created attachment 257489 [details]
net-print/turboprint - ebuild, patches and manifest: Version bump
Comment 40 Zorzo Luca 2010-12-18 11:03:51 UTC
Created attachment 257490 [details]
net-print/turboprint - license
Comment 41 Andreas K. Hüttel archtester gentoo-dev 2012-02-19 22:55:05 UTC
Is anyone still interested in this?
Comment 42 Rainer Keller 2012-02-20 20:54:23 UTC
(In reply to comment #41)
> Is anyone still interested in this?
I picked one of the attached ebuilds some years ago. Currently I keep it in my own portage overlay.
There was no activity on this bug for some years now. If noone is able/willing to spend effort on this it perhaps make sense to close this bug.
Comment 43 Andreas K. Hüttel archtester gentoo-dev 2012-05-26 18:47:54 UTC
(In reply to comment #42)
> (In reply to comment #41)
> > Is anyone still interested in this?
> I picked one of the attached ebuilds some years ago. Currently I keep it in
> my own portage overlay.
> There was no activity on this bug for some years now. If noone is
> able/willing to spend effort on this it perhaps make sense to close this bug.

Are you interested in maintaning this driver directly yourself in the new 
printer-drivers overlay [1]?

If yes, just send me via personal e-mail at the
following data, so we can give you git push access to the overlay:
* the user name that you'd like to have
* your public ssh key [2], so we can give you git push access to the overlay
* your e-mail address
* and your full name
If you have a gnupg key, you should sign that e-mail [3].

Just a few rules:
* Initially, the ebuilds should work for you, and not break
  anything else.
* You enter yourself as maintainer in metadata.xml (together with
  the printing herd), and are then automatically cc'ed in bug reports 
  on bugzilla.
* We will guide you towards improving the ebuilds over the next 
  months so they follow the rules and qa guidelines of the Gentoo 
  main portage tree. In particular this means also using a recent
  EAPI (3 or perferably 4), and fixing repoman warnings [4].
  Don't worry, we'll help you with that.
* I hope this is never going to happen, but... ebuilds that "work but 
  go against the guidelines" and do not see any improvement will be 
  removed again one year after initial addition.

There are many ways to get help.
* You can directly ask me by personal e-mail (my time is limited, 
  but I'll try), 
* you can ask on freenode, channel #gentoo-dev-help,
* you can read the documentation (ebuild howto [5], devmanual [6]), 
* ...

Comment 44 No Name 2013-09-19 23:07:02 UTC
Turboprint 2.30 is out. Any progress here after all the years?

I want to make my canon mp810 working. Anyone has an ebuild for this in local overlay which can be posted here? would be nice.