Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 606406 - media-gfx/blender-2.79-r1 stable request
Summary: media-gfx/blender-2.79-r1 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jonathan Scruggs (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: CVE-2017-9110, CVE-2017-9111, CVE-2017-9112, CVE-2017-9113, CVE-2017-9114, CVE-2017-9115, CVE-2017-9116 639804 639806 642270 686456
Blocks: python-3.5-stable
  Show dependency tree
 
Reported: 2017-01-18 15:08 UTC by Pacho Ramos
Modified: 2019-06-06 21:23 UTC (History)
7 users (show)

See Also:
Package list:
media-gfx/blender-2.79-r1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2017-01-18 15:08:53 UTC
Needed for python 3.5 stabilization
Comment 1 Jonathan Scruggs (RETIRED) gentoo-dev 2017-01-23 23:53:10 UTC
(In reply to Pacho Ramos from comment #0)
> Needed for python 3.5 stabilization

I'm confused. How is this needed for Python 3.5 stabilisation? This depends on 3.5. Unfortunately upstream removed ed support for lower versions.

Cheers
Comment 2 Pacho Ramos gentoo-dev 2017-01-31 21:07:31 UTC
We need it because the current stable is not compatible with python-3.5 :/

But this needing to go at the same time is not an issue... we can simply CC arches at the same time when python-3.5 is finally ready and all ok :)
Comment 3 Jonathan Scruggs (RETIRED) gentoo-dev 2017-01-31 21:57:17 UTC
Ah. I understand. However, 2.78a depends on CUDA v8 which isn't stable. 2.78 depends on any CUDA version, so it should be made stable then. That's why I keep 2.78 in portage even though 2.78a is out. Upstream made it CUDA v8 only. 

Cheers.
Comment 4 Jonathan Scruggs (RETIRED) gentoo-dev 2017-03-02 12:25:54 UTC
2.78 has a better chance of being stabilized because it doesn't depend on CUDA v8. I'd rather have a shorter time getting this stabilized so that 2.72 can be removed.
Comment 5 Matt Turner gentoo-dev 2017-06-16 17:36:06 UTC
Can we stabilize something? This is blocking python-3.5 from going stable.
Comment 6 Pacho Ramos gentoo-dev 2017-06-17 09:45:20 UTC
(In reply to Matt Turner from comment #5)
> Can we stabilize something? This is blocking python-3.5 from going stable.

They will need to go together, once python-3.5 is going to be stabilized, this will be able to
Comment 7 anonymous 2017-09-07 08:47:53 UTC
I can't install >=blender-2.78-r1 because it requires request-2.18.2-r1 which requires <idna-2.6

emerge says `<idna-2.6` cannot be satisfied.
Comment 8 Adrian 2017-09-14 15:45:39 UTC
(In reply to crocket from comment #7)
> emerge says `<idna-2.6` cannot be satisfied.
I received this blocker also when trying to install blender-2.78c, but was able to resolve it by ensuring that I properly unmasked and enabled python3_5. I have documented a detailed recipe that may help you on the Gentoo wiki page for blender. See https://wiki.gentoo.org/wiki/Blender#Python_3.5
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-11-28 16:45:49 UTC
Python 3.5 is now the default, so you may want to actually finally allow this. However, given the quantity of problems with this package, it might be a better idea to drop it to ~arch altogether.
Comment 10 Stabilization helper bot gentoo-dev 2017-12-04 14:02:37 UTC
An automated check of this bug failed - repoman reported dependency errors (73 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
Comment 11 Stabilization helper bot gentoo-dev 2017-12-04 19:02:11 UTC
An automated check of this bug failed - repoman reported dependency errors (73 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
> dependency.bad media-gfx/blender/blender-2.78a-r1.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['>=media-libs/ilmbase-2.2.0:=', '>=media-libs/openexr-2.2.0:=', 'media-libs/opensubdiv[cuda=]', 'media-gfx/openvdb[python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_single_target_python3_5(+),abi3-compat(+),openvdb-compression(+)]']
Comment 12 Stabilization helper bot gentoo-dev 2017-12-25 19:01:09 UTC
An automated check of this bug failed - repoman reported dependency errors (73 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
Comment 13 Stabilization helper bot gentoo-dev 2017-12-26 10:00:50 UTC
An automated check of this bug failed - repoman reported dependency errors (73 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
Comment 14 Stabilization helper bot gentoo-dev 2017-12-26 11:00:49 UTC
An automated check of this bug failed - repoman reported dependency errors (73 lines truncated): 

> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
> dependency.bad media-gfx/blender/blender-2.79.ebuild: DEPEND: amd64(default/linux/amd64/13.0/desktop) ['>=media-libs/openimageio-1.7.0', 'media-libs/osl:=']
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-03-18 14:35:00 UTC
CC arches back when depends o will be fully handled
Comment 16 Larry the Git Cow gentoo-dev 2018-03-30 16:04:31 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=100b06703d4d894bc45a047f95003abbc679e9b5

commit 100b06703d4d894bc45a047f95003abbc679e9b5
Author:     Aaron Bauman <bman@gentoo.org>
AuthorDate: 2018-03-30 16:00:45 +0000
Commit:     Aaron Bauman <bman@gentoo.org>
CommitDate: 2018-03-30 16:04:12 +0000

    media-gfx/blender: amd64 stable
    
    Bug: https://bugs.gentoo.org/606406
    Package-Manager: Portage-2.3.26, Repoman-2.3.7

 media-gfx/blender/blender-2.79-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 17 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2018-07-14 16:43:13 UTC
@Maintainers ping

We have pending security issues wrt blender-2.72b, if you can assist with x86 stabilization would be great.

Thank you,
Comment 18 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-21 15:24:53 UTC
FYI, I'll probably remove 2.72* along with python3.4 today.
Comment 19 Andreas Sturmlechner gentoo-dev 2019-04-21 18:30:32 UTC
Wouldn't this bug be obsolete considering bug 606406?
Comment 20 Larry the Git Cow gentoo-dev 2019-06-06 21:21:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fce2bae92fc72196e82a236c2ae3d290910c23b6

commit fce2bae92fc72196e82a236c2ae3d290910c23b6
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-06-06 21:20:33 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-06-06 21:21:44 +0000

    media-gfx/blender: Drop 2.79 and 2.79-r1
    
    No one explained why keep it, so drop it.
    
    Closes: https://bugs.gentoo.org/606406
    Closes: https://bugs.gentoo.org/659498
    Package-Manager: Portage-2.3.67, Repoman-2.3.14
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 media-gfx/blender/Manifest                         |   1 -
 media-gfx/blender/blender-2.79-r1.ebuild           | 290 ---------------------
 media-gfx/blender/blender-2.79.ebuild              | 287 --------------------
 .../blender-2.79-fix-build-with-OSL-1.9.x.patch    |  26 --
 4 files changed, 604 deletions(-)