Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 604442 - sys-block/open-iscsi-2.0.874 : bnx2.c:(.text+<snip>): undefined reference to `minor'
Summary: sys-block/open-iscsi-2.0.874 : bnx2.c:(.text+<snip>): undefined reference to ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 628506 (view as bug list)
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-01-02 21:44 UTC by Toralf Förster
Modified: 2018-01-02 14:54 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,184.21 KB, text/plain)
2017-01-02 21:44 UTC, Toralf Förster
Details
environment (environment,120.09 KB, text/plain)
2017-01-02 21:44 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.61 KB, application/x-bzip)
2017-01-02 21:44 UTC, Toralf Förster
Details
sys-block:open-iscsi-2.0.874:20170102-205843.log (sys-block:open-iscsi-2.0.874:20170102-205843.log,48.11 KB, text/plain)
2017-01-02 21:44 UTC, Toralf Förster
Details
Patch to apply upstream fix (sysmacros.patch,745 bytes, patch)
2017-12-29 20:30 UTC, Brandon Penglase
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-01-02 21:44:07 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -I../../src/uip -I../../src/apps/brcm-iscsi -I../../src/apps/dhcpc -I../../src/unix/libs -I../../../include -I../../../usr -DBYTE_ORDER=LITTLE -O2 -pipe -march=native -Wall -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wall -rdynamic -Wl,-O1 -Wl,--as-needed -o iscsiuio iscsiuio-build_date.o iscsiuio-main.o iscsiuio-clock-arch.o iscsiuio-logger.o iscsiuio-nic.o iscsiuio-nic_id.o iscsiuio-nic_vlan.o iscsiuio-nic_nl.o iscsiuio-nic_utils.o iscsiuio-packet.o iscsiuio-iscsid_ipc.o iscsiuio-ping.o  -ldl -lpthread ../../src/uip/lib_iscsi_uip.a ../../src/apps/dhcpc/lib_apps_dhcpc.a ../../src/apps/brcm-iscsi/lib_apps_brcm_iscsi.a ../../src/unix/libs/lib_iscsiuio_hw_cnic.a
../../src/unix/libs/lib_iscsiuio_hw_cnic.a(bnx2.o): In function `bnx2_open.part.6':
bnx2.c:(.text+0xd38): undefined reference to `minor'
../../src/unix/libs/lib_iscsiuio_hw_cnic.a(bnx2x.o): In function `bnx2x_open.part.14':

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named 13.0-systemd-unstable_20161230-115459) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  from make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp bzip2 cdb cgroups contrib egl evdev -gcj glamor gnuplot gpg haptic hdf5 ibus javascript libinput mpg123 odbc openssl opus pcre16 plasma policykit pulseaudio -qt5 sqlite3 system-ffmpeg tcpd traceroute ufed utils wayland webstart xml xscreensaver -xvfb"

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.1

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
  -----------------------------------------------------------------



$ cat emerge-info.txt
Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/systemd, gcc-5.4.0, glibc-2.24, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   1679604 free
KiB Swap:   67108860 total,  67091632 free
Timestamp of repository gentoo: Mon, 02 Jan 2017 20:22:47 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0-r2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/i2pd/certificates"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cdb cgroups cli contrib convert cracklib crypt cxx dri egl evdev exif ffmpeg fortran gd gdbm glamor gnuplot gpg haptic hdf5 ibus iconv icu ipv6 javascript libinput messages mikmod mmx mmxext mod modules mpg123 multilib ncurses nls nptl odbc openmp openssl opus pam pax_kernel pcre pcre16 plasma policykit pulseaudio python qml readline seccomp session sqlite3 sse sse2 ssl ssp svc system-ffmpeg systemd tcpd traceroute truetype udev ufed unicode utils video wayland webstart xattr xml xscreensaver xtpax zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="cy fa he or rw" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2017-01-02 21:44:14 UTC
Created attachment 458424 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2017-01-02 21:44:17 UTC
Created attachment 458426 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2017-01-02 21:44:20 UTC
Created attachment 458428 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2017-01-02 21:44:23 UTC
Created attachment 458430 [details]
sys-block:open-iscsi-2.0.874:20170102-205843.log
Comment 6 Adam Stylinski 2017-09-14 15:20:12 UTC
(In reply to Simone Gotti from comment #5)
> This looks fixes upstream in these commits:
> 
> https://github.com/open-iscsi/open-iscsi/commit/
> 5cecffad475735d672305fcf0163fd79d3b93ff9
> https://github.com/open-iscsi/open-iscsi/commit/
> fea8d2e506a40f80f9062aa9c98f403518782f27

So, bump to 2.0.875?
Comment 7 Eddie Chapman 2017-09-29 17:51:18 UTC
FWIW sys-block/open-iscsi-2.0.873-r1 builds fine for me with sys-libs/glibc-2.25-r5 & sys-devel/binutils-2.29.1 on x86_64
Comment 8 Andreas K. Hüttel gentoo-dev 2017-10-20 20:27:27 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 9 Brandon Penglase 2017-12-29 20:30:17 UTC
Created attachment 511992 [details, diff]
Patch to apply upstream fix

I ran into this while rebuilding the world for the 17.0 profile change. Attached is the patch I came up with from the links from Simone Gotti in Comment 5.

It at least built for me.
Comment 10 Adam Stylinski 2017-12-29 20:56:31 UTC
I had (In reply to Brandon Penglase from comment #9)
> Created attachment 511992 [details, diff] [details, diff]
> Patch to apply upstream fix
> 
> I ran into this while rebuilding the world for the 17.0 profile change.
> Attached is the patch I came up with from the links from Simone Gotti in
> Comment 5.
> 
> It at least built for me.

It's been a while since I've touched it in my local overlay, but I believe I also needed to patch it to work with GCC 6 (not just the glibc changes) and glibc 2.26.  There was a fix in their repo for some bitwise operator somewhere (and a number of other things).
Comment 11 Thomas Capricelli 2018-01-02 13:10:54 UTC
Hit by this today. My glibc is 2.26-r3
Comment 12 Thomas Deutschmann gentoo-dev Security 2018-01-02 13:53:55 UTC
*** Bug 628506 has been marked as a duplicate of this bug. ***
Comment 13 Larry the Git Cow gentoo-dev 2018-01-02 14:54:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9278a10daad10aaedff21f2ca630570a1c0dacbe

commit 9278a10daad10aaedff21f2ca630570a1c0dacbe
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2018-01-02 14:01:56 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2018-01-02 14:53:57 +0000

    sys-block/open-iscsi: Rev bump to fix multiple issues
    
    Ebuild changes:
    ===============
    - Patch: Include sysmacros.h. [Bug 604442]
    
    - Install systemd service. [Bug 640598]
    
    - Remove deprecated iscsidev.sh udev rule in favor of udev native iSCSI
      support which is available since udev-143. [Bug 633574]
    
    - Drop "slp" USE flag. [Bug 558366]
    
    Bug: https://bugs.gentoo.org/558366
    Closes: https://bugs.gentoo.org/604442
    Closes: https://bugs.gentoo.org/640598
    Closes: https://bugs.gentoo.org/633574
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 .../open-iscsi-2.0.874-include-sysmacros.patch     |  20 ++++
 sys-block/open-iscsi/open-iscsi-2.0.874-r2.ebuild  | 122 +++++++++++++++++++++
 2 files changed, 142 insertions(+)