Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 603444 (CVE-2016-10028) - <app-emulation/qemu-2.8.0: display: virtio-gpu-3d: OOB access while reading virgl capabilities (CVE-2016-10028)
Summary: <app-emulation/qemu-2.8.0: display: virtio-gpu-3d: OOB access while reading v...
Status: RESOLVED FIXED
Alias: CVE-2016-10028
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://lists.gnu.org/archive/html/qe...
Whiteboard: B3 [glsa cve]
Keywords:
Depends on: CVE-2016-9907 604010
Blocks:
  Show dependency tree
 
Reported: 2016-12-22 09:09 UTC by Agostino Sarubbo
Modified: 2017-02-16 18:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2016-12-22 09:09:43 UTC
From ${URL} :

Quick Emulator(Qemu) built with the Virtio GPU Device emulator support is
vulnerable to an out of bounds memory access issue. It could occur while
processing 'VIRTIO_GPU_CMD_GET_CAPSET' command.

A guest user/process could use this flaw to crash the Qemu process instance
on a host, resulting in DoS.

Upstream patch:
---------------
  -> https://lists.gnu.org/archive/html/qemu-devel/2016-12/msg01903.html

Reference:
----------
  -> http://www.openwall.com/lists/oss-security/2016/12/20/1


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 SpanKY gentoo-dev 2016-12-29 19:59:33 UTC
i've added it to our 2.8.0 ebuild
Comment 2 Thomas Deutschmann gentoo-dev Security 2017-01-01 19:00:08 UTC
Stabilization will be happen as part of bug 601824.
Comment 3 Thomas Deutschmann gentoo-dev Security 2017-01-21 22:34:59 UTC
New GLSA request filed.
Comment 4 Thomas Deutschmann gentoo-dev Security 2017-01-23 01:08:46 UTC
No ACE/RCE, downgraded to B3.
Comment 5 GLSAMaker/CVETool Bot gentoo-dev 2017-01-23 03:14:29 UTC
This issue was resolved and addressed in
 GLSA 201701-49 at https://security.gentoo.org/glsa/201701-49
by GLSA coordinator Aaron Bauman (b-man).
Comment 6 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2017-01-23 03:15:15 UTC
Re-opened for cleanup.
Comment 7 Matthias Maier gentoo-dev 2017-02-13 05:34:36 UTC
Vulnerable versions removed, please close.


commit cd0007ee8270ccd2773604782ddcc4b67fa3a103
Author: Matthias Maier <tamiko@gentoo.org>
Date:   Sun Feb 12 22:08:18 2017 -0600

    app-emulation/qemu: drop old versions 2.7.0, 2.7.1
    
    Package-Manager: Portage-2.3.3, Repoman-2.3.1
Comment 8 Thomas Deutschmann gentoo-dev Security 2017-02-16 18:30:24 UTC
All done, repository is clean.