Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 601938 - dev-db/mysql-workbench-6.3.4-r2 : /.../lf_popover.cpp:383:13: error: no match for ‘operator!=’ (operand types are ‘Glib::RefPtr<Gdk::Window>’ and ‘int’)
Summary: dev-db/mysql-workbench-6.3.4-r2 : /.../lf_popover.cpp:383:13: error: no match...
Status: RESOLVED DUPLICATE of bug 600376
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-07 20:57 UTC by Toralf Förster
Modified: 2017-05-22 04:53 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-db:mysql-workbench-6.3.4-r2:20161207-202022.log (dev-db:mysql-workbench-6.3.4-r2:20161207-202022.log,486.95 KB, text/plain)
2016-12-07 20:57 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,346.38 KB, text/plain)
2016-12-07 20:57 UTC, Toralf Förster
Details
environment (environment,185.08 KB, text/plain)
2016-12-07 20:57 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.05 KB, application/x-bzip2)
2016-12-07 20:57 UTC, Toralf Förster
Details
gtk.patch from Debian (gtk.patch,975 bytes, patch)
2017-01-01 23:29 UTC, Rodrigo Saboya
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-12-07 20:57:43 UTC
/var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/work/mysql-workbench-community-6.3.4-src/library/forms/gtk/src/lf_popover.cpp: In member function ‘void {anonymous}::PopoverWidget::show_popover(int, int, mforms::StartPosition)’:
/var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/work/mysql-workbench-community-6.3.4-src/library/forms/gtk/src/lf_popover.cpp:383:13: error: no match for ‘operator!=’ (operand types are ‘Glib::RefPtr<Gdk::Window>’ and ‘int’)
     if (wnd != 0)
             ^
/var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/work/mysql-workbench-community-6.3.4-src/library/forms/gtk/src/lf_popover.cpp:383:13: note: candidate: operator!=(int, int) <built-in>


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-systemd-unstable_20161129-180925) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp aqua btrfs cgroups csc cups dbus -ecc -evdev fluidsynth introspection -isag javascript libkms -lvm -mikmod ncurses nscd odbc qml sdl spice sqlite sqlite3 theora timidity truetype vala vlc webgl xetex xslt"
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.0
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   python3.5 (fallback)
  [4]   pypy (fallback)
  [5]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby20 (with Rubygems) *
  [2]   ruby21 (with Rubygems)
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------

Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.23-r3, 4.8.12-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.12-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,  42175820 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Wed, 07 Dec 2016 20:17:40 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 3

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /etc/omega.conf /etc/stunnel/stunnel.conf /opt/openfire/resources/security/ /usr/lib64/fax /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding btrfs bzip2 cairo cdda cdr cgroups cli cracklib crypt csc cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fluidsynth fortran gdbm gif glamor gpm gtk iconv introspection ipv6 javascript jpeg kde kipi lcms ldap libkms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl nscd odbc ogg opengl openmp pam pango pax_kernel pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell spice sqlite sqlite3 sse sse2 ssl ssp startup-notification svg systemd tcpd theora tiff timidity truetype udev udisks unicode upower usb vala vlc vorbis webgl widgets wxwidgets x264 xattr xcb xcomposite xetex xinerama xml xscreensaver xslt xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="lt" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-07 20:57:46 UTC
Created attachment 455462 [details]
dev-db:mysql-workbench-6.3.4-r2:20161207-202022.log
Comment 2 Toralf Förster gentoo-dev 2016-12-07 20:57:49 UTC
Created attachment 455464 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-12-07 20:57:51 UTC
Created attachment 455466 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-12-07 20:57:54 UTC
Created attachment 455468 [details]
etc.portage.tbz2
Comment 5 Rodrigo Saboya 2017-01-01 23:29:19 UTC
Created attachment 458264 [details, diff]
gtk.patch from Debian

Found this patch here:
https://anonscm.debian.org/cgit/collab-maint/mysql-workbench.git/tree/debian/patches/gtk.patch?id=2d345f93378bad2d5a1d769e7318db529059c833

Applied cleanly to 6.3.4-r1 (current stable). The error was no longer present but I still wasn't able to compile due to another issue, will open another issue for that.
Comment 6 Jan Vansteenkiste 2017-01-26 20:08:39 UTC
Putting the patch in /etc/portage/patches/dev-db/mysql-workbench-6.3.4-r2 fixed compilation for me and mysql-workbench also seems to work
Comment 7 Markus Rathgeb 2017-03-22 08:25:08 UTC
> Putting the patch in /etc/portage/patches/dev-db/mysql-workbench-6.3.4-r2 fixed compilation for me

For me, too
Comment 8 Alessandro Capogna 2017-04-03 21:44:24 UTC
that patch works for me too (both compilation and run) with dev-db/mysql-workbench-6.3.4-r1 on amd64
Comment 9 Tomáš Mózes 2017-04-20 08:53:17 UTC
I can too confirm the patch working on ~amd64 with version 6.3.4-r2.
Comment 10 Robert G. Siebeck 2017-05-10 15:23:06 UTC
The patch works also for me. I prepared an ebuild which applies this patch:
https://github.com/robert7k/gentoo-overlay/blob/master/dev-db/mysql-workbench/mysql-workbench-6.3.4-r3.ebuild
Comment 11 Tomáš Mózes 2017-05-11 05:46:28 UTC
https://github.com/gentoo/gentoo/pull/4601
Comment 12 Hans de Graaff gentoo-dev 2017-05-21 06:15:29 UTC

*** This bug has been marked as a duplicate of bug 600376 ***
Comment 13 Joerg Schaible 2017-05-21 10:24:15 UTC
Please reopen. Issue 600376 describes a different problem. It is mysql-workbench-6.3.4-r2 that is failing. Therefore this problem is obviously not solved with a patch for -r2!
Comment 14 Tomáš Mózes 2017-05-22 04:53:29 UTC
(In reply to Joerg Schaible from comment #13)
> Please reopen. Issue 600376 describes a different problem. It is
> mysql-workbench-6.3.4-r2 that is failing. Therefore this problem is
> obviously not solved with a patch for -r2!

Just looking at the patch, it's the same as Rodrigo mentioned here, so this really should be fixed :)