Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 600376 - dev-db/mysql-workbench fails to build against current x11-libs/gtk+ on ~amd64
Summary: dev-db/mysql-workbench fails to build against current x11-libs/gtk+ on ~amd64
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
: 601938 619524 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-21 06:58 UTC by Marcin Kowalski
Modified: 2017-05-25 05:47 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kowalski 2016-11-21 06:58:52 UTC
the bug i encountered is discussed here.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839356

The patch that resolves the issue is at 

https://anonscm.debian.org/cgit/collab-maint/mysql-workbench.git/plain/debian/patches/gtk.patch?id=2d345f9
Comment 1 Samat 2016-12-09 05:30:02 UTC
I can confirm this bug:

cat /var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/temp/build.log |grep error:

/var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/work/mysql-workbench-community-6.3.4-src/library/forms/gtk/src/lf_popover.cpp:383:13: error: no match for ‘operator!=’ (operand types are ‘Glib::RefPtr<Gdk::Window>’ and ‘int’)

/var/tmp/portage/dev-db/mysql-workbench-6.3.4-r2/work/mysql-workbench-community-6.3.4-src/library/forms/gtk/src/lf_popover.cpp:399:13: error: no match for ‘operator!=’ (operand types are ‘Glib::RefPtr<Gdk::Display>’ and ‘int’)
Comment 2 lee 2017-04-24 19:31:13 UTC
I can also confirm it; there are numerous errors about variables having data types for which no conversion operator is known but required to compare them.
Comment 3 Hans de Graaff gentoo-dev 2017-05-21 06:15:29 UTC
*** Bug 601938 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Graaff gentoo-dev 2017-05-21 08:18:32 UTC
This patch has now been applied to mysql-workbench-5.3.4-r2
Comment 5 Hans de Graaff gentoo-dev 2017-05-25 05:47:15 UTC
*** Bug 619524 has been marked as a duplicate of this bug. ***