Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 589130 - app-portage/gentoolkit-0.3.2-r1: revdep-rebuild: Could not save cache: unicode argument expected, got 'str'
Summary: app-portage/gentoolkit-0.3.2-r1: revdep-rebuild: Could not save cache: unicod...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
: 589128 590172 596542 603114 603446 604730 606856 608854 (view as bug list)
Depends on:
Blocks: 346443
  Show dependency tree
 
Reported: 2016-07-19 07:22 UTC by Dennis Schridde
Modified: 2021-01-04 19:38 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2016-07-19 07:22:58 UTC
Whenever I run `revdep-rebuild`, I see the following error message:

```
# revdep-rebuild -- --ask
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
        Could not save cache: unicode argument expected, got 'str'
 * Checking dynamic linking consistency
[…]

```

```
# grep '^[^#]' /etc/python-exec/python-exec.conf
pypy
python3.4
```

```
# q file -v /usr/lib/python-exec/pypy/revdep-rebuild
app-portage/gentoolkit-0.3.2 (/usr/lib/python-exec/pypy/revdep-rebuild)
```

```
# emerge --info gentoolkit pypy
Portage 2.3.0 (python 2.7.10-final-42, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.23-r2, 4.6.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.6.3-gentoo-x86_64-AMD_A10-7800_Radeon_R7,_12_Compute_Cores_4C+8G-with-gentoo-2.2
KiB Mem:    15381052 total,   2249168 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 18 Jul 2016 14:15:01 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25 p1.2) 2.25
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.6.0::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2-r1::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /var/cache/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000

kde
    location: /var/lib/layman/kde
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/kde.git
    masters: gentoo
    priority: 50

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    sync-type: laymansync
    sync-uri: git://github.com/cschwan/sage-on-gentoo.git
    masters: gentoo science
    priority: 50

science
    location: /var/lib/layman/science
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/sci.git
    masters: gentoo
    priority: 50

local
    location: /var/cache/portage/local
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=bdver3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=bdver3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacplus aacs acl acpi alsa amd64 appindicator archive audit avahi bash-completion bdplus berkdb bluetooth bluray branding bzip2 cairo caps cdda cddb cdio cdr celt cjk cli colord conntrack cracklib crypt cups cxx d3d9 dbus declarative dirac dri dts dvb dvd dvdr egl emboss encode exif fam fax ffmpeg firefox flac fontconfig fortran fribidi gdbm geoclue geolocation gif git glamor gles gmp gpm gstreamer gtk gtk3 harfbuzz ibus iconv ipv6 jpeg jpeg2k kde kipi ladspa latex lcms ldap libinput libnotify libproxy libsecret lua_target_lua5-2 lv2 lz4 lzma lzo mad mercurial mmx mmxext mng modemmanager modplug modules mp3 mp4 mpeg mplayer mtp multilib multitarget mysql ncurses netlink networkmanager nls nptl ogg openal opencl openexr opengl openmax openmp opus pam pango pcap pch pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline rtmp samba scanner schroedinger sctp sdl seccomp semantic-desktop session speex spell sse sse2 ssl startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upnp upnp-av upower usb v4l v4l2 vaapi vdpau vorbis vpx wavpack wayland webp widgets x264 x265 xattr xcb xcomposite xinerama xml xrandr xscreensaver xv xvid xz zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="stage words flow sheets gemini" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" DRACUT_MODULES="btrfs caps systemd" ELIBC="glibc" ENLIGHTENMENT_MODULES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="coreboot efi-64 pc" INPUT_DEVICES="joystick" KERNEL="linux" L10N="de en en-GB ar fa tr ja ko zh zh-CN zh-TW" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en en_GB ar fa tr" LIRC_DEVICES="devinput" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4 pypy pypy3" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-portage/gentoolkit-0.3.2::gentoo was built with the following:
USE="" ABI_X86="64" PYTHON_TARGETS="pypy python2_7 python3_4 -python3_3 -python3_5"

dev-python/pypy-5.3.1::gentoo was built with the following:
USE="bzip2 gdbm jit ncurses shadowstack sqlite -doc -libressl -low-memory (-sandbox) -test -tk" ABI_X86="64" CPU_FLAGS_X86="-sse2"
```
Comment 1 Dennis Schridde 2016-07-19 07:23:40 UTC
*** Bug 589128 has been marked as a duplicate of this bug. ***
Comment 2 Paul Varner (RETIRED) gentoo-dev 2016-07-19 14:42:41 UTC
I found the issue as well on one of my systems.  I'm working on fixing it.

This does not impact the ability of revdep-rebuild to check the system, it just will not be able to use a cache to speed things up, when the bug is occurring.
Comment 3 Paul Varner (RETIRED) gentoo-dev 2016-08-04 16:37:47 UTC
*** Bug 590172 has been marked as a duplicate of this bug. ***
Comment 4 Paul Varner (RETIRED) gentoo-dev 2016-08-15 21:09:00 UTC
I have pushed the fix for this to git.  The fix can be tested with gentoolkit-9999

https://gitweb.gentoo.org/proj/gentoolkit.git/commit/?id=c8783ccb225cddb43052463c092e8edc091c371a
Comment 5 Paul Varner (RETIRED) gentoo-dev 2016-10-18 17:53:01 UTC
*** Bug 596542 has been marked as a duplicate of this bug. ***
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2016-12-19 16:41:00 UTC
*** Bug 603114 has been marked as a duplicate of this bug. ***
Comment 7 Mikhail Kurinnoi 2016-12-31 17:41:55 UTC
I faced with this issue too.
I tested this patch with current stable version 0.3.2-r1
Patch fix the issue for me.
Comment 8 Brian Dolbec gentoo-dev 2017-01-01 17:56:53 UTC
This fix has been released in gentoolkit-0.3.3
Comment 9 Zac Medico gentoo-dev 2017-01-01 21:27:21 UTC
*** Bug 603446 has been marked as a duplicate of this bug. ***
Comment 10 Brian Dolbec gentoo-dev 2017-01-11 17:26:35 UTC
*** Bug 604730 has been marked as a duplicate of this bug. ***
Comment 11 Paul Varner (RETIRED) gentoo-dev 2017-01-24 20:37:22 UTC
*** Bug 606856 has been marked as a duplicate of this bug. ***
Comment 12 Paul Varner (RETIRED) gentoo-dev 2017-01-24 20:41:10 UTC
Reopening for visibility until >=app-portage/gentoolkit-0.3.3 is stabilized. We are still getting bug reports from stable users on gentoolkit-0.3.2-r1 and the default bugzilla search doesn't search resolved bugs.
Comment 13 Paul Varner (RETIRED) gentoo-dev 2017-02-10 16:04:18 UTC
*** Bug 608854 has been marked as a duplicate of this bug. ***
Comment 14 Conrad Kostecki gentoo-dev 2021-01-04 19:38:51 UTC
Fixed, so closing.