Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 578022 - sys-boot/grub-0.97-r16 fails to compile
Summary: sys-boot/grub-0.97-r16 fails to compile
Status: RESOLVED DUPLICATE of bug 550132
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-22 20:10 UTC by Michal Plichta
Modified: 2016-03-22 21:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge -info (emerge.info,6.00 KB, text/plain)
2016-03-22 20:10 UTC, Michal Plichta
Details
full build log (grub.log,138.98 KB, application/octet-stream)
2016-03-22 20:10 UTC, Michal Plichta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Plichta 2016-03-22 20:10:03 UTC
Created attachment 428782 [details]
emerge -info

is bug 568222 related???

(...)
Making all in stage1
make[2]: Entering directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/stage1'
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..   -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -march=i686 -fno-builtin -nostdinc -DHAVE_CONFIG_H -I. -I..  -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -g -c -o stage1.o stage1.S
x86_64-pc-linux-gnu-gcc -m32  -g -nostdlib -Wl,-N,-Ttext,7C00 -Wl,-O1 -Wl,--as-needed -Wl,--build-id=none -o stage1.exec stage1.o  
objcopy -O binary stage1.exec stage1
make[2]: Leaving directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/stage1'
Making all in lib
make[2]: Entering directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/lib'
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..   -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -I../stage2 -I../stage1 -g -c -o getopt.o getopt.c
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..   -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -I../stage2 -I../stage1 -g -c -o getopt1.o getopt1.c
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..   -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -I../stage2 -I../stage1 -g -c -o device.o device.c
rm -f libcommon.a
ar cru libcommon.a getopt.o getopt1.o device.o 
ranlib libcommon.a
make[2]: Leaving directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/lib'
Making all in grub
make[2]: Entering directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/grub'
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..  -DGRUB_UTIL=1 -DFSYS_EXT2FS=1 -DFSYS_FAT=1 -DFSYS_FFS=1 -DFSYS_ISO9660=1 -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_UFS2=1 -DFSYS_VSTAFS=1 -DFSYS_XFS=1 -DUSE_MD5_PASSWORDS=1 -DSUPPORT_HERCULES=1 -DSUPPORT_SERIAL=1  -I../stage2 -I../stage1 -I../lib -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -g -c -o main.o main.c
x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I..  -DGRUB_UTIL=1 -DFSYS_EXT2FS=1 -DFSYS_FAT=1 -DFSYS_FFS=1 -DFSYS_ISO9660=1 -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_UFS2=1 -DFSYS_VSTAFS=1 -DFSYS_XFS=1 -DUSE_MD5_PASSWORDS=1 -DSUPPORT_HERCULES=1 -DSUPPORT_SERIAL=1  -I../stage2 -I../stage1 -I../lib -Wall -Wmissing-prototypes -Wunused -Wshadow -Wpointer-arith -falign-jumps=1 -falign-loops=1 -falign-functions=1 -Wundef -O0 -fno-strict-aliasing -g -c -o asmstub.o asmstub.c
asmstub.c: In function `console_putchar':
asmstub.c:655:11: warning: variable `y' set but not used [-Wunused-but-set-variable]
    int x, y;
           ^
x86_64-pc-linux-gnu-gcc -m32 -O0 -fno-strict-aliasing -g  -Wl,-O1 -Wl,--as-needed -Wl,--build-id=none -o grub main.o asmstub.o ../stage2/libgrub.a  ../lib/libcommon.a -lncurses 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: asmstub.o: undefined reference to symbol 'COLS'
/usr/lib32/libtinfo.so.5: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:366: recipe for target 'grub' failed
make[2]: *** [grub] Error 1
make[2]: Leaving directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97/grub'
Makefile:382: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-boot/grub-0.97-r16/work/grub-0.97'
Makefile:323: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: sys-boot/grub-0.97-r16::gentoo failed (compile phase):
 *   emake failed
Comment 1 Michal Plichta 2016-03-22 20:10:48 UTC
Created attachment 428784 [details]
full build log
Comment 2 Ian Stakenvicius gentoo-dev 2016-03-22 20:18:19 UTC
Can you try grub-0.97-r17 and see if that works?  I've been awaiting positive feedback for months to determine if I can push it to stable.
Comment 3 Ian Stakenvicius gentoo-dev 2016-03-22 20:30:56 UTC
I'm expecting this to be a duplicate of bug 564890
Comment 4 Michal Plichta 2016-03-22 20:57:05 UTC
-r17 compiled fine!
I can't reboot (if new grub is really wotking) since libreoffice, chromium and icedtea are emerging, but I can assume it should be fine.
Comment 5 Ian Stakenvicius gentoo-dev 2016-03-22 21:35:41 UTC

*** This bug has been marked as a duplicate of bug 550132 ***